Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-19-02, 02:06 PM   #1
jaywalker
Guest
 
Posts: n/a
Default NVidia with TV OUT and Matrox Card

Hello,

I'm trying to get the following to work:
One CRT connected to a Matrox G550 AGP
One CRT connected to a NVidia GeForce4 MX 420 PCI
TV connected to the NVidia card.

I'd like to use the two CRTs as one Xinerama-like desktop and have one copy (of the part of the desktop displayed on the NVidia card) on the TV or, as an alternative, have the possibility to copy a windows content to the TV (or even Overlays like in Windows?).

I can set up each card seperately not using Xinerama and having only one CRT as my Desktop and either of the cards works, the NVidia even with TV out showing a copy of the desktop.
But as soon as I enable both video cards with or without Xinerama, X won't start up and the NVidia card will get locked showing vertical white stripes on black background (on both the CRT and the TV) while the Matrox card shows a black screen. One can't revert NVidias card to a normal state, even killing the X-Server or switching to the console doesn't help, although the system does not hang.
The X server doesn't produce any error message in its log files. When setting up two MetaModes for the NVidia card, one using just the CRT, the second enabling TV, X starts correctly. When I then try to switch the Mode to turn TV out on, X crashes with fatal error: "caught signal 11" (no other error messages appear), but before it's crashing, one can (for half a second or so) see the correct image on both the CRT and the TV.

I'm using Debian 3.0 on a Elitegroup K7S5A with Duron 800 processor with kernel 2.4.19. I'm using the newest drivers available from matrox and nvidia. I tried X 4.1 and 4.2 and I replaced the matrox card by another NVidia to make sure the failure is NVidia-related and is not some strange bug in the matrox drivers, which it isn't.

Would be great if anyone could help...
  Reply With Quote
Old 01-02-03, 07:25 AM   #2
spokkie
Registered User
 
Join Date: Jan 2003
Posts: 2
Default

i want to do the same thing you are trying and i wonder if you managed to get both cards working?? If you did i can purchase a nvidia card with TV out
spokkie is offline   Reply With Quote
Old 01-15-03, 11:03 AM   #3
nico_from_tlse
Registered User
 
Join Date: Jan 2003
Posts: 1
Default

I have the same problem, so I someone have the solution, please tell me too...
nico_from_tlse is offline   Reply With Quote
Old 01-16-03, 03:04 AM   #4
spokkie
Registered User
 
Join Date: Jan 2003
Posts: 2
Default NVidia driver

It is possible to use both cards with the XFree86 nv driver But this driver does not support (TV out as far as I know). Both video cards work with this driver. This is with a standard XFree86 installation from the ports dir.

To use the TV out i think i have to use the NVidia driver.
With the newly released nvidia driver which supports TV-out the error line i get when starting X is: Failed to initialize the NVdriver kernel module...............

Did have this error line???? And of course (how) did you fix it...

Greetings and have a good day
spokkie is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.