Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-18-06, 04:38 AM   #1
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default 6600GT TDH Low Peformance ...

Hi,

I get a LeadTek 6600GT TDH (AGP) and low performance :
~4200 FPS with glxgears (3500 with a 9600 Pro !)
~30 FPS with doom3, Medium Quality, 1280*1024

Strange visual bugs on FarCry and bad perf (Windows).


My hardware :
AMD64 3200+ Core Venice
2*512 PC3200 Corsair Cas 2
ABIT AV8
Antec SmartPower 2.0 400W

System :
Debian 32bit
Gentoo 64bit
Windows 32bit (only tested with farcry and Trackmania)

I Tried to use another Power Supply only for the card, to unplug DVD and DVDRw to plug only the card, etc ..

I'm using last drivers.

Some infos:
Code:
root@xfpc:/proc/driver/nvidia# cat registry
VideoMemoryTypeOverride: 1
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
SoftEDIDs: 1
Mobile: 4294967295
ResmanDebugLevel: 4294967295
FlatPanelMode: 0
DevicesConnected: 0
VideoEnhancement: 0
RmLogonRC: 1
VbiosFromROM: 0
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
RemapLimit: 0
UseCPA: 4294967295
DetectPrimaryVga: 0

root@xfpc:/proc/driver/nvidia# cat version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module  1.0-8178  Wed Dec 14 16:22:51 PST 2005
GCC version:  version gcc 4.0.3 20060104 (prerelease) (Debian 4.0.2-6)

root@xfpc:/proc/driver/nvidia/agp# cat card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0xff000e1b:0x00000000

root@xfpc:/proc/driver/nvidia/agp# cat host-bridge
Host Bridge:     PCI device 1106:0282
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0x1f000a1b:0x00000000

root@xfpc:/proc/driver/nvidia/agp# cat status
Status:          Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem

root@xfpc:/proc/driver/nvidia/cards# cat 0
Model:           GeForce 6600 GT
IRQ:             19
Video BIOS:      05.43.02.69.68
Card Type:       AGP

dmesg
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:01:00.0 to 64
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-8178  Wed Dec 14 16:22:51 PST 2005
Any Idea ?
Iksaif is offline   Reply With Quote
Old 01-18-06, 05:02 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6600GT TDH Low Peformance ...

root@xfpc:/proc/driver/nvidia/agp# cat status
Status: Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem


Lack of AGP support likely explains your performance problems. Please generate and attach an nvidia-bug-report.log file.
zander is offline   Reply With Quote
Old 01-18-06, 05:38 AM   #3
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: 6600GT TDH Low Peformance ...

I tried with :
nvagp + NvAgp 1 (no dmesg error, but /proc/driver/nvidia/agp/status tell me the same thing ...)
agpgart + amd64_agp + NvAgp 2
agpgart + amd64_agp + via_agp + NvAgp 2
agpgart + via_agp + NvAgp 2

and there is always this problem.

Link: http://xf.iksaif.net/nvidia/nvidia-bug-report.log

Last edited by Iksaif; 01-18-06 at 09:40 AM.
Iksaif is offline   Reply With Quote
Old 01-18-06, 05:49 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6600GT TDH Low Peformance ...

Please use agpgart/amd64_agp (NvAGP doesn't support the Via K8T800Pro), leave the "NvAGP" option unset, start X with the NVIDIA driver and generate an updated bug report file.
zander is offline   Reply With Quote
Old 01-18-06, 09:41 AM   #5
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: 6600GT TDH Low Peformance ...

With agpgart/amd64_agp on Gentoo 64Bit
NvAGP set to 2 ..
http://xf.iksaif.net/nvidia/nvidia-bug-report2.log
I will try without NvAGP after a bios upgrade
Iksaif is offline   Reply With Quote
Old 01-18-06, 10:08 AM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 6600GT TDH Low Peformance ...

nvidia: module license 'NVIDIA' taints kernel.
GSI 19 sharing vector 0xC1 and IRQ 19
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:01:00.0 to 64
NVRM: loading NVIDIA Linux x86_64 NVIDIA Kernel Module 1.0-8178 Wed Dec 14 16:58:07 PST 2005
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected AGP bridge 0
agpgart: AGP aperture is 128M @ 0xf0000000
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 19
NVRM: loading NVIDIA Linux x86_64 NVIDIA Kernel Module 1.0-8178 Wed Dec 14 16:58:07 PST 2005
NVRM: unable to initialize the Linux AGPGART driver, please
NVRM: verify you configured your kernel to include support
NVRM: for AGPGART (either statically linked, or as a kernel
NVRM: module). Please also make sure you selected support
NVRM: for your AGP chipset.
NVRM:
NVRM: note that as of Linux 2.6 AGPGART, all chipset/vendor
NVRM: drivers are split into independent modules; make sure
NVRM: the correct one is loaded for your chipset.


This shows that AGPGART was loaded and detected a bridge, but that it failed to initialize. This doesn't look like an NVIDIA Linux graphics driver bug, unless it only happened after the NVIDIA kernel module was reloaded.
zander is offline   Reply With Quote
Old 01-18-06, 11:13 AM   #7
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: 6600GT TDH Low Peformance ...

so.. maybe a bios upgrade wil help ^^, but my windows is dead, and awflash don't work on my freedos livecd :'(
I will try to find a floppy
Iksaif is offline   Reply With Quote
Old 01-18-06, 12:46 PM   #8
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: 6600GT TDH Low Peformance ...

bios update, nothing new (a line in mtrr maybe ?) :'(
http://xf.iksaif.net/nvidia/nvidia-bug-report.log

I tried to test with the program in this post :
http://lkml.org/lkml/2005/12/31/88
the result is :

Code:
version: 0.101
bridge id: 0x2821106
agp_mode: 0x1f000a1b
aper_base: 0xf0000000
aper_size: 128
pg_total: 208896
pg_system: 208896
pg_used: 0
entry.key : 0
entry.key : 1
Allocated 8 megs of GART memory
MemoryBenchmark: 37 mb/s
MemoryBenchmark: 38 mb/s
MemoryBenchmark: 38 mb/s
Average speed: 37 mb/s
Testing data integrity (1st pass): passed on first pass.
Testing data integrity (2nd pass): passed on second pass.

dmesg | tail 
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: testgart tried to set rate=x12. Setting to AGP3 x8 mode.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
if it can help ...

Last edited by Iksaif; 01-18-06 at 02:09 PM.
Iksaif is offline   Reply With Quote

Old 01-18-06, 02:27 PM   #9
Iksaif
Registered User
 
Join Date: Jan 2006
Posts: 6
Default Re: 6600GT TDH Low Peformance ...

I only needed to recompile the kernel module, sry
Iksaif is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM

All times are GMT -5. The time now is 11:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.