Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-03, 06:32 AM   #1
TheCrasher
Registered User
 
Join Date: Jan 2003
Location: Germany
Posts: 4
Send a message via ICQ to TheCrasher
Angry Winex does not work!

Hi Guy's!

I nearly tried everything now.. so here is my Problem:

I had an Voodoo II and winex worked perfectly with this GK (As far as you can call it ever perfektly ). After I buyed an GeForce 4, I installed the new offical driver from Nvidia (NVIDIA_GLX-1.0-4191.i386.rpm & NVIDIA_kernel-1.0-4191.suse73.i386.rpm). Then I configured my X Server. The HWA works perfectly. glxinfo shows: direct rendering: Yes
and in glxgears I get Framerates above 6000 .... but when I try to run a 3D Game in winex it crashes with an error! Non 3D Programs and Games work well. So it is an Problem with the 3D Support! Here is my System configuration:

CPU: Intel Celeron 1,4 GHz
Board: Gigabyte GA-6OXM7E
GPU: Nvidia GeForce 4 Ti 4400
Ram: 512 MB SD (Infineon)
OS: SuSE Linux 7.320020228
wine: Version 20020228
winex: 2.2
Nvidia Driver: Version 1.0-4191

Can anybody help me to solve this Problem PLEASE??? Thank you!


TheCrasher
__________________
No one lives for ever
TheCrasher is offline   Reply With Quote
Old 01-12-03, 06:51 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

"it crashes with an error"

And what, pray tell, would this error be?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-14-03, 03:47 AM   #3
TheCrasher
Registered User
 
Join Date: Jan 2003
Location: Germany
Posts: 4
Send a message via ICQ to TheCrasher
Default Sorry!

Sorry... wasn't on my own PC when I wrote the Thread! But the Message donesn't says anything at all I think... it just says: "Unhandled exception! Starting Debugger.....". The Debugger in winex does not work on my PC.. but I'll add the DBG Messages from Wine in the Post (.TXT File!)
If this tells anyone anything... please tell me! So far I've not solved my Problem... Tanks for any help!!!


TheCrasher
Attached Files
File Type: txt error.txt (50.5 KB, 245 views)
__________________
No one lives for ever
TheCrasher is offline   Reply With Quote
Old 01-14-03, 06:40 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Do you get any useful info from a backtrace? (bt at the wine-dbg> prompt)
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-17-03, 03:04 PM   #5
TheCrasher
Registered User
 
Join Date: Jan 2003
Location: Germany
Posts: 4
Send a message via ICQ to TheCrasher
Default Here comes my Backtrace

Ok.. I've done a Backtrace (with wine! Not with winex... but both won't work with 3D support) and attached it to this Post (error.txt) I've tried Jedi Knight II and Half-Life. The Videomode in JKII is marked as "?" because I don't get even in the Menu ( But I think this is of none interest.. because I've tried Half-Life with every available mode. None worked). If this tells you anything bwkaz I would be glad for help (if you know a solution for my problem of corse).


TheCrasher
Attached Files
File Type: txt error.txt (1.1 KB, 170 views)
__________________
No one lives for ever
TheCrasher is offline   Reply With Quote
Old 01-17-03, 07:18 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hmm... unfortunately, it seems your libc was compiled without debug information in it. Which means a good bit of that backtrace (both the current function name and the first function name in the call stack) are nonsense.

Notice:

Code:
Backtrace:
=>0 0x402e0421 (NTDLL.DLL.memcpy+0x2cec1 in libc.so.6) (ebp=4d762f04)                                  
  1 0x4070bf6c (TIME_MMSysTimeThread+0x6c(arg=0x40395054) [time.c:159] in libwinmm.so) (ebp=4d762f20)  
  2 0x400f199d (THREAD_Start+0x5d [thread.c:257] in libntdll.so) (ebp=4d762f38)                        
  3 0x400f0c88 (SYSDEPS_StartThread+0x38(teb=0x4d773000) [sysdeps.c:168] in libntdll.so) (ebp=4d762ff4)
  4 0x4030fbaa (NTDLL.DLL.memcpy+0x5c64a in libc.so.6) (ebp=00000000)
how the offsets (the ones in bold) from the start of NTDLL.DLL.memcpy are so huge compared to the others? That's a good indication that the affected address isn't actually in that function (memcpy, in this case). The filename (libc.so.6) is right., though.

Have you ever compiled glibc before? Reconfiguring it with --enable-debug would probably give better information, but the process is a little complicated.

I must admit, I haven't seen anything like this in wine or winex before, but hopefully it won't be too hard to track down. Hopefully...

Does SuSE 7.3 use gcc 3.2? If so, I can compile glibc and post the libc.so.6 file for you, with --enable-debug, but if not, I'm fairly sure that won't work.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-17-03, 07:47 PM   #7
thecombatwombat
Registered User
 
Join Date: Dec 2002
Posts: 3
Default

First of all, what game are you trying to run? I can say from experience (as a subscriber of better than a year), many games don't work in winex.

Even when 3d support is working, many (or most) games don't work at all with winex, check the games database at transgaming.com, see if others have gotten your game to work.

Have you posted to the transgaming forums? They're far more likely to be able to help than here. Be sure to include what game you're running and what version of winex you're using, in addition to what you've provided here. If you're using cvs and are running a supported game, I suggest subscribing and getting an official package.

Output from regular wine probably won't be much help, unless you're planning on running it in regular wine, especially if it *must* be the 3d, winehq's wine and transgaming's wine are quite different, particularly when it comes to 3d support.
thecombatwombat is offline   Reply With Quote
Old 01-17-03, 11:21 PM   #8
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Half-life is the game he said. It works fine for me, and gives him an unhandled exception in the same place as Jedi Knight 2 does, so it seems the problems are game-independent.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote

Old 01-18-03, 12:29 AM   #9
thecombatwombat
Registered User
 
Join Date: Dec 2002
Posts: 3
Default

hmmm, ok then, I had problems similar to this a while ago, there were two issues.

Since you're running SuSE 7.3, I'd guess your glibc is < 2.3, but if not, you'll need winex 2.2.1 to have any hope of working. I got an error about ntdll (which I noticed in your backtrace) but maybe the glibc compile options mentioned by bwkaz keeps you from getting an error?)

That was one of my problems, the other had to do with my 3d drivers, if you've made any changes to your installed packages recently, (between now and when you could get games to work in winex, if ever) then I recommend you remove those rpms, and install the tarballs fresh. I'd apt-gotten mesa/glut, installed from tarball, then apt-get upgraded over some apparently critical files for the nvidia drivers, strangely glxgears etc was working though.

I can also suggest the most often suggested fix on the TG forums. Have you tried running as a fresh user/with a fresh winex config? Like windows (only worse), wine/winex can get awfully messed up as you install programs/new dlls. Maybe a clean slate is all you need?
thecombatwombat is offline   Reply With Quote
Old 01-18-03, 06:46 AM   #10
TheCrasher
Registered User
 
Join Date: Jan 2003
Location: Germany
Posts: 4
Send a message via ICQ to TheCrasher
Default Hmmm..

Hi guys.. first of all I want to tank you for your tips. My main Problem is that it works fine with my old Graphicard (Voodoo 3 3000)! With the same wine & winex version and config. The only thing I've changed (at the beginning) was the GC Driver! I think I'm going to reinstall the whole System and try it again then. I know this is poor, but this is the last Idea I have (I have I few other Problems, that will also be solved with the reinstall.. I think).
I'm telling you what happend!... Until later


TheCrasher
__________________
No one lives for ever
TheCrasher is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiseat X with two cards: used to work, now segfaulting Artefact2 NVIDIA Linux 10 06-26-12 05:22 PM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 02:38 PM
WineX or nVidia troubles? arise NVIDIA Linux 2 10-10-02 07:57 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 08:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.