Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-25-06, 01:18 PM   #1
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default "You passed an undefined mode number"

Right in the beginning I get that "error" and then I can choose some modes, rows and colums, 80x30, 80x60 etc.
It happens though, that I don't get it, and then, my bash resolution is set at 1280x1024 on my LCD.
Which is good and I want it like that without the error.

If I mess upp my xorg.conf file (im using suse 10) the xserver won't start and I won't get that error, but my resolution in bash will still be 1280x1024. btw what's the command for starting XServer?

Also, why is my refresh rate at 75 when I've set it at 60? I'm using DVI on my fx5200 with the latest driver from nvidia homepage.
windwos is offline   Reply With Quote
Old 01-25-06, 01:34 PM   #2
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: "You passed an undefined mode number"

Use gtf or another application to create the necessary modeline for your xorg.conf configuration to run at the resolution and refresh rate you want to use
evilghost is offline   Reply With Quote
Old 01-26-06, 03:48 AM   #3
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default Re: "You passed an undefined mode number"

Quote:
Originally Posted by evilghost
Use gtf or another application to create the necessary modeline for your xorg.conf configuration to run at the resolution and refresh rate you want to use
Doesn't work.
Well first I changed to "gtf 1280 1024 60", and then I restarted, and the error didn't come. Restarted again and it didn't come so I thought it helped. Although it was still 75hz, but I had a nice resolution in bash.
Then I changed to "gtf 1024 768 60" just to see if it works, but it doesn't. I get the error messege and in fluxbox/xdm it's 1280x1024@75Hz.

Man I didn't think my screen could take 75Hz on DVI, didn't work in windows atleast.
windwos is offline   Reply With Quote
Old 01-26-06, 09:55 AM   #4
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: "You passed an undefined mode number"

You're placing the modeline generated by gtf in your xorg.conf, right? Post your xorg.conf
evilghost is offline   Reply With Quote
Old 01-26-06, 11:56 AM   #5
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default Re: "You passed an undefined mode number"

http://files.upl.silentwhisper.net/upload0/xorg.txt

When I booted up recently I didn't get the error and I had 1280x1024 in bash. And I still have 75Hz (80horizontal).
windwos is offline   Reply With Quote
Old 01-26-06, 02:07 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: "You passed an undefined mode number"

Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-27-06, 02:20 PM   #7
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default Re: "You passed an undefined mode number"

This is after I got the error:
http://files.upl.silentwhisper.net/u...bug-report.txt
And this is when I didn't:
http://files.upl.silentwhisper.net/u...ug-report1.txt
windwos is offline   Reply With Quote
Old 01-27-06, 02:35 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: "You passed an undefined mode number"

I don't see anything wrong in the bug report you posted.

What is the error that you're seeing?

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 01-31-06, 05:58 AM   #9
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default Re: "You passed an undefined mode number"

Just right before linux start loading, or at the same time, I get an error that says " You passed an undefined mode number"
Then I can either wait 30s or choose some options with rows and cols.

After that it proceeds as normal, with the "standard" resolution in bash. When I log on to fluxbox ( I used to have it through XDM but now I start it as "startx") I have 1280x1024@75Hz, even though I've set it at 60Hz, both in Sax and with the gtf command.
It's not really a problem with 75Hz, but I do get a bit sharper image with 60.

Now, sometimes this error does not come, linux loads as usual in bash with the resolution 1280x1024, and 75Hz. This looks very nice in bash. When I start x I have the same res and all.

But my problem is then that I don't want the error to come, I want the bash to be in high res and the freq at 60hz. At least I just don't want the error to come.

windwos is offline   Reply With Quote
Old 01-31-06, 10:19 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: "You passed an undefined mode number"

The "You passed an undefined mode number" error is a framebuffer configuration issue and is completely unrelated to the nvidia X driver's functionality.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-31-06, 10:38 AM   #11
windwos
Registered User
 
Join Date: Jan 2006
Posts: 10
Default Re: "You passed an undefined mode number"

Ok.. Do you know how I can fix that?
windwos is offline   Reply With Quote
Old 01-31-06, 11:52 AM   #12
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default Re: "You passed an undefined mode number"

hi windwos,

try passing to your kernel's boot parameters (either from your bootloader's config file or by hand at boot time): vga=791.

That should account for the error at boot time. But it is really not an nvidia-related question. I guess you can find a number of solutions by googling a bit 'round, or surf on linuxquestions.org forums and the like.

Hope this helps,

best,
d_p
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.
debian_penguin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 10:11 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 07:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.