Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-18-03, 02:09 PM   #1
Lord Blackdrago
Registered User
 
Join Date: Jan 2003
Posts: 27
Question FSAA, SBA, and FASTWRITE

I had this problem, everytime i try to turn on any of the var i ether get it or i don't

When I turn on FSAA i don't get FSAA
Turning on FW and SBA spawn weird errors when i boot and i can't get X working until i remove the var
can anyone help me out.

System
AMD Athlon XP 1600+
Epox AK3A
256 megs of kingston ram
80 gig western digital SE
40 gig western digital normal
Asus 8420 ( Geforce 4 Ti 4200 128 megs )
Soundblaster Audigy MP3
Jaz scsi 2 Gig tape drive
10/100 ether card
RedHat 8.0 ( no upgrades because the updating system like to crash on me )
At&t boardband

.bashrc

# .bashrc
export __GL_MODE_FSAA=4

# User specific aliases and functions

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi

module.conf

lias parport_lowlevel parport_pc
alias eth0 8139too
alias sound-slot-0 audigy
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&$
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 $
alias usb-controller usb-uhci
alias ieee1394-controller ohci1394
alias char-major-195 nvidia

alias scsi_hostadapter advansys

SBA and FW isn't in here becasue if it was i won't be writing this letter right now :-p

help, help, help
unreal tournament 2003 don't look so good without FSAA enabled :-)
Lord Blackdrago is offline   Reply With Quote
Old 01-18-03, 06:15 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: FSAA, SBA, and FASTWRITE

Well, this is why you aren't getting FSAA:

Quote:
Originally posted by Lord Blackdrago
# .bashrc
export __GL_MODE_FSAA=4
That should be, according to the docs, export __GL_FSAA_MODE=4

As for SBA and FW, what are these "weird errors" when you startx? It's hard to tell you what to try when we don't know the error message...

You may also want to look at /proc/driver/nvidia/agp/host-bridge and /proc/driver/nvidia/agp/card, to see what your hardware supports. If both files don't report that the features are supported, then it won't enable, and it is remotely possible that this is causing the driver to not load.

Also, which distro are you using?
__________________
Registered Linux User #219692

Last edited by bwkaz; 01-18-03 at 06:18 PM.
bwkaz is offline   Reply With Quote
Old 01-18-03, 07:00 PM   #3
Lord Blackdrago
Registered User
 
Join Date: Jan 2003
Posts: 27
Default

Hey thanks for the FSAA problem :-) when i looked at the post and saw that the words was mixed up I laughed myself out of my seat lol

my distro is Redhat 8.0

Ok the FW SBA error I get at post is something like this

there is a error in /etc/modules.conf line something
options NVdriver NVreg_EnableAGPFW=1
something for SBA

then it moves on loading all the other stuff then I come to the command line login and not graphic login. so from there i can remove the options and get the graphical login

my hardware support SBA and FW
so do my bios.. here let me post the output

Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x1f000104

this is from cat card

Host Bridge: Via Apollo Pro KT266
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000104

this is from host-bridge

Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

and this is from cat status

Model: GeForce4 Ti 4200
IRQ: 10
Video BIOS: 04.25.00.30.00
Card Type: AGP

this is from /proc/driver/nvidia/cards

NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4191 Mon Dec 9 11:49:01 PST 2002
GCC version: gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

this is from cat /proc/driver/nvidia/version

i hope any of this can help

if you need more info on the error tell me help to cut and paste from command line ( the black and white verison ).
Lord Blackdrago is offline   Reply With Quote
Old 01-18-03, 07:22 PM   #4
Lord Blackdrago
Registered User
 
Join Date: Jan 2003
Posts: 27
Default update

ok i just tried to enble FW in my modules.conf file and rebooted i can get into X with one but when i cat my video card status it say's not enbled
Lord Blackdrago is offline   Reply With Quote
Old 01-18-03, 08:08 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It's not enabled because the module's name changed starting with 4191. It's now named nvidia, not NVdriver. So change the options line.

I think the other problem (where modprobe complains about an invalid syntax) is because you probably can't have 2 options lines for the same module. Put both of them together on one line, like so:

options nvidia NVreg_EnableAGPFW=1 NVreg_EnableAGPSBA=1

, rerun /sbin/depmod -a, unload the nvidia module, and re-/sbin/modprobe it. If that works, then reboot and make sure it still does.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-18-03, 09:22 PM   #6
Lord Blackdrago
Registered User
 
Join Date: Jan 2003
Posts: 27
Default

AHH... thank you, bwkaz if there was a rating on how helpful people are i would give you a 10 everything is up and running and running smooth to.

if you can and if the new nvidia drivers have a new doc can you point me as to where it would be on my system? thanks again
Lord Blackdrago is offline   Reply With Quote
Old 01-19-03, 08:33 AM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

It would be /usr/share/doc/NV<and hit tab>/README

It's just a copy of the README off the download page, though.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.