Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-06, 06:30 PM   #1
Chris97b
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Failed to load the NVIDIA kernel module!

Hello all,

Been beating my head on the desk for a few days on this one.

I'm running FC4 (kernel 2.6.15-1-1830), trying to install the Nvidia driver (8178, using the installer from nvidia.com) for a GeForce 5500.

The installer seems to run fine, but when I try to start X, it crashes with the error: Failed to load the NVIDIA kernel module!

a modprobe nvidia results in the error: Module nvidia_1_0_8178 not found


I ran the nvidia-bug-report script, the output is at:

http://pastebin.ca/40433

(this output includes the contents of nvidia-installer.log)


At the suggestion of a friend, I'm recompiling the kernel without framebuffer at the moment, but has anyone seen this before?

I've tried several different modifications to xorg.conf I've found crawling the web, none of which seem to help. I'm just about at my wits end


Thanks,
-Chris
Chris97b is offline   Reply With Quote
Old 02-06-06, 06:35 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Failed to load the NVIDIA kernel module!

Check your /etc/modprobe.conf. Some 3rd party nvidia driver packages put an nvidia kernel module alias for nvidia_1_0_8178 in there which should not be there.

-Lonni
netllama is offline   Reply With Quote
Old 02-06-06, 08:19 PM   #3
Chris97b
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Re: Failed to load the NVIDIA kernel module!

Well, that fixed that problem, thx!

But now I'm having the same issue I did with the 3rd party modules; X locks up loading.

It looks like a dialog/warning box pops up, but the 'fedora core' loading screen covers it up, and X is hung, so I cannot bring it to the front.


I have included another bug report. If anyone has any more ideas, I would appreciate it

-Chris

nvidia-bug-report.log:

http://pastebin.ca/40456
Chris97b is offline   Reply With Quote
Old 02-06-06, 09:49 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Failed to load the NVIDIA kernel module!

What kind of motherboard are you using, and which BIOS version?

-Lonni
netllama is offline   Reply With Quote
Old 02-07-06, 07:23 AM   #5
Chris97b
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Re: Failed to load the NVIDIA kernel module!

Honestly, I think I've narrowed it down to the board

It's a *really* old ECS Socket A board (not sure of the specific model/BIOS; will check when I get home)

I'm going to a friends place today or tomorrow to test the card in his sytem, should show if it's the mobo


Thanks again,
-Chris
Chris97b is offline   Reply With Quote
Old 02-07-06, 12:50 PM   #6
Chris97b
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Re: Failed to load the NVIDIA kernel module!

OK, found a little more information on the motherboard.

It's an ECS K7SEM (PC Chips M810LMR) w/ a SIS7018 chipset. Still not sure what the specific BIOS is on it, but I'm almost positive it has never been updated.

A Tech site on this motherboard (http://radel.inet.net.nz/m810lmr.html) suggested using a beefy power supply when using an AGP card (the motherboardboard has onboard VGA) and forcing 1X AGP.


As soon as I get off of work, I'm going to swap the PSU for a 400W and try updating the BIOS. As for 1X AGP, I'm not certain this is something I can do from the BIOS (the site I found indicates that for windows users, a registry hack is the best way to do it)


Does anyone know of a software method to force 1X AGP? Is this one of the options I can pass to the nvidia driver in xorg.conf?

I'll update this as soon as I can try those out.


-Chris
Chris97b is offline   Reply With Quote
Old 02-07-06, 01:20 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Failed to load the NVIDIA kernel module!

You can disable AGP from the driver by setting NvAGP=0, however you cannot specify specific AGP bus rates. Some BIOS's allow you to set the AGP bus rate.

-Lonni
netllama is offline   Reply With Quote
Old 02-07-06, 04:26 PM   #8
Chris97b
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Re: Failed to load the NVIDIA kernel module!

WOOHOO!!!

Setting NvAGP=0 did the trick!

glxgears gives me an average FPS over 1,300! (As opposed to ~130 with the stock 'nv' driver)

Thanks Lonni,

-Chris
Chris97b is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM

All times are GMT -5. The time now is 09:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.