Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-10-06, 10:41 AM   #1
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Suse10 + nvsound = random crashing **found solution**

Hi people.

I have had this problem for a while now, it is the only thing that is causing me to not use SUSE 10 as my main desktop system.

When I install the Nvidia nvsound driver (from www.nvidia.com) and made the changes to /etc/modprobe.d/sound and reboot the system becomes very unstable.

After installing the driver It has about 1 in 10 chance of being able to boot to system, it mostly locks up at random on boot, if it does actualy manage to boot then there is 1 in 2 change of usb working (this is without making any changes)

This problem has existed for open suse on my machine since RC1, I have tried the 3.06 and 3.10 nvidia drivers.


Here are some things to consider regarding this issue:-

It is SUSE specific:-
- The same machine runs the same driver fine on the following OS's - Mandriva 2006, Kubuntu 5.10 and Fedora 4.
- It is not the SUSE kernel as I have tested using vanilla kernel (+ck patch) on Kubuntu and Suse - Kubuntu works fine, Suse crashes randomly.

I know I could just use ALSA, but the nvsound driver is much better to listen to music through.

Any help in troubleshooting this (i,e want log files to look in) would be great, one reason why this is going to be hard to troubleshoot is the random nature of the crashing once I have enabled nvsound.

Here are my specs:-

Motherboard : Nforce 2 - Asus A7N8X-E Deluxe BIOS 1013 - Reiserfs 3.6

Cheers

Last edited by interzoneuk; 01-14-06 at 12:02 AM. Reason: **found solution**
interzoneuk is offline   Reply With Quote
Old 01-10-06, 06:17 PM   #2
MPiece
Registered User
 
Join Date: Jan 2006
Posts: 8
Default Re: Suse10 + nvsound = random crashing

I have the exact same problem, and the exact same board, with exactly the same BIOS, and exactly the same filesystem. I run Kanotix 2005-04. I haven't figured out what is causing this behavior yet, but the problem mostly occcurs when I connect a HP Deskjet 3550 printer to the USB. That makes a hard lockup virtually guaranteed.

MP
MPiece is offline   Reply With Quote
Old 01-10-06, 08:30 PM   #3
MPiece
Registered User
 
Join Date: Jan 2006
Posts: 8
Default Re: Suse10 + nvsound = random crashing

Hmmm......it indeed seems to be related to the USB. Or it could be an IRQ issue. It seems that different BIOS configurations give different results. This IRQ configuration works for me at the moment. Thats nearly good news. Because then it's probably unnecessesary to disable them completely. I keep trying... I will post again when I know more about this

cat /proc/interrupts

CPU0
0: 36613 XT-PIC timer
1: 39 XT-PIC i8042
2: 0 XT-PIC cascade
5: 8575 XT-PIC NVIDIA nForce2 Controller, ehci_hcd:usb3, SysKonnect SK-98xx
7: 168 XT-PIC parport0
8: 4 XT-PIC rtc
9: 7977 XT-PIC acpi, NVIDIA nForce2 Audio, ohci_hcd:usb2, ohci1394, nvidia
11: 129 XT-PIC ohci_hcd:usb1, bttv0, bt878
12: 5177 XT-PIC i8042
14: 3090 XT-PIC ide0
15: 14842 XT-PIC ide1
NMI: 0
LOC: 36570
ERR: 54

EDIT: I think it's specificly related to ehci_hcd:usb3 . My computer seems to lock up in different IRQ configurations, but it's always related to that device as far as I can tell.
MPiece is offline   Reply With Quote
Old 01-11-06, 03:20 PM   #4
MPiece
Registered User
 
Join Date: Jan 2006
Posts: 8
Default Re: Suse10 + nvsound = random crashing

I give up. I've recompiled my kernel 15 times and tried numerous configuratiions, but no solution. But I think it.s the usb-ohci support which
detects the nVidia MCP chip in kernel 2.6.15 (latest kerneltree), but only when the nvsound module is loaded

Last edited by MPiece; 01-11-06 at 03:49 PM.
MPiece is offline   Reply With Quote
Old 01-11-06, 06:38 PM   #5
MPiece
Registered User
 
Join Date: Jan 2006
Posts: 8
Default Re: Suse10 + nvsound = random crashing

I found a solution; go back to kernel 2.6.12.2 (verified and working) or use ALSA and drop the hardware mixing. Nvidia explicitly stated in their release notes, that they just recently added support for this branch of kernels. I just didn't read it, but I should have. Personally, I think the MCP is well worth it (the sound quality is AMAZING!) . So I'm happy.

Bye.
MPiece is offline   Reply With Quote
Old 01-11-06, 09:00 PM   #6
MPiece
Registered User
 
Join Date: Jan 2006
Posts: 8
Default Re: Suse10 + nvsound = random crashing

2.6.12.6 works too: http://www.kernel.org/pub/linux/kern...6.12.6.tar.bz2

A piece of advice to anybody who cares; when Nvidia explicitly states that support has been added to a specific branch of kernels, don't expect the drivers to work with a newer branch, much less a branch under development. 2.6.12.6 is less than ½ a year old. So all in all, I think Nvidia supports linux well. Pun intended to all those users who expect their drivers to magicly work every time with a UNSUPPORTED kernel branch new as wet paint, and bitch about it when they don't. I have read numerous rants about this in here, and they (and myself) could have saved themselves plenty of headaches, by simply reading the release notes.

MP
MPiece is offline   Reply With Quote
Old 01-14-06, 12:00 AM   #7
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Smile Solution

HI.

Found a solution.

This is using the Suse kernel 2.6.13-15.7 - I will test it on the 2.6.15 kernel later.

All I did was disable the onboard Nforce network card, I use the other onboard one (sk98lin), then installed the driver and did the changes to the /etc/modprobe.d/sound.

I am so happy this works !!

interzoneuk is offline   Reply With Quote
Old 02-01-06, 08:37 AM   #8
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Re: Suse10 + nvsound = random crashing

Ignore Last email, it still isn't working. Well it worked until I rebooted.

However i have installed the driver successfully in Gentoo!
interzoneuk is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random loot packs are the best-selling item in free-to-play City of Heroes News Latest Tech And Game Headlines 0 05-06-12 11:00 AM

All times are GMT -5. The time now is 08:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.