Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-03-06, 09:18 AM   #1
coxc
Registered User
 
Join Date: Jan 2006
Posts: 1
Unhappy Audio not working with Fedora Core 3

I am running Fedora Core 3 with a 2.6.12-1.1381_FC3 kernel and a Gnome desktop. My setup is pretty much the standard way that Fedora Core 3 gets installed. My audio does not work properly even though the nvsound module appears to load correctly. If I perform "cat /usr/share/freeciv/stdsounds/gong10.wav >/dev/dsp", I get appropriate sound in the speakers. However, the following features do not work.

(1) I cannot play sounds through applications like RealPlayer, kaboodle, etc.

(2) When I select Sound & Video->Volume Control from the desktop menu, I get an error window with the following message. "Sorry, no mixer elements and/or devices found."

(3) I have a volume control icon on my taskbar. When I left-click it, it displays a vertical slider bar for the volume. I can drag the volume up on the bar, but it immediately falls back down to zero volume even before I release the slider. When I right-click on the icon, I can select "Preferences". Doing so opens a window where I should be able to select an audio channel, but the "Audio Channels" list is empty.

(4) When I select System Settings->Soundcard detection from the desktop menu, a window titled "Audio devices" opens with the following information:

The following audio device was detected.
Vendor: nVidia
Model: Corporation: Unknown device 026b
Module: nvsound

There is also a "Play test sound" button. When it is pressed, no sound occurs, and a window pops up asking if a sound was heard. When "No" is pressed, a window appears that says "Automatic detection of sound card did not work. Audio will not be available on the system. Please click OK to continue."

(5) I have run nvmixer and ensured that all volumes are high and all mute selections are disabled (no muting).

BTW, I have no problems with the network driver nvnet.

Here is the troubleshooting that I know to do and the results.

Here is the output of the lsmod command showing the nvsound module is loaded and associated with the soundcore module (whatever that is).

Module Size Used by
nls_utf8 2113 0
vfat 13249 0
fat 55005 1 vfat
nvsound 1555512 0
parport_pc 28293 1
lp 12873 0
parport 40073 2 parport_pc,lp
autofs4 28229 0
i2c_dev 10945 0
i2c_core 21313 1 i2c_dev
sunrpc 164229 1
ipt_REJECT 5441 1
ipt_state 1857 2
ip_conntrack 41369 1 ipt_state
iptable_filter 2881 1
ip_tables 19521 3 ipt_REJECT,ipt_state,iptable_filter
video 15685 0
button 4033 0
battery 9285 0
ac 4805 0
sd_mod 20289 0
md5 4033 1
ipv6 263105 12
usb_storage 72329 0
scsi_mod 146313 2 sd_mod,usb_storage
ohci_hcd 26081 0
ehci_hcd 40013 0
soundcore 10785 1 nvsound
nvnet 74660 0
dm_snapshot 17413 0
dm_zero 2113 0
dm_mirror 25645 0
ext3 130633 2
jbd 83161 1 ext3
dm_mod 57333 6 dm_snapshot,dm_zero,dm_mirror

Here is some interesting parts of running the dmesg command.

...
ACPI: RSDP (v000 Nvidia ) @ 0x000f7af0
ACPI: RSDT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x17ee3040
ACPI: FADT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x17ee30c0
ACPI: MCFG (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x17ee9540
ACPI: MADT (v001 Nvidia AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x17ee9480
ACPI: DSDT (v001 NVIDIA AWRDACPI 0x00001000 MSFT 0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
...
Nvsound: Nvidia Audio Init Module, 11:31:12 Jan 13 2006 version 1.0-7
ACPI: PCI Interrupt Link [LACI] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LACI] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:10.2 to 64
Nvsound: NVIDIA MCP51 Audio aci 0xd800 and ac97 0xdc00, IRQ b
Nvsound: DEV MIXER 0 DEV AUDIO 3
ACPI: PCI Interrupt Link [LUB2] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:0b.1[b] -> Link [LUB2] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:0b.1 to 64
...
Nvsound: Audio getting removed d6f1b480
KERN_INFO Nvsound: Release DEV MIXER 0
Nvsound: Nvidia Audio Init Module, 11:31:12 Jan 13 2006 version 1.0-7
ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LACI] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:10.2 to 64
Nvsound: NVIDIA MCP51 Audio aci 0xd800 and ac97 0xdc00, IRQ b
Nvsound: DEV MIXER 0 DEV AUDIO 3
...

I don't know exactly what I am reading, but the "Nvsound: Audio getting removed" entry catches my eye.

Does anyone know what the problem may be? Failing that, if a few people that have gotten their nvsound module to work could post the results of running "lsmod" and "dmesg", the differences between a working setup and my non-working setup may be useful. Well, maybe the parts of "dmesg" that have to do with NVIDIA or nvsound, since "dmesg" output can be pretty long. Thanks.
coxc is offline   Reply With Quote
Old 02-03-06, 10:30 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Audio not working with Fedora Core 3

Please generate and post an nforce-bug-report.log. Also keep in mind that the nvsound module is an OSS module, and provides no ALSA support. Any applications configured to use ALSA will fail.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-12-06, 10:32 AM   #3
gnutux
Linux User: 362616
 
Join Date: Oct 2005
Location: Toronto, Canada
Posts: 108
Default Re: Audio not working with Fedora Core 3

It is definitely NOT wise to have a driver for OSS only as it is not depricated. ALSA is the current way to go!

gnutux
gnutux is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tony Hawk devs working on Call of Duty News Gaming Headlines 0 06-15-12 10:30 AM
i3 one core runs hotter than the other muelo1000 CPUs, Motherboards And Memory 3 05-29-12 12:00 PM
Intel's Ivy Bridge Core i7 3770K Overheating Issue Detailed News Archived News Items 0 05-16-12 10:40 AM
CPUMark99 - how do you compare fuelrod Benchmarking And Overclocking 66 07-19-11 08:32 AM
nForce Audio pergamon NVIDIA Linux 6 12-25-02 11:38 PM

All times are GMT -5. The time now is 01:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.