Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-05-06, 09:50 AM   #1
zensaber
Registered User
 
Join Date: Feb 2006
Posts: 3
Default Nvidia working problem

OK installed but when ever I or the nvidia driver changes the nv in my config to nvidia i get a black screen when i reload x. Any one know what i could add to my xorg config to fix or somthing? Please I want to play games T.T

Distro: SuSe 10
Video Card: Geforce 6800 GS agp 256
zensaber is offline   Reply With Quote
Old 02-06-06, 05:00 PM   #2
far.right
Registered User
 
Join Date: Feb 2006
Posts: 2
Default Re: Nvidia working problem

I am interested in your issue because I am considering that exact same card for my linux workstation and I'm not sure how well supported it will be.

You should take a look at (or post) your xorg log file after one of the black screen events to see what errors are being generated. Find it in /var/log/xorg.0.log.

I'll tell you what I would try and if it works please tell me, and I will go ahead and buy my own GS. This post might get kinda dry - feel free to supplement it with beer. I have highlighted my suggested changes to your xorg.conf in blue.

What driver are you using? Try and get a recent driver if you don't already have one.

First off, you probably need to disable DRI (I had to to get my 6600 working), so comment out 'Load "dri"' from Section "Modules" and comment out the entire Section "DRI". So you will have commented out the following as such:


Section "Module"
...
# Load "dri"

...

#Section "DRI"
# Mode 0666
#EndSection


Restart your X server, or reboot, and give that a try and see if it works. If not, there's something else we can try...

See, the 6800 GS AGP Chip ID (0x0047) isn't listed in the Linux Driver Supported Chipsets appendix. I am not sure if the omission is accidental or not, but one could take it to mean that the AGP version of the 6800 GS is just not supported (because everyone is hating on AGP nowadays).

However, the AGP GS is essentially just a GT with a different ROM. They are both NV40. In fact, if you probe the GS with RivaTuner (in windows) it will report that it's hardwired ID is actually 0x0045 and has been ROM strapped to 0x0047!

Soooo, you can use xorg.conf to tell the nvidia driver that your card is in fact a GT and it might stop throwing fits. I successfully used this method to make my ATI fglrx driver think my (unsupported) R481 X850 was an R480 X850. You do this by manually specifying a ChipID in the "Device" section like this:


Section "Device"
...
ChipID 0x0045
EndSection


Add exactly that to your xorg.conf and restart X or reboot and cross your fingers. It should have a high probability of working.

Again, if these methods work, please let me know. Also let me know if they don't work so I can pass on the GS and go pay way too much for a GT.

Last edited by far.right; 02-06-06 at 08:37 PM.
far.right is offline   Reply With Quote
Old 02-08-06, 05:20 PM   #3
zensaber
Registered User
 
Join Date: Feb 2006
Posts: 3
Default Re: Nvidia working problem

well the latest nvidia linux driver came out dec 22 2005 while the 6800gs agp came out in jan 2006
zensaber is offline   Reply With Quote
Old 02-08-06, 06:11 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia working problem

Please generate and post a bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-09-06, 11:28 AM   #5
vrode
Registered User
 
Join Date: Jan 2006
Posts: 36
Default Re: Nvidia working problem

Quote:
Originally Posted by far.right
I am interested in your issue because I am considering that exact same card for my linux workstation and I'm not sure how well supported it will be.

You should take a look at (or post) your xorg log file after one of the black screen events to see what errors are being generated. Find it in /var/log/xorg.0.log.

I'll tell you what I would try and if it works please tell me, and I will go ahead and buy my own GS. This post might get kinda dry - feel free to supplement it with beer. I have highlighted my suggested changes to your xorg.conf in blue.

What driver are you using? Try and get a recent driver if you don't already have one.

First off, you probably need to disable DRI (I had to to get my 6600 working), so comment out 'Load "dri"' from Section "Modules" and comment out the entire Section "DRI". So you will have commented out the following as such:


Section "Module"
...
# Load "dri"

...

#Section "DRI"
# Mode 0666
#EndSection


Restart your X server, or reboot, and give that a try and see if it works. If not, there's something else we can try...

See, the 6800 GS AGP Chip ID (0x0047) isn't listed in the Linux Driver Supported Chipsets appendix. I am not sure if the omission is accidental or not, but one could take it to mean that the AGP version of the 6800 GS is just not supported (because everyone is hating on AGP nowadays).

However, the AGP GS is essentially just a GT with a different ROM. They are both NV40. In fact, if you probe the GS with RivaTuner (in windows) it will report that it's hardwired ID is actually 0x0045 and has been ROM strapped to 0x0047!

Soooo, you can use xorg.conf to tell the nvidia driver that your card is in fact a GT and it might stop throwing fits. I successfully used this method to make my ATI fglrx driver think my (unsupported) R481 X850 was an R480 X850. You do this by manually specifying a ChipID in the "Device" section like this:


Section "Device"
...
ChipID 0x0045
EndSection


Add exactly that to your xorg.conf and restart X or reboot and cross your fingers. It should have a high probability of working.
Again, if these methods work, please let me know. Also let me know if they don't work so I can pass on the GS and go pay way too much for a GT.
-----------------
I have a similar problem except in my case I have nvidia geforce go 6800. Would I need to specify ChipID as well? If so would you happen to know the ID or can point me in the right direction? my lspci doesn't list it

regards,
/virendra
vrode is offline   Reply With Quote
Old 02-09-06, 02:04 PM   #6
zensaber
Registered User
 
Join Date: Feb 2006
Posts: 3
Default Re: Nvidia working problem

I don't know myself, but i switched from suse to fedora 4 to see if that might help.
zensaber is offline   Reply With Quote
Old 02-09-06, 03:16 PM   #7
far.right
Registered User
 
Join Date: Feb 2006
Posts: 2
Default Re: Nvidia working problem

vrode - as far as I can tell, the geforce go 6800 is supported by the linux driver. You might just have a xorg configuration problem. take a look at the README and try to get it setup right.


zensaber - I take it you tried specifying the ChipID in xorg.conf and it didn't work?
far.right is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 01:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.