Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-19-03, 03:35 PM   #1
lmetza
Registered User
 
Join Date: Aug 2002
Location: Canada
Posts: 151
Send a message via AIM to lmetza
Default WineX Configuration file *help*

I downloaded wineX 2.21 build. I do the stuff the guide says (the readme).
How do i set up the /root/.wine/config file.

I went to install WC3, this is what i got.


[root@mdoc-km-244-55-249 root]# cd /mnt/cdrom
[root@mdoc-km-244-55-249 cdrom]# wine install.exe
Could not stat /root/.transgaming/c_drive (No such file or directory), ignoring
drive C:
Invalid path 'c:\windows' for windows directory: does not exist
Perhaps you have not properly edited or created your Wine configuration file.
This is (supposed to be) '/root/.wine/config'
lmetza is offline   Reply With Quote
Old 01-20-03, 08:30 AM   #2
jnd3
Sword Saint
 
jnd3's Avatar
 
Join Date: Jul 2002
Location: Alpharetta, GA USA
Posts: 465
Send a message via AIM to jnd3 Send a message via Yahoo to jnd3
Default

Hi,

Check out this thread:

http://www.nvnews.net/vbulletin/show...&threadid=5659

It got me up and running with WineX. Of course, I don't have any games that really work in it, but still...

Cheers,
JND
jnd3 is offline   Reply With Quote
Old 01-20-03, 09:01 AM   #3
lmetza
Registered User
 
Join Date: Aug 2002
Location: Canada
Posts: 151
Send a message via AIM to lmetza
Default

Got any idea on how i would fix this , i followed volts guide.. Some strange crap about fonts (i got this when i copyed my fonts folder over to my fake windows drive. I get this when i go to install warcraft 3.


[dan@mdoc-km-244-55-249 cdrom]$ wine install.exe
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/modern.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/roman.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/script.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/desktop.ini" err = 55
fixme:dialog:MSGBOX_OnInit task modal msgbox ! Not modal yet.
[dan@mdoc-km-244-55-249 cdrom]$

btw: wolfenstein (rtcw) is installing ok, but itsa linux friendly game of course, im useing wineX to do it too (wine Setup.exe) umm, when im instal lrtcw it says i need DCOM95???

Last edited by lmetza; 01-20-03 at 09:17 AM.
lmetza is offline   Reply With Quote
Old 01-20-03, 09:03 AM   #4
lmetza
Registered User
 
Join Date: Aug 2002
Location: Canada
Posts: 151
Send a message via AIM to lmetza
Default

btw: is it supposed to do this when i go to set up the registry.

[root@mdoc-km-244-55-249 wine]# /programs/regapi/regapi setValue < winedefault.reg
bash: /programs/regapi/regapi: No such file or directory
lmetza is offline   Reply With Quote
Old 01-20-03, 09:22 AM   #5
volt
 
Join Date: Jul 2002
Location: /dev/null
Posts: 1,556
Default

Quote:
Originally posted by lmetza
Got any idea on how i would fix this , i followed volts guide.. Some strange crap about fonts (i got this when i copyed my fonts folder over to my fake windows drive. I get this when i go to install warcraft 3.


[dan@mdoc-km-244-55-249 cdrom]$ wine install.exe
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/modern.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/roman.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/script.fon" err = 2
err:font:AddFontFileToList Unable to load font file "/home/dan/.wine/c_drive/windows/Fonts/desktop.ini" err = 55
fixme:dialog:MSGBOX_OnInit task modal msgbox ! Not modal yet.
[dan@mdoc-km-244-55-249 cdrom]$

btw: wolfenstein (rtcw) is installing ok, but itsa linux friendly game of course, im useing wineX to do it too (wine Setup.exe) umm, when im instal lrtcw it says i need DCOM95???
By the way, I did not say anything about copying fonts from XP CD
__________________
[b]Optimization guidelines by Koji Ashida of NVIDIA:[/b][list][*]Use fx12 instructions whenever possible[*]Use lowest pixel shader version[/list][url=http://developer.nvidia.com/docs/IO/10878/ChinaJoy2004_OptimizationAndTools.pdf]source[/url]

[size=1]The politics are invading the technology. We don't really like to mess with politics because that kind of adversarial relationship has nothing to do with pure technical operations and the technical specifications of what we like to play with, the hardware![/size]
volt is offline   Reply With Quote
Old 01-20-03, 10:06 AM   #6
jnd3
Sword Saint
 
jnd3's Avatar
 
Join Date: Jul 2002
Location: Alpharetta, GA USA
Posts: 465
Send a message via AIM to jnd3 Send a message via Yahoo to jnd3
Default

Quote:
Originally posted by lmetza
btw: is it supposed to do this when i go to set up the registry.

[root@mdoc-km-244-55-249 wine]# /programs/regapi/regapi setValue < winedefault.reg
bash: /programs/regapi/regapi: No such file or directory
Ahhh, yes, I think Volt might have forgotten a step (or my CVS build didn't do it right). I had to go into the ./wine/programs/regapi/ directory (don't forget the ./wine on the front!) and do a make to get the regapi program built. Then it worked fine.

Cheers,
JND
jnd3 is offline   Reply With Quote
Old 01-20-03, 12:10 PM   #7
lmetza
Registered User
 
Join Date: Aug 2002
Location: Canada
Posts: 151
Send a message via AIM to lmetza
Default

Quote:
Originally posted by jnd3
Ahhh, yes, I think Volt might have forgotten a step (or my CVS build didn't do it right). I had to go into the ./wine/programs/regapi/ directory (don't forget the ./wine on the front!) and do a make to get the regapi program built. Then it worked fine.

Cheers,
JND
sweet, then i know i didnt screw it up when i typed that, cuz i was browsin the folders and notices makefile in regapi so i decided to type make and see what happens. now do i need to type make install???
But after "make" i do the "./programs/regapi/regapi setValue < winedefault.reg"
right? and it should work then.

all i need to do now is get WC3 installeds and get some installshield support somehow (i found a wineX221.tar.bz2 (got it off a website) apparently i need mesa to build it, what makes it different from the CVS other then the installshield.

How do i uninstall wineX if i want to try the wineX 2.21???

thanks..
lmetza is offline   Reply With Quote
Old 01-20-03, 12:40 PM   #8
tuxfriend
Registered User
 
Join Date: Jul 2002
Location: Muelheim/Ruhr Germany
Posts: 27
Default

Hi,
this will help:
http://www.linuxfusion.net/installwine.htm
you also should get rid of Wine to,then get the CVS- version and
follow the link I postet above.

good luck
tuxfriend is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD 9 Release with Nvidia 550 Ti configuration issues goga NVIDIA FreeBSD 0 05-23-12 08:34 AM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
RPM Source problems LaoTzuTao NVIDIA Linux 10 01-19-03 05:15 AM
Can't install NVIDIA_kernel.XXXX.XXXX.src or regular rpm noeffort NVIDIA Linux 15 12-17-02 01:22 PM
WineX or nVidia troubles? arise NVIDIA Linux 2 10-10-02 07:57 AM

All times are GMT -5. The time now is 11:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.