Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-06, 02:42 AM   #1
iman
Registered User
 
Join Date: Feb 2006
Posts: 2
Default Can't build 6629 on SuSE 10 (2.6.13)

Hi,

I'm using a faily old nVidia graphics card in my box:

01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro] (rev 11)

I understand that only drivers <7xxx support these cards. So I downloaded NVIDIA-Linux-x86-1.0-6629-pkg1.run to build a kernel module.

I also installed the kernel sources and configured them with "make cloneconfig" and "make modules_prepare".

When start NVIDIA-Linux-x86-1.0-6629-pkg1.run, I get right to the progress bar where it claims to build the module, but then it stops with an error. I'll append /var/log/nvidia-installer.log below.

If anyone has a hint for me... would be great.

Thanks,
iman




# cat nvidia-installer.log
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Feb 11 20:55:15 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.13-15.8-smp/source'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
-> Performing rivafb module check.
WARNING: Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.13-15.8-smp
/source SYSOUT=/lib/modules/2.6.13-15.8-smp/build'...
Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!

*** Failed rivafb module sanity check, but continuing! ***


NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.13-15.8-smp/build KBUILD_VERBOSE=1
-C /lib/modules/2.6.13-15.8-smp/source SUBDIRS=/tmp/selfgz11101/NVIDIA-Linux
-x86-1.0-6629-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.13-15.8-smp/build \
KBUILD_SRC=/usr/src/linux-2.6.13-15.8 KBUILD_VERBOSE=1 \
KBUILD_CHECK= KBUILD_EXTMOD="/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1
/usr/src/nv" \
-f /usr/src/linux-2.6.13-15.8/Makefile modules
mkdir -p /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_ver
sions
make -f /usr/src/linux-2.6.13-15.8/scripts/Makefile.build obj=/tmp/selfgz111
01/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz11101/NV
IDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nv.
o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.0.2/include -D__KERNE
L__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.13-15.8/include -I/tmp/selfgz1
1101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wundef -Wstrict-proto
types -Wno-trigraphs -Werror-implicit-function-declaration -fno-strict-alias
ing -fno-common -ffreestanding -O2 -fomit-frame-pointer -pipe -msoft-float -
mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=i586 -mregparm=3 -mtu
ne=i686 -Iinclude/asm-i386/mach-generic -I/usr/src/linux-2.6.13-15.8/include
/asm-i386/mach-generic -Iinclude/asm-i386/mach-default -I/usr/src/linux-2.6.
13-15.8/include/asm-i386/mach-default -Wdeclaration-after-statement -Wno-poi
nter-sign -I/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wal
l -Wimplicit -Wreturn-type -Wswitch -Wformat
-Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -
fno-common -MD -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__
-DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -D
NV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629 -DNV_UNIX -DNV_
LINUX -DNV_INT64_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PFN_RAN
GE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DN
V_PCI_GET_CLASS_PRESENT -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidi
a -c -o /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_nv.o
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c
In file included from /usr/src/linux-2.6.13-15.8/include/linux/list.h:7,
from /usr/src/linux-2.6.13-15.8/include/linux/wait.h:23,
from include2/asm/semaphore.h:41,
from /usr/src/linux-2.6.13-15.8/include/linux/sched.h:20,
from /usr/src/linux-2.6.13-15.8/include/linux/module.h:10,
from /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:52,
from /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv.c:14:
/usr/src/linux-2.6.13-15.8/include/linux/prefetch.h: In function ‘prefetch
_range’:
/usr/src/linux-2.6.13-15.8/include/linux/prefetch.h:62: warning: pointer of
type ‘void *’ used in arithmetic
In file included from /usr/src/linux-2.6.13-15.8/include/linux/dmapool.h:14,
from /usr/src/linux-2.6.13-15.8/include/linux/pci.h:870,
from /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv-linux.h:75,
from /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv.c:14:
include2/asm/io.h: In function ‘check_signature’:
include2/asm/io.h:253: warning: wrong type argument to increment
In file included from /tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv/nv.c:14:
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-linux.h:203:5:
warning: "NV_ENABLE_MEM_TRACKING" is not defined
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-linux.h:231:5:
warning: "NV_ENABLE_MEM_TRACKING" is not defined
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:223:5: warni
ng: "NV_ENABLE_MEM_TRACKING" is not defined
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
‘nvidia_init_module’:
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:930: warning
: ‘pm_register’ is deprecated (declared at /usr/src/linux-2.6.13-15.8/in
clude/linux/pm.h:107)
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
‘nvidia_exit_module’:
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:1051: warnin
g: ‘pm_unregister’ is deprecated (declared at /usr/src/linux-2.6.13-15.8
/include/linux/pm.h:112)
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:1097:5: warn
ing: "NV_ENABLE_MEM_TRACKING" is not defined
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
‘_get_phys_address’:
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2509: warnin
g: passing argument 1 of ‘pmd_offset’ from incompatible pointer type
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c: In function
‘nv_agp_init’:
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2991: error:
implicit declaration of function ‘inter_module_get’
/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c:2992: warnin
g: ‘inter_module_put’ is deprecated (declared at /usr/src/linux-2.6.13-1
5.8/include/linux/module.h:573)
make[4]: *** [/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.
o] Error 1
make[3]: *** [_module_/tmp/selfgz11101/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/sr
c/nv] Error 2
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
iman is offline   Reply With Quote
Old 02-11-06, 03:06 AM   #2
iman
Registered User
 
Join Date: Feb 2006
Posts: 2
Default Re: Can't build 6629 on SuSE 10 (2.6.13)

Hi (again),

tried this patch: NVIDIA-1.0-6629-02.28.2005+warpxmod-09.24.2005.diff.txt

Now the build works, but including the kernel module (modprobe nvidia) is not possible, here's the tail of dmesg:

nvidia: module not supported by Novell, setting U taint flag.
nvidia: Unknown parameter `NVreg_DeviceFileUID'

First line seems to be the usual message. But I can't make much sense from the second line...

Cheers,
iman
iman is offline   Reply With Quote
Old 02-11-06, 11:03 AM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can't build 6629 on SuSE 10 (2.6.13)

You likely have an entry somewhere in /etc/modprobe.d that is specifying `NVreg_DeviceFileUID' as a module option. You'll need to remove that entry.

Also, 1.0-6229 is no longer supported. 1.0-7174 is the version that you should be using with your NV5.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Diablo 3 Wizard build guide News Archived News Items 0 05-30-12 02:40 PM
Diablo 3 build guide: Barbarian, Demon Hunter, Monk, Witch Doctor and Wizard News Archived News Items 0 05-12-12 12:00 PM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
My source RPM won't build right! z28Power NVIDIA Linux 5 09-18-02 11:55 AM

All times are GMT -5. The time now is 01:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.