Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-06, 05:14 PM   #1
nvRaimi
Registered User
 
Join Date: Sep 2005
Posts: 10
Default Xorg does not start with 100% CPU on Dual-AMD64, 6200

Hey *,

I'm trying to set up my brand new workstation: It's a Dual-Opteron running Debian in 64-Bit. When starting xorg it just hangs at 100% CPU and cannot be killed (not even with kill -9). The other CPU keeps the system usable but I have to reboot to resolve the situation. Xorg's 'nv' driver does not run at all because it does not detect the card at all. Very strange.

Please find attached the Xorg logfile at the point when it hangs. Also find an nvidia-bug-report that should contain all relevant information. However, the nvidia driver was not loaded when that bug-report was created (was after a reboot or two).

The driver i want to run is: NVIDIA-Linux-x86_64-1.0-8178-pkg2
The kernel is vanilla linux-2.6.15.3 (PREEMPT) compiled with Debian gcc 4.0.

I've searched this forum and found quite a bit of problems people have. The PREEMPT thing seems to be a problem, but I do not get the error message other people get.

I'm afraid this machine being an SMP system adds another dimension to the problem. I always had the feeling that nvidia does not really deal with SMP. This goes back to my Dual-PIII with a GeForce 4 card. What I'd like to see is an official statement by nvidia:

1) is the kernel module to be SMP safe?
1a) why not?
2) what compiler should one use when compiling an own kernel?
3) does nvidia test their drivers when a new kernel is released? or are they just testing against the most common SuSE / Fedora kernels ?
3a) why?

I wouldnt really bother making this 6200 card run on the Tyan K8W S2875 with the nvidia driver if only the nv driver did work. I'm also about to file a bugreport with xorg. *Sigh* this is neither cheap nor crappy hardware so that end should not be a problem.

Might any of the patches posted on this forum change anything? why? Shall I fallback to some older kernel? why?

thanks for any advice,
Raimund
Attached Files
File Type: zip nvidia-bug-report.log.zip (15.3 KB, 111 views)
File Type: zip Xorg.0.log-hang.zip (5.0 KB, 108 views)
nvRaimi is offline   Reply With Quote
Old 02-11-06, 05:36 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg does not start with 100% CPU on Dual-AMD64, 6200

I have a few questions:
0) Have you applied these patches?
http://www.nvnews.net/vbulletin/showthread.php?t=62021
1) Which BIOS version are you using?
2) Does this reproduce without a PREEMPT enabled kernel?
3) Is there a reason why your bug report has no X configuration or X log?
4) If you boot with the noapic and/or acpi=off kernel parameters does that have any impact on this problem?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-12-06, 05:03 AM   #3
nvRaimi
Registered User
 
Join Date: Sep 2005
Posts: 10
Default Re: Xorg does not start with 100% CPU on Dual-AMD64, 6200

Hi!

Quote:
0) Have you applied these patches?
http://www.nvnews.net/vbulletin/showthread.php?t=62021
not yet. gonna do that tomorrow when i'm physically around the machine to see the result.

Quote:
1) Which BIOS version are you using?
The logfile shows:
(--) NVIDIA(0): VideoBIOS: 05.44.a2.03.00
Do you need the System BIOS, too? It's some AMI-BIOS, I can write down the exact version tomorrow, too.

Quote:
2) Does this reproduce without a PREEMPT enabled kernel?
I'll try this tomorrow, too.

Quote:
3) Is there a reason why your bug report has no X configuration or X log?
I did not run the bug-report script immediately after the first crash. I attached the relevant X log in a separate file (Xorg.0.log-hang).

I did not hide the X configuration from the bug report script, so your bug-report script should have found it. I'll attach it.

Quote:
4) If you boot with the noapic and/or acpi=off kernel parameters does that have any impact on this problem?
I'll try that tomorrow, too. But turning of the APIC will prevent this from becoming an SMP system, doesnt it?

Thanks so far,
Raimund
Attached Files
File Type: zip xorg.conf.zip (1.2 KB, 117 views)
nvRaimi is offline   Reply With Quote
Old 02-12-06, 01:31 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Xorg does not start with 100% CPU on Dual-AMD64, 6200

I was referring to the motherboard BIOS version.

Disabling APIC should not prevent SMP support from working.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-13-06, 02:46 AM   #5
nvRaimi
Registered User
 
Join Date: Sep 2005
Posts: 10
Default Re: Xorg does not start with 100% CPU on Dual-AMD64, 6200

Hello again!

The system BIOS is an American Megatrends v02.53
Version: 08.00.10
Build date: 06/14/05
ID: 0AAAA000

noapic / acpi=off do not change anything (with nor without patches).

I applied NVIDIA_kernel-1.0-8178-U012206.diff.txt but that does not change anything.

Note: While Xorg is hanging at 100% CPU i cannot run the nvidia-bug-report utility. It blocks while cat(1)ing some nvidia card info from the /proc filesystem. Seems the driver completely locks up the CPU/kernel.

What's next? I'm willing to experiment.

Raimund
nvRaimi is offline   Reply With Quote
Old 02-13-06, 03:05 AM   #6
nvRaimi
Registered User
 
Join Date: Sep 2005
Posts: 10
Default Re: Xorg does not start with 100% CPU on Dual-AMD64, 6200

Update: apt-get upgrade just delivered a new Xorg, Version 6.9. With this version my card gets detected by the nv driver.

Since this is a (programming) workstation i can very well live without OpenGL and I am not so much willing to experiment any longer.

I think nvidia should once and for all declare if PREEMPT and SMP (or the nvidia model and SMP) can live together.

I would give some experiment a go again, but no wild guessing and permutating all possible toggles, sorry.

Raimund
nvRaimi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 10:11 AM

All times are GMT -5. The time now is 12:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.