Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-03-02, 05:01 AM   #25
sas
Guest
 
Posts: n/a
Default

oh and suing should work fine

are there any differences between your 2 device sections?

Also check your bios, if you have onboard/integrated graphics enabled make sure that you disable them
  Reply With Quote
Old 09-03-02, 08:57 AM   #26
BDKR
Guest
 
Posts: n/a
Default

Hey Sas,

The person with the two device settings was me.

But don't worry about. After I got out of the fog of anger from seeing my system hard lock then having to deal with the resulting failed fsck check at boot time, I got it figured out after taking a good look at one of the posts above.

But thanx for the concern.

And it works great now too. I'm still a little underpowered at the processor level (This is my workstation that I built in '98 with a K6-2 400), but it's still good for the lunch time blast.

Thanx!,
BDKR
  Reply With Quote
Old 09-03-02, 07:56 PM   #27
STeeLGuT
Guest
 
Posts: n/a
Default installed! but...

My screen isn't centered now...newbie here, anyone have a fix?

Thx in advance.


btw...great, clear instructions. I wanted to make sure I had lots of info before I attempted to install the drivers, because I screwed it up before.
  Reply With Quote
Old 09-05-02, 08:48 AM   #28
hanumani
Guest
 
Posts: n/a
Exclamation I hate NVidia, I hate linux (although I love it)

My X system is not booting, I've followed the instructions to a T, everything worked fine, but I get a prompt when booting and if I run xinit, I get a whole bunch of errors about Glx, I'm dying here, I need to work and am screwed because of some video driver upgrade that was working fine before!!!!!!!
  Reply With Quote
Old 09-05-02, 10:54 AM   #29
tommy
Guest
 
Posts: n/a
Default

Hey I've been trying to get X working with a GeForce 2 Go. First I had slackware 8.1 installed, but I figure for first dibs I better use RedHat, and because I didn't see a driver on this site for Slack - (don't fancy my chances of compiling one up straight away, I'm better off using an rpm).

Anyways I can't get it to work and running XFree86 -configure gives me an error. Is there a way to determine my version on XFree86, perhaps mine is too old?
  Reply With Quote
Old 09-08-02, 12:53 PM   #30
yaddab
Guest
 
Posts: n/a
Default Re: Re: Complete failure! help! (RH7.3)

Quote:
Originally posted by utiel


Try this:

boot in "init 3", or when X crash, enter as root and write "init 3" ( to kill your X Server )

If you have installed Nvidia RPMs, uninstall it.

To know if the are installed
~$ rpm -qa | grep NV
NVIDIA_GLX-1.0-2960
NVIDIA_kernel-1.0-2960

To erase
rpm -e NVIDIA_GLX NVIDIA_kernel

Now we have a clean system.
.....
.....

Hi,
Thanks guys for your help. But it turns out that the problem I had was of a different nature all together:

Please be advised, that you could try every trick in the book and still fail if you don't UPDATE your redhat 7.3 following installation and BEFORE attempting to configure nVidia drivers. You will get kernel related symbol conflict errors if you don't and will NEVER be able to run nVidia.

You see, when I initially installed redhat, the test that came up for configuring X failed inspite of many efforts to vary the resolution and color depth. However, running Xconfigurator allowed me to start X with a low resolution. In order to run it, I had to login without X (My bootloader is Grub. so I typed p when the grub menu came up, entered my password, then typed a, then typed (space) 3. Than loaded linux without X). Then I typed Xconfigurator, hit enter and followed the instructions of the program.
You could at this stage (before updating) modify the XF86Config-4 file to add additional resolution strengths for your screen, and to make sure that the horizontal and vertical sync rates for your monitor are correct. The driver section had to be kept as "vesa" for me as "nvidia" and "nv" would never work. Erasing (or adding a # before) "dri" and "GLcor" in the module section can be done now or later.
Once I was running X, I ran redhat update (I was in the KDE interface). I had to download more than 250MB.
Then I went to the nVidia website. I downloaded all the possible choices that would apply to an easy to find directory. Then I rebooted to load linux without X and logged in as root. The NVchooser.sh suggested I install the bigmem i686 kernel, but that didn't work. So I used the NVcheck.sh which was a wonderful tool. It helped me a great deal getting things done. I ended up having to use the src.rpm files (I followed the steps that the README file of nVidia suggested for source file installation). This time it worked like a charm. I modified the XF86Config-4 file so the driver section would be "nvidia". The NVcheck gave it the thumbs-up (it asserted that the installation worked). Then I rebooted the system. AND VIOLA! the nVidia logo came up, which gave me a great sense of relief, and everything worked just great.!
  Reply With Quote
Old 09-12-02, 02:26 AM   #31
Dnzauker
Registered User
 
Join Date: Sep 2002
Posts: 13
Default

let me get it staight yaddab:

you mean you had a working 7.3 box

THEN you downloaded and installed the drivers

THEN wou booted in a low resolution mode

THEN you ran the update wizard

THEN you edited the X-config file?

I installed the drivers, first from source, then from rpms and they still don't work. Do you think that if I boot in low resolution and then do the update trick even if I already edited the X-Configs it will work?
Dnzauker is offline   Reply With Quote
Old 09-12-02, 10:10 AM   #32
yaddab
Guest
 
Posts: n/a
Default

Quote:
Originally posted by Dnzauker
let me get it staight yaddab:

you mean you had a working 7.3 box

THEN you downloaded and installed the drivers

THEN wou booted in a low resolution mode

THEN you ran the update wizard

THEN you edited the X-config file?

I installed the drivers, first from source, then from rpms and they still don't work. Do you think that if I boot in low resolution and then do the update trick even if I already edited the X-Configs it will work?
Well it worked something like this:

1- I installed RH7.3 on my P4 1.3GHz box that has an nVidia Ge4 Ti 4600 vidio card. During RH installation, I did not succeed in confuguring X and the test failed. So I couldn't boot to X after installation.
If you were successful during the installation, the test would show you something like a desktop. This means that you should be able to start X. If that was the case, and you were happy with the screen resolution, you could skip to step 4 below.

2- I booted as root without X. I typed Xconfigurator and hit enter, and tried to get X to work. I had to play around with the numbers untill it accepted the configuration. It allowed a low resolution screen, and I was able to start X at this point.

3- I booted again without X and edited the XF86Config-4 file (type: vi /etc/X11/XF86Config-4 and hit i. When you are done and you want to save hit Esc then type :wq and hit enter. If you don't want to save, type :q! instead of :wq).
All I did was correct the horizontal and vertical sync figures for the monitor as per the manufacturer's published figures, and I changed the color depth and default depth and added higher resolutions to the modes. I made some mistakes initially, so when I started X it didn't work. You need to keep trying till it works.
This is how that section was:
Subsection "Display"
Depth 8
Modes "640x480"
EndSubSection
Subsection "Display"
Depth 8
Modes "640x480"
EndSubSection


This is how I modified it:
Subsection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
Subsection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection


You need to choose the resolution modes that you will be comfortable with and that your screen can support.

4- After starting X, register at RedHat Network and update your RH7.3 . To do that, start the Update Agent Configuration, then start the Update agent. My guess as to why this is important is that my box (and most new computers) has an i686 chipset. The linux kernel I installed was designed for i386. That kernel (if not updated) will cause conflicts with the NVIDIA kernel.

5- Now you could create an easy to find new directory (e.g. under your Desktop directory) and call it a convenient name (e.g. NVIDIA_drivers). Then go to the nVidia website:
http://www.nvidia.com/view.asp?IO=li...splay_1.0-2960
My advise is to download all applicable drivers (into the new directory you made):
For GLX: GLX RPM, GLX SOURCE RPM, and GLX Tar File.
For the kernel: RedHat 7.3 UP i386, RedHat 7.3 UP i686, RedHat 7.3 Bigmem i686, Kernel Source RPM, and Kernel Tar File.
I also downloaded the NVchooser.sh file:
http://download.nvidia.com/XFree86_4...0/NVchooser.sh
and the nv_check.sh file:
http://www.nvnews.net/vbulletin/atta...s=&postid=6583
I also printed out the README file. If you don't have a printer, or if you were not able to onfigure your printer, please get this file printed somewhere else before proceding.

6- Once all have been downloaded, you could either exit X or reboot without X. cd into the directory you made for nVidia drivers. Now type NVchooser.sh and hit enter. It will tell you which drivers to install. At this point you have a choice, either follow that advise, or go to step 8.

7- When I did the above, it advised me to install the GLX RPM and the RedHat 7.3 Bigmem i686. I did that (as per the README file), but I got error messages. Then I ran nv_check.sh and it told me that the installation didn't work. So I uninstalled both the GLX and the kernel.
You may be luckier. If you don't get error messages, you could go to step 9.

8- I followed the README file instructions for installing the source files for both the GLX and the kernel. This time the installation did not give any symbol conflict messages.

9- I modified the XF86Config-4 file: first the module section. type # at the begining of the both lines that read: Load "dri", and Load "GLcore" (alternatively, erase both lines). Make sure you have a line that reads: Load "glx".
This is how that section looks now:
Section "Module"
Load "dbe" # Double-buffering
# Load "GLcore" # OpenGL support
# Load "dri" # Direct rendering infrastructure
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection


Now edit the driver section. change the driver to "nvidia" (instead of "vesa" or "nv").
Once you have modified the config file, you could check your installation. I typed nv_check.sh and hit enter. It said that the installation was good.

10- Now startX, or reboot. To me, the best sign that the nVidia drivers have actually loaded correctly is to see the nVidia logo screen when I reboot. You could also go a step fu
rther and test your system to see if it is runninf openGL to the fullist capacity: open a console and do the following:
to check your versions type
glxinfo then hit enter.
to test it out type
glxgears then hit enter.

I hope this was helpful. Good Luck!!
  Reply With Quote

Old 09-21-02, 09:22 PM   #33
Kruno
TypeDef's assistant
 
Join Date: Jul 2002
Location: Australia
Posts: 1,641
Send a message via ICQ to Kruno Send a message via AIM to Kruno
Default

WTF???
GlxGears works perfect but my games (OpenGL) don't. WTF???
I try running Armagetron and it doesn't work.
So crackly strange

This is my error when trying to run Armagetron:
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Since I can run GLgears, is that a sign that my OGL driver works fine?
__________________
"Never before has any voice dared to utter the words of that tongue in Imladris, Mr. Anderson" - Elrond LOTR

Last edited by Kruno; 09-21-02 at 09:36 PM.
Kruno is offline   Reply With Quote
Old 09-25-02, 09:02 AM   #34
shadov
Guest
 
Posts: n/a
Default XFree86 -configure

I followed the instructions, but running
# XFree86 -configure
gives error:
Code:
Fatal server error:

XFree86 has found a valid card configuration.
Unfortunately the appropriate data has not been added to xf86PciInfo.h.
Please forward 'scanpci -v' output to XFree86 support team.

...
What does it mean?
Can I ignore it and just edit the original XF86Config-4 file?
  Reply With Quote
Old 09-25-02, 09:53 PM   #35
Kruno
TypeDef's assistant
 
Join Date: Jul 2002
Location: Australia
Posts: 1,641
Send a message via ICQ to Kruno Send a message via AIM to Kruno
Default

Go right ahead.
The way I done mine was.
Install the RPM's by double clicking on them. After that edit the bloody file and add: Load "glx". Then edit the video module and change "nv" and "vga" to nvidia.

Restart X and log in and then you will run anything OGL.
I never needed anything else. My distro is in my sig btw

Though I wonder where can I enable AF 8x and AA along with Digital Vibrance?
__________________
"Never before has any voice dared to utter the words of that tongue in Imladris, Mr. Anderson" - Elrond LOTR

Last edited by Kruno; 09-25-02 at 10:00 PM.
Kruno is offline   Reply With Quote
Old 09-26-02, 05:42 AM   #36
shadov
Guest
 
Posts: n/a
Default

Thanx!
I got it working. Load "glx" was already there so I just had to change "vesa" to "nvidia" in device section and set resolution and depth in display section.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Puts Tesla K20 GPU Coprocessor Through its Paces News Archived News Items 0 09-20-12 10:00 AM
NVIDIA Showcases GPU Breakthroughs at IBC 2012 News Archived News Items 0 09-07-12 10:10 AM
The Nvidia Forums Are Still Not Available, Finally We Know Why News Archived News Items 0 07-14-12 05:10 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM

All times are GMT -5. The time now is 06:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.