Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-13-06, 10:37 AM   #1
steve9001
Registered User
 
Join Date: May 2005
Posts: 3
Default GL apps kill 2d performance

Symptom: running any GL app causes the rest of the screen
to become extremely slow. I can see the terminal repainting
a scanline at a time.

Without a GL app it runs quickly.
1) Run only a terminal, "find /" OK
2) Run only glxgears OK
3) Run both: extremely slow.

Does anybody else get this problem?
Attached Files
File Type: zip nvidia-bug-report.log.zip (26.4 KB, 127 views)
steve9001 is offline   Reply With Quote
Old 02-13-06, 12:24 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GL apps kill 2d performance

In looking at your bug report something looks wrong with your kernel and/or BIOS, as all the interrupts are only being handled by one CPU, even though you have 4 (see /proc/interrupts). You should probably get this resolved, as you're effectively using a non-SMP system.

If this problem reproduces with 1.0-8178, please verify whether disabling RenderAccel has any impact.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-14-06, 06:00 AM   #3
steve9001
Registered User
 
Join Date: May 2005
Posts: 3
Default Re: GL apps kill 2d performance

There doesn't seem to be a bios option.
I've tried linux noacpi and disableapic to no avail.
Anything else I should try?

I get the problem with and without renderaccel
steve9001 is offline   Reply With Quote
Old 02-14-06, 10:14 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GL apps kill 2d performance

I'd suggest resolving your IRQ distribution problem first. As I mentioned, the IRQ problem is due to your kernel and/or your BIOS. I don't know that this forum is the best place to get assistance with those points of failure.

-Lonni
netllama is offline   Reply With Quote
Old 02-14-06, 09:06 PM   #5
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: GL apps kill 2d performance

Hi,

well, he could boot into some non graphic runlevel (not loading the nvidia module!), do some stuff that creates lots of interrups (using a mouse with gpm, copying around stuff etc) and, if still only one CPU gets the interrupts, go to his distributions bugzilla and open a bug. dmesg -s 100000, lspci -vvvx output is certainly welcome.
energyman76b is offline   Reply With Quote
Old 02-15-06, 04:48 AM   #6
steve9001
Registered User
 
Join Date: May 2005
Posts: 3
Default Re: GL apps kill 2d performance

Right, it seems that CONFIG_IRQBALANCE is not enabled in the stock
debian smp kernels for some reason. Installing the irqbalance package
seems to have sorted it out. (as an aside, I found it difficult to get
up to date documentation on this)

The symptoms are identical unfortunately.

Is there some kind of debugging/logging I can enable to track
this down further? What should I look at next? I've attached
the lspci -vvvx output.


Code:
           CPU0       CPU1       CPU2       CPU3
  0:     220309     170090     166145     160057    IO-APIC-edge  timer
  1:         50          0          0         14    IO-APIC-edge  i8042
  7:          0          0          0          0    IO-APIC-edge  parport0
  8:          3          0          0          0    IO-APIC-edge  rtc
  9:          0          0          0          0   IO-APIC-level  acpi
 14:       6338       2620       3551       3210    IO-APIC-edge  ide0
 15:        401        249        207        771    IO-APIC-edge  ide1
169:          0          0          0          0   IO-APIC-level  uhci_hcd:usb1
177:      19512          0          0          0   IO-APIC-level  uhci_hcd:usb2, eth0
185:       7305          0          0          0   IO-APIC-level  Intel 82801BA-ICH2, advansys
193:       3654      35310      37449       1765   IO-APIC-level  ohci1394, nvidia
NMI:          0          0          0          0
LOC:     716141     716140     716139     716138
ERR:          0
MIS:          0
Attached Files
File Type: txt lspci.vvvx.txt (12.7 KB, 124 views)
steve9001 is offline   Reply With Quote
Old 02-15-06, 06:52 AM   #7
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: GL apps kill 2d performance

Quote:
Originally Posted by steve9001
I've tried linux noacpi and disableapic to no avail.
I recently figured out that there doesn't exist a "stand-alone"
option "noacpi", at least not for recent kernels (maybe it existed
for older kernels). To get a different interrupt routing, you need to
apply "acpi=off", "pci=noacpi" or "pci=noirq", instead.

Since 2.6.14, i need to apply "acpi=off" or otherwise the system
silently reboots under graphics load (the other two options don't
help for me). I also experienced a 2D application slowdown when
running glxgears like you described it, but "acpi=off" made it
disapear. However, this option has some disadventages, or may
even have fatal consequences:

1. You need to powerdown you computer manually using the
power switch.

2. Since ACPI is not active, i'm pretty sure that the kernel compile time
option "Processor -> Theral zones" is also not active and the kernel
help pages says:

Quote:
Originally Posted by kernelconfig
This driver adds support for ACPI thermal zones. Most mobile and
some desktop systems support ACPI thermal zones. It is HIGHLY
recommended that this option be enabled, as your processor(s)
may be damaged without it.
From what i found out, this options prevents the CPU from demage
under overheat condition, i.e. when the CPU fan gets broken and the
CPU starts to get overheated, then the OS gets notified to power down
the system. I understand that as long as you make sure the CPU is
cooled well enough, it shoudn't be a problem to have this option disabled.

At least it seems to work for me for an Athlon64 X2, but if you are
applying "acpi=off", then be aware that you do it on your own risk!

Would be interessting to know if the 2D performance problem disapears
for you when applying "acpi=off".

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 02-15-06, 07:14 AM   #8
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: GL apps kill 2d performance

It can be not nVidia problem. I have infamous Asus A8N-VM CSM mainboard with broken bios. Everything looks good but when you start X the computer hangs. This is due to buggy DSDT table in bios. The acpi=noirq cures this.
zbiggy is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Panel: Exascaling Your Apps News Archived News Items 0 06-10-12 02:30 AM
Great apps for Release Preview: third-party Metro apps in Windows 8 News Archived News Items 0 06-02-12 03:10 AM
Exascale Apps Pave Way To Supercomputing Greatness News Archived News Items 0 05-16-12 11:30 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM

All times are GMT -5. The time now is 06:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.