Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-15-06, 06:11 PM   #1
neuron
Registered User
 
Join Date: Jan 2003
Location: Switzerland
Posts: 5
Default Xgl AMD64: No matching visual for __GLcontextMode

Hello all,
I am using Ubuntu's Xgl & compiz packages on AMD64, but am unable to get Xgl to run correctly.
Here's the (tail) output of
Code:
:~$ Xgl :2 -ac -accel xv:fdo -accel glx:pbuffer
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes = 32
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes = 32
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes = 32
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes = 32
While the server starts, opening an xterm & running glxinfo leads to this:
Code:
~$glxinfo
name of display: :2.0
X Error failed request:  BadAlloc (insufficient ressources for operation)
   Major opcode of failed request:  148 (GLX)
   Minor opcode of failed request:  3 (X_GLXCreateContext)
   Serial number of failed request:    16
   Current serial number in output stream:  17
At the same time, I receive this error in the term where I launched the server:
Code:
find_mesa_visual returned NULL for visualID = 0x002d
However, I have setup a 32bit chroot, with X / Xgl & the necessary NVidia drivers. Running Xgl from within the chroot works (compiz & wobbly windows also). Running glxheads :0 :2 from the chroot or not gives me thie following (:0 is normal, :2 is the 32bit chroot)
Code:
~$ glxheads :0 :2
Name: :0
  Display:     0x516540
  Window:      0x3c00002
  Context:     0x559680
  GL_VERSION:  2.0.1 NVIDIA 81.78
  GL_VENDOR:   NVIDIA Corporation
  GL_RENDERER: GeForce 6200/PCI/SSE2
Name: :2
  Display:     0x65a2e0
  Window:      0x400002
  Context:     0x660380
  GL_VERSION:  1.2 (2.0.1 NVIDIA 81.78)
  GL_VENDOR:   NVIDIA Corporation
  GL_RENDERER: GeForce 6200/PCI/SSE2
Is this a packaging issue, or is it an AMD64 specific bug. I am attaching the output of glxinfo from the 64bit environment, and from the 32bit chrrooted environment for comparison, if it helps.

Note: These errors & differences also occur when run from a shell, instead than from within an X session.
Attached Files
File Type: txt glxinfo_32.txt (2.9 KB, 121 views)
File Type: txt glxinfo_64.txt (10.1 KB, 133 views)
neuron is offline   Reply With Quote
Old 02-15-06, 06:41 PM   #2
d4rk74m4
Registered User
 
Join Date: Aug 2004
Posts: 72
Default Re: Xgl AMD64: No matching visual for __GLcontextMode

This looks like http://bugs.gentoo.org/show_bug.cgi?id=122140, which is freedesktop.org bug #5835. My guess is that the patch to fix it hasn't yet been added to the Ubuntu xorg-server package.
d4rk74m4 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Maximus Fires Up Visual Effects In Men in Black 3 News Archived News Items 0 06-26-12 06:00 PM

All times are GMT -5. The time now is 10:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.