Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-17-06, 04:32 PM   #1
geezer
Registered User
 
Join Date: Jul 2005
Posts: 59
Default NVagp will not load

Hi, I've been to get the NV agp to load but can't. All I can use is agpgart or pci.

If I set nvagp = 1 X will not start at all. I've tried compiling kernel 2.6.12 with various settings for agp and dri but nothing seems to help.

When I compile kernel with no agpgart support as the readme says, nvagp still wont load and I have no errors or messages about agp in dmesg or /var/log/messages.

NV mx420
Slackware linux 10.2
2.6.12 kernel
geezer is offline   Reply With Quote
Old 02-17-06, 05:19 PM   #2
geezer
Registered User
 
Join Date: Jul 2005
Posts: 59
Default Re: NVagp will not load

this may help
Attached Files
File Type: log nvidia-installer.log (21.1 KB, 126 views)
geezer is offline   Reply With Quote
Old 02-17-06, 05:21 PM   #3
geezer
Registered User
 
Join Date: Jul 2005
Posts: 59
Default Re: NVagp will not load

.
Attached Files
File Type: log nvidia-bug-report.log (79.7 KB, 120 views)
geezer is offline   Reply With Quote
Old 02-17-06, 06:05 PM   #4
geezer
Registered User
 
Join Date: Jul 2005
Posts: 59
Default Re: NVagp will not load

Just looking thru installer log and i see:

-DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT

I have compiled kernel with agpgart out, but does this mean somehow it is still seeing it?

I'm going to update kernel to 2.6.15 and report back
geezer is offline   Reply With Quote
Old 02-18-06, 04:57 PM   #5
geezer
Registered User
 
Join Date: Jul 2005
Posts: 59
Default Re: NVagp will not load

Ok same problem with 2.6.15

How can I get nvagp working??
geezer is offline   Reply With Quote
Old 02-18-06, 05:59 PM   #6
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: NVagp will not load

Is there a reason for wanting this? I use agpgart, what is wrong with that?
pe1chl is offline   Reply With Quote
Old 02-18-06, 08:26 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVagp will not load

Your bug report indicates that you have a [SiS] 746 AGP chipset. Per the NVIDIA README, that chipset is not supported by NvAGP. You'll need to use the kernel's AGP support.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Can't load NVdriver jojotux123 NVIDIA Linux 4 09-18-02 06:15 AM
load "GLX" issue on Slack 8.1 psychothiz NVIDIA Linux 4 09-08-02 11:19 PM

All times are GMT -5. The time now is 07:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.