Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-21-03, 10:18 AM   #1
douga
Registered User
 
Join Date: Jan 2003
Location: California
Posts: 2
Default Artifact on screen when leaving X?

I'm using the newest nvidia driver on my machine with Slackware 8.1. I have the kernel compiled to NOT use AGP, and I don't have any AGP settings in my XF86Config. I DO have glx loaded.

When I exit X, I sometimes get a rectangle of color in the lower right hand quarter or eighth of the screen. If I then startx again, I rectangle may move, but it doesn't go away. I'm using the Riva TNT card that came with my Dell (about two years old, I think).

Anyone seen anything like this?

Thanks for any help.
douga is offline   Reply With Quote
Old 01-27-03, 07:35 AM   #2
michal017
Registered User
 
Join Date: Jan 2003
Posts: 5
Default

I'm seeing a similar problem.. when leaving X (sometimes) I have sort of shadow on the screen so I can't see the console.

Some guy suggested to 'reset the DRI (or was it Xv?) memory space correctly' but I don't know how to do that
michal017 is offline   Reply With Quote
Old 01-27-03, 09:05 AM   #3
douga
Registered User
 
Join Date: Jan 2003
Location: California
Posts: 2
Default

Quote:
Originally posted by michal017
I'm seeing a similar problem.. when leaving X (sometimes) I have sort of shadow on the screen so I can't see the console.

Some guy suggested to 'reset the DRI (or was it Xv?) memory space correctly' but I don't know how to do that
I found *a* solution to this problem, but I don't know if it's *the* solution.

First off, I had to load the nvidia module last in rc.modules. Then, I set NvAGP to "1" in my XF86Config, and recompiled my kernel so that it didn't support AGP.

As far as the DRI goes, I know that if you have a line that says "load dri" in your XF86Config, you should comment it out.
douga is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 08:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.