Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-23-06, 08:07 AM   #1
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Unable to install and get sound of 1.0-8178

Trying to install the 1.0-8178 package (on my SuSE 9.3) I get the error message "ERROR: Unable to load the kernel module 'nvidia.ko'.
This is most likely because the kernel module was built using the wrong kernel source files. Please make sure you have installed the kernel source files ".
Nevertheless I have installed the complete source-tree (and issue the install command as root from the kernel location). With an earlier version of the package
I was able to construct the nvidia.ko module, and it sits somewhere in the source-tree. I am able to get an unpleasent noise with the command
cat sweet.wav /dev/nvididia0 (indeed, no ">"), but I'd hope for something better than this.
The nvidia.ko was made from NFORCE-Linux-x86_64-1.0-0310-pkg1, and I was able to start the panel nvmixer, but got no sound from that (only the unpleasent sound from above).
Anyone a suggestion how to link this to firefox, to go to a radiostation or use skype? And on docs about the use of this nvidia package?
Thanks
PS system: athlon A8NE with nforce4Ultra
julathlon is offline   Reply With Quote
Old 02-23-06, 02:25 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to install and get sound of 1.0-8178

nvidia.ko is the graphics driver, not the NFORCE sound driver. The sound driver is nvsound.ko. Also, /dev/nvidia0 is the device for the graphics driver. I'm not sure what catting a wav file into /dev/nvidia0 would do, other than potentially crash X.

Please generate and post an nforce-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-23-06, 02:44 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Unable to install and get sound of 1.0-8178

It wouldn't do anything harmful, the graphics driver doesn't implement the read/write file operations for /dev/nvidia*.
zander is offline   Reply With Quote
Old 02-23-06, 03:43 PM   #4
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Re: Unable to install and get sound of 1.0-8178

Was not aware that nvidia.ko was a graphics driver. Saw it was (withit's nv characters) in the /dev tree, and thougt it would do. In particular since my speakers gave some noise after catting a wav file to /dev/nvidia1. Then again I don't have any nvsound? in my /dev-tree. (How to generate them?)
After sending this I'll send nforce-bug-report.log and nvidia-installer.log for your attention at linux-nforce-bugs@nvidia.com.
Thanks for your help!
Julien
julathlon is offline   Reply With Quote
Old 02-23-06, 04:05 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to install and get sound of 1.0-8178

Please post the bug report here, there's no need to email it.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-23-06, 05:09 PM   #6
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Re: Unable to install and get sound of 1.0-8178

OK, as you wish. Ehm, 302K exceeds upload-limit of 100K. But already sent it to linux-nforce-bugs. Was not passed on to you?
julathlon is offline   Reply With Quote
Old 02-23-06, 05:11 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to install and get sound of 1.0-8178

You can compress the bug report to post it here.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-24-06, 05:47 AM   #8
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Re: Unable to install and get sound of 1.0-8178

Both logs (nforce-bug-report and nvidia-installer) are attached. In an earlier message you said I should have used /dev/nvsound to listen to audio-output. Non of this is on my machine, and also google does not know /dev/nvsound. Does nvidia have a script (command-suggestion?) to create it?
Thank you.
julathlon is offline   Reply With Quote

Old 02-24-06, 12:14 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to install and get sound of 1.0-8178

I don't see anywhere that I stated that /dev/nvsound was used. I stated that the NFORCE sound module is nvsound.ko.

You've not attached any bug reports in this thread. Please do so.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-24-06, 01:53 PM   #10
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Re: Unable to install and get sound of 1.0-8178

Had uploaded them. this morning, and had thought they would arrive. Hopefully you get them now. (Will check for reply in 30 minutes (19.30 GMT))
julathlon is offline   Reply With Quote
Old 02-24-06, 03:07 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Unable to install and get sound of 1.0-8178

I'm not clear where you've uploaded the bug reports, however they should be attached (and instantly viewable) to this thread.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-24-06, 03:45 PM   #12
julathlon
Registered User
 
Join Date: Feb 2006
Posts: 25
Default Re: Unable to get sound of 1.0-8178; what devicename to use?

Quote:
Originally Posted by netllama
nvidia.ko is the graphics driver, not the NFORCE sound driver. The sound driver is nvsound.ko. Also, /dev/nvidia0 is the device for the graphics driver. I'm not sure what catting a wav file into /dev/nvidia0 would do, other than potentially crash X.
Lonni
This was the source of my mistakenly thinking there was a "/dev/nvsound"
Appearently the /dev/nvidia0 should not be used to produce sound, but yet this is the one and only device I could cat a wav file into and get sound out of my speakers. What is the legitimate device to cat sound into to test a nvidia configuration?
julathlon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.