Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-12-02, 03:46 AM   #1
Rob C.
Guest
 
Posts: n/a
Lightbulb Xtacy t14600, Redhat 7.3.. X but no logo.

I went through all the threads and with much wisdom I installed and uninstalled the to .rpm files several times before getting it right! The search function of these forums is awesome.. T-bird is the man... I found several threads where his advice paid off..... Thank you Thunderbird..Anyway.

I am able to startx.. but I don't get the famed nVidia logo everyone seems to get? I checked my XF86Config-4 and the only stuff loading is nVidia based. I even deleted my XF86Config just to be sure I was using the XF86Config-4. Also my screen is not aligned properly and when I use xvidtune I am still not able to totally correct it.. Anyone have any suggestions?

Here is my config.

#####################################START

# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Red Hat Linux 6.0 and later use the xfs font server for improved
# interactive performance

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe"# Double-buffering
# Load "GLcore"# OpenGL support
# Load "dri"# Direct rendering infrastructure
Load "glx"# OpenGL X protocol interface
Load "extmod"# Misc. required extensions
Load "v4l"# Video4Linux
# Load "record"# X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1"# Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout""us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Envision"
VendorName "Envision"
ModelName "Envision"
HorizSync 30-90
VertRefresh 50-70
Option "dpms"
EndSection

Section "Device"
Identifier "NVIDIA GeForce 4 (generic)"
# Driver "vesa"
Driver "nvidia"
BoardName "ti4600"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "ti4600"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Envision"
DefaultDepth 16
Subsection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

#################################END

Thank you in advance!
  Reply With Quote
Old 08-12-02, 04:31 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

The XF86Config-4 part looks ok to me.

You can try "cat /proc/driver/nvidia/version" to see what nvidia driver version you are using. And also check the output of "glxinfo" to see if you are using the nvidia driver stuff. (If correct that output will say that the vendor is nvidia, what version number you are using and it will spit out a lot of GL extensions.)
Thunderbird is offline   Reply With Quote
Old 08-12-02, 04:55 AM   #3
Rob C.
Guest
 
Posts: n/a
Default Thanks Thunderbird...

Code:
$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA NVdriver Kernel Module  1.0-2960  Tue May 14 07:41:42 PDT 2002
GCC version:  gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
  Reply With Quote
Old 08-12-02, 04:57 AM   #4
Rob C.
Guest
 
Posts: n/a
Default

Code:
$glxinfo
 
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.2
server glx extensions:
  GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,  
  GLX_SGIX_pbuffer, GLX_ARB_multisample
client glx vendor string: NVIDIA Corporation
client glx version string: 1.2
client glx extensions:
  GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,  
  GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,  
  GLX_SGIX_swap_group, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig,  
  GLX_SGIX_pbuffer
GLX extensions:
  GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,  
  GLX_SGIX_pbuffer, GLX_ARB_multisample, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 Ti 4600/AGP/3DNOW!
OpenGL version string: 1.3.1 NVIDIA 29.60
OpenGL extensions:
  GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,  
  GL_ARB_texture_border_clamp, GL_ARB_texture_compression,  
  GL_ARB_texture_cube_map, GL_ARB_texture_env_add,  
  GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,  
  GL_ARB_transpose_matrix, GL_S3_s3tc, GL_EXT_abgr, GL_EXT_bgra,  
  GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,  
  GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,  
  GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,  
  GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_rescale_normal,  
  GL_EXT_secondary_color, GL_EXT_separate_specular_color,  
  GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_texture3D,  
  GL_EXT_texture_compression_s3tc, GL_EXT_texture_edge_clamp,  
  GL_EXT_texture_env_add, GL_EXT_texture_env_combine,  
  GL_EXT_texture_env_dot3, GL_EXT_texture_cube_map,  
  GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod,  
  GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,  
  GL_EXT_vertex_weighting, GL_HP_occlusion_test,  
  GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,  
  GL_NV_copy_depth_to_color, GL_NV_evaluators, GL_NV_fence,  
  GL_NV_fog_distance, GL_NV_light_max_exponent,  
  GL_NV_multisample_filter_hint, GL_NV_occlusion_query,  
  GL_NV_packed_depth_stencil, GL_NV_point_sprite, GL_NV_register_combiners,  
  GL_NV_register_combiners2, GL_NV_texgen_reflection,  
  GL_NV_texture_compression_vtc, GL_NV_texture_env_combine4,  
  GL_NV_texture_rectangle, GL_NV_texture_shader, GL_NV_texture_shader2,  
  GL_NV_texture_shader3, GL_NV_vertex_array_range,  
  GL_NV_vertex_array_range2, GL_NV_vertex_program, GL_NV_vertex_program1_1,  
  GL_SGIS_generate_mipmap, GL_SGIS_multitexture, GL_SGIS_texture_lod,  
  GL_SGIX_depth_texture, GL_SGIX_shadow
glu version: 1.3
glu extensions:
  GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
 
  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x21 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x22 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x23 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x24 16 tc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 None
0x25 16 tc  0 16  0 r  .  .  5  6  5  0  0 24  8 16 16 16 16  0 0 None
0x26 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 Ncon
0x27 16 tc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 Ncon
0x28 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 Ncon
0x29 16 tc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 Ncon
0x2a 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x2b 16 dc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 None
0x2c 16 dc  0 16  0 r  .  .  5  6  5  0  0 24  8 16 16 16 16  0 0 None
0x2d 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 Ncon
0x2e 16 dc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 Ncon
0x2f 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 Ncon
0x30 16 dc  0 16  0 r  y  .  5  6  5  0  0 24  8 16 16 16 16  0 0 Ncon
  Reply With Quote
Old 08-12-02, 05:00 AM   #5
Rob C.
Guest
 
Posts: n/a
Default

I made a new config with the XFree86 -configure command and I was able to correct my alignment issues. No nVidia logo however. I am able to play Quake 3 Arena v.1.31 without any lag.. But I am concerned I missed a small step somewhere and may have issues in the future.
  Reply With Quote
Old 08-12-02, 05:04 AM   #6
Rob C.
Guest
 
Posts: n/a
Default

Incidently here is an output from glxgears... I am not sure what a good output is but I am sure someone else can run it and benchmark it for me..

$glxgears

73712 frames in 5.0 seconds = 14742.400 FPS
77294 frames in 5.0 seconds = 15458.800 FPS
71461 frames in 5.0 seconds = 14292.200 FPS
62573 frames in 5.0 seconds = 12514.600 FPS
61719 frames in 5.0 seconds = 12343.800 FPS
76893 frames in 5.0 seconds = 15378.600 FPS
78637 frames in 5.0 seconds = 15727.400 FPS
  Reply With Quote
Old 08-12-02, 05:44 AM   #7
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

All looks ok. The only time you will see the X logo is the first time you start X after a reboot. For the rest it is ok.
Thunderbird is offline   Reply With Quote
Old 08-12-02, 09:07 AM   #8
rupertshocking
Guest
 
Posts: n/a
Default Check the documentation on the nforce drivers...

I found a XFree86-conf directive to enable disable the graphical splash you can find it in the install readme or some such. included in the rpm drivers ... find it by doing a rpm -qp --list YourRPMFile.rpm this was for the nforce chipset.
  Reply With Quote

Old 08-12-02, 09:28 AM   #9
Rob C.
Guest
 
Posts: n/a
Default

My option for disabling the logo is not set. Everything seems to be in order even though I get no logo.

BTW... the command is

#Option "NoLogo"

Here are the rest

Code:
 
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "DigitalVibrance"           # <i>
        #Option     "PageFlip"                  # [<bool>]
        #Option     "Dac8Bit"                   # [<bool>]
        #Option     "NoLogo"                    # [<bool>]
        #Option     "Overlay"                   # [<bool>]
        #Option     "UBB"                       # [<bool>]
        #Option     "Stereo"                    # [<bool>]
        #Option     "BlueLine"                  # [<bool>]
        #Option     "WindowFlip"                # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "HWcursor"                  # [<bool>]
        #Option     "VideoKey"                  # <i>
        #Option     "NvAGP"                     # <i>
        #Option     "PixmapCacheLines"          # <i>
        #Option     "IgnoreEDID"                # [<bool>]
        #Option     "NoDDC"                     # [<bool>]
        #Option     "ConnectedMonitor"          # <str>
        #Option     "ConnectedMonitors"         # <str>
 #Option     "TVStandard"                # <str>
        #Option     "TVOutFormat"               # <str>
        #Option     "NoRenderAccel"             # [<bool>]
        #Option     "CursorShadow"              # [<bool>]
        #Option     "CursorShadowAlpha"         # <i>
        #Option     "CursorShadowXOffset"       # <i>
        #Option     "CursorShadowYOffset"       # <i>
        #Option     "UseEdidFreqs"              # [<bool>]
        #Option     "FlatPanelProperties"       # <str>
        #Option     "UseInt10Module"            # [<bool>]
        #Option     "SwapReady"                 # [<bool>]
        #Option     "NoTwinViewXineramaInfo"    # [<bool>]
        #Option     "NoRenderExtension"         # [<bool>]
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 12:26 PM
Working RedHat 7.3 with Nvidia?? Be'Lal NVIDIA Linux 3 08-03-02 05:16 PM
2960 drivers, redhat 7.3, kernel normanpang NVIDIA Linux 6 08-03-02 12:11 AM

All times are GMT -5. The time now is 09:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.