Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-22-03, 11:53 PM   #1
nauticus
Registered User
 
Join Date: Jan 2003
Posts: 3
Exclamation Red Hat 8 error on installing driver binaries

when i type in
rpm -ivh NVIDIA_kernel-1.0-4192.rh80up_2.4.18_18.8.0.athlon.rpm
to install the kernel drivers, th gives me this error at the end of the output:

failed to install nvidia.o

error: %post(NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0) scriptlet failed, exit status 1


i run a geforce 2 gts and a 1.2 ghz athlon
thanx in advance

i also have the newest red hat linux kernel update
nauticus is offline   Reply With Quote
Old 01-23-03, 08:58 AM   #2
jnd3
Sword Saint
 
jnd3's Avatar
 
Join Date: Jul 2002
Location: Alpharetta, GA USA
Posts: 465
Send a message via AIM to jnd3 Send a message via Yahoo to jnd3
Default

Get the source RPM. I think the latest kernel update from RH is -19.8.0, not -18.8.0, so there is a version mismatch. Check the readme for how to do the install from source RPM. It's an extra step of "rpmbuild --rebuid source.rpm"...

Cheers,
JND
jnd3 is offline   Reply With Quote
Old 01-23-03, 12:15 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

And make sure you have kernel-source-2.4.18-19.8.0 installed and configured as well.

Configure it by looking in the /usr/src/linux/configs/ directory for something that matches your hardware, copying it to ../.config, going to /usr/src/linux, and running make mrproper oldconfig dep.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-23-03, 08:14 PM   #4
nauticus
Registered User
 
Join Date: Jan 2003
Posts: 3
Default

oh... version mismatch... i am SOOO stupid
thanx for the help!
nauticus is offline   Reply With Quote
Old 01-23-03, 08:34 PM   #5
nauticus
Registered User
 
Join Date: Jan 2003
Posts: 3
Default

i tried rebuilding the source rpm
rpmbuild --rebuild NVIDIA_kernel-1.0-4191.src.rpm
and i get this at the end of the output:

RPM build errors:
user buildmeister does not exist - using root
group buildmeister does not exist - using root
user buildmeister does not exist - using root
group buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.24123 (%install)

whats going on?
nauticus is offline   Reply With Quote
Old 01-24-03, 07:59 AM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Those errors shouldn't matter... as long as you got a .rpm file in the output directory, you should be good. If you didn't, then there were other errors that you haven't posted.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 12:25 PM
red hat distros gadido NVIDIA Linux 3 09-02-02 05:17 PM
Red Hat Linux and Dell Inspiron 8200 haridamineni NVIDIA Linux 3 08-27-02 12:37 PM
Source RPMS for GCC3.2 - Red Hat 8.0? chrisw01 NVIDIA Linux 4 08-21-02 08:17 AM

All times are GMT -5. The time now is 09:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.