Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-06, 06:05 PM   #1
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

Hi,

I used to have a very stable box, but then some customer comes along and takes away from me my good old MSI K8MM-V
no problem I thought, I'll just replace it with one of the new fangled gf6100-based motherboard !

so I got a MSI K8NGM-V board (matx, s754, pci-e (but using onboard video), geforce 6100 (I'm assuming this is the northbridge actually)+ nforce410(guess it's the southbridge))

on the old system everything worked and the installed OS (gentoo) I could take the hard-drive put it in a similar machine that has a nforce3 chipset (MSI K8N Neo V2.0) and the sound and the rest also worked

the box that had a K8MM-V in it had an old nondescript geforce 3 and the nvidia driver worked well

so I just swapped the motherboard and booted (that usually works as opposed to what happens in windows-world )
it booted correctly but X wouldn't start (as expected, I only had to change the BusID in xorg.conf) but then things started to go bad

when I tried to run with the nvidia driver, it said it wouldn't detect (as far as I can tell now all the settings are correct in xorg.conf) the driver just says can't initialize , no nvidia gpu found

first thing I did I upgraded from 8174 to 8178, no effect
then I upgrade from 2.6.14.7 to 2.6.15.1 (and enabled PCI-E support)
no effect

so I figured this new chipset just isn't supported yet so I switched to vesa and it worked (of course)

then I noticed the sound wasn't working (alsa doesn't detect a sound card at all) this board uses the Realtek ALC655 codec chip, I checked the alsa config and kernel config , I already had the intel8x0 driver compiled in, it should have detected it, so I guess this new sound chip just isn't supported yet either

now I opened xchat and firefox and started searching
didn't get help in #gentoo nor #nvidia nor #alsa :\
searched this forum but outside of that lengthy nforce 430 thread there's not much about this new chipset series :\

and while I was doing that researching I had to reboot a couple time, the mouse (usb logitech) stopped working, and unplugging and replugging it didn't make it work again (and when it happenned lsusb stopped seeing the mouse too), I tried to keep working keyboard-only when it happenned but I realised that the network stopped responding at exactly the same time (wouldn't even ping it's default gateway nor any other box that are just one hop away on the catalyst)

so I have no sound, barely working video and intermittent silent-failling usb and network

at this point I'll take any help you guys might have to offer !

thanks, bye
shodan

Last edited by shodanx; 02-28-06 at 06:41 PM.
shodanx is offline   Reply With Quote
Old 02-28-06, 06:08 PM   #2
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

oh, btw that network/usb problem is very probably irq related , if I leave the usb alone it doesn't crash even after extended periods of using the network , I guess if I unhook the network cable and keep using the usb it probably won't stop working either , I think they both use irq 10, maybe some driver problem because they are probably meant to share irq since they apparently are living on the same chip !

reminds me a lot of that sb live and network card irq sharing weirdness
shodanx is offline   Reply With Quote
Old 02-28-06, 06:20 PM   #3
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

after reading this thread

Spurious interrupts with GeForce 6150 / nForce 430

I thought about checking my /proc/interupts
glitch ~ # cat /proc/interrupts
CPU0
0: 2403932 IO-APIC-edge timer
1: 1493 IO-APIC-edge i8042
5: 239721 IO-APIC-edge ehci_hcd:usb1, ohci_hcd:usb2, eth0
7: 2 IO-APIC-edge parport0
8: 2 IO-APIC-edge rtc
10: 0 IO-APIC-edge i2c-pca-isa
14: 3454 IO-APIC-edge ide0
NMI: 0
LOC: 2403880
ERR: 0
MIS: 0

I was mistaken both network and usb are on irq5

I also uploaded my .config file to my website you can get it right here

tell me if you want anything else (I'll try to think of things to collect and post them as I find them)
shodanx is offline   Reply With Quote
Old 02-28-06, 06:36 PM   #4
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

here are some things I got from /proc

cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 44
model name : AMD Sempron(tm) Processor 2600+
stepping : 2
cpu MHz : 1607.326
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm
bogomips : 3218.02

/proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC).

lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.2 Multimedia audio controller: nVidia Corporation MCP51 AC97 Audio Controller (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

and I uploaded lspci -v in a file to save some space on this thread

I'm running vesa right now so the nvidia kernel module doesn't get loaded
I loaded it to get some more data

this was in the dmesg

nvidia: module license 'NVIDIA' taints kernel.
PCI: Setting latency timer of device 0000:00:05.0 to 64
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-8178 Wed Dec 14 16:22:51 PST 2005

I also uploaded the full dmesg right here

I re-edited xorg to use the nvidia driver and ran it (from entrance a xdm-like program)
I uploaded the log here
shodanx is offline   Reply With Quote
Old 02-28-06, 06:48 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-28-06, 07:26 PM   #6
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

one nvidia-bug-report.log coming up

looking at what I'm sending looks like the NVRM syslog messages are interesting
looks like it caught something that escaped me

Feb 28 01:45:10 glitch NVRM: Tried to get irq 10, but another driverNVRM: has it and is not sharing it.
Feb 28 01:45:10 glitch NVRM: you may want to verify that an audio driver isn't using the irq
Feb 28 01:45:10 glitch NVRM: isr request failed 0xfffffff0

(I guess you can ignore the Feb 26 20: entries , that error is because I started X after upgrading the nvidia driver, the module version mismatched the xorg driver version)
shodanx is offline   Reply With Quote
Old 02-28-06, 07:29 PM   #7
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

I have checked for a new bios but this board is too recent there aren't any yet
I'll try disabling anything non-essential in the bios to see if something helps

I also have spare parts for everything so I'll try swapping components to see if it helps (not much else I can do at this point I guess)
shodanx is offline   Reply With Quote
Old 02-28-06, 07:42 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

Yes, the lack of IRQ sharing certainly seems to be the problem. Other than being able to reassign IRQs in the BIOS, I can't think of anything else that can be done to resolve this without MSI's assistance.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 02-28-06, 07:47 PM   #9
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

I went in the bios disabled some stuff, here's what I changed

cpu/pcie/sata spread spectrum to disable
IOAPIC disabled
usb and sound controllers disabled
floppy, COM1/2, LPT disabled
sata disabled
cool'n'quiet (this notorious trouble maker was already disabled)

all that's left now is the acpi and manually reserving IRQ's and DMA's in "PNP/PCI Configuration" IRQ/DMA Resource Setup
and some hypertransport controller and integrated memory controller settings

I tried to boot, as far as getting the graphics to work with the nvidia driver there's no change

this error
NVRM: Tried to get irq 10, but another driverNVRM: has it and is not sharing it.
NVRM: you may want to verify that an audio driver isn't using the irq
NVRM: isr request failed 0xfffffff0

is still here , maybe if I set irq 10 to RESERVED it might help I'll probably try that next

in the bios, in the "Advanced Chipset Features" there are a few settings about the hypertransport controller, some of them are about the graphic subsystem

I couldn't take a screenshot so I took a picture with my 300D



I'm not positive what all these settings do, the manual isn't much help
maybe if you spot something in there ....
shodanx is offline   Reply With Quote
Old 02-28-06, 07:50 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

I don't see anything in that screenshot that would have any impact on this problem. Have you tried disabling the sound/audio modules?

-Lonni
netllama is offline   Reply With Quote
Old 02-28-06, 08:03 PM   #11
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

after reading your last message I gave reserving the IRQ and guess what, that did it
I just rebooted and straight into fully accelerated xorg it went, I'll start re-enabling subsystems one-by-one to be sure

now that is some serious ISA-era trick (though still fresh in my memory because I had to do it on some late 90's box to get a high speed isa ISIS scanner fpga-based ISA controller to work that didn't even understand isapnp just last week !)

I guess MSI is too blame, but they'll probably fix that in the next bios update, what I'm curious is how is windows dealing with this, it probably wouldn't pass Q/C if windows couldn't get it to work, and if windows can get it to work then surely linux can right (without all that ressource-hacking hudge-pudge) ?

for anyone else reading this thread, maybe having the same problem I took a couple pictures to show what I just did


first go in this menu (PNP/PCI Configurations)



then into IRQ Resource Setup



and finally, according to you dmesg logs set the irq that the driver wants to use (in my case IRQ 10) to reserved
shodanx is offline   Reply With Quote
Old 02-28-06, 08:11 PM   #12
shodanx
Registered User
 
Join Date: Nov 2004
Posts: 12
Default Re: Naughty MSI K8NGM-V (gf6100+nf410) prob w/ video,sound,usb and network !

netllama,

can you confirm that the hypertransport configuration settings mean the following

LDT(K8) to NB Frequency
Lightning Data Transport to North Bridge Frequency

NB to NVIDIA(SB) Frequency
North Bridge to nvidia South Bridge Frequency

LDT(K8) to NBLinkWidth
Lightning Data Transport to North Bridge LinkWidth

NB to NVIDIA(SB) LinkWidth
North Bridge to nvidia South Bridge LinkWidth

those two frequency settings can be pushed to 1000Mhz, is there any reason to leave that to 800 ?
also North Bridge to nvidia South Bridge LinkWidth can be set to 16 down 16 up instead of 8/8 , is there any reason not to ? (are those datapath used by something else or maybe they are not preset or enabling would degrade performance for some reason ?)

and lastly, I guess this isn't the forum for this but is the sound supposed to work with alsa yet ? or is this new chipset just too new ?

thanks
Shodan
shodanx is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.