Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-19-03, 10:39 PM   #37
KiiPart
Registered User
 
Join Date: Mar 2003
Location: Earth...
Posts: 2
Red face I've the same problem, too.

I also have the same problem on my GF4 420Go.

Although I can fire up the /dev/fb0 by rivafb on the
Slackware8.1 kernel 2.4.18 and startx well to play the
mpeg files. But the console mode was blank entirly from
kernel init started to login after. Thus I also blindly typed
the commands. I did not prefer to use the nV's official drivers
which contain the GL and kernel part, especially the object
file in that kernel package......

So did anybody have any idea to solve these issue???
To avoid typing the command blindly like a @#$%!!


KiiPart,
__________________
~ Best regards ~
KiiPart is offline   Reply With Quote
Old 03-20-03, 02:10 PM   #38
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

You cannot use rivafb. You have to use vesafb instead.

rivafb and the nVidia drivers are two independent drivers trying to share the same device. This causes bad, bad things to happen (like your blank screen). Enable the "VESA VGA console" option in your kernel, and disable the "Riva 128" one.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-20-03, 08:59 PM   #39
KiiPart
Registered User
 
Join Date: Mar 2003
Location: Earth...
Posts: 2
Thumbs up

Thanks, bwkaz!!

I did not attempt to use the nVidia drivers,
instead I would like the rivafb cause that
nVidia drivers included the Object(.obj) file
ONLY we cannot touch it deeply enough .

But, in the console mode on the rivafb, the
screen only blank(2.4.18). On the same time
in the console mode, the system ran well except
didn't display any words/letters on, also, the
mouse cursor can move around on the top line
of the screen.

I guessed that the rivafb's codes have a little
problem but I did not know where and how to
modify that!! So, could someone have an idea
on that


KiiPart,
__________________
~ Best regards ~
KiiPart is offline   Reply With Quote
Old 03-29-03, 01:37 AM   #40
SpaceMunkey
Registered User
 
SpaceMunkey's Avatar
 
Join Date: Mar 2003
Posts: 17
Default

Quote:
Originally posted by spart
Same problem here with an nForce2 IGP (GeForce 4)/XFree 4.2.1 on a linux kernel 2.4.20 (Debian testing) with nvidia driver release 4191.

I sent a BR too...
Guess we just have to wait :-(
I've had the same problem too (switching to console mode from xwindows). For some reason when twinview is enabled the problem does not occur. Turn off twinview mode and it's back. I've tried this with a high res frame buffer (vga=788) and with the framebuffer disabled.

specs:
nforce2 IGP (GeForce4)
xfree 4.2.0
nvidia driver 4191
kernel 2.4.20
dist: suse 8.1
SpaceMunkey is offline   Reply With Quote
Old 03-29-03, 04:59 PM   #41
ninjachinchilla
Registered User
 
Join Date: Mar 2003
Posts: 9
Default For GeForce 4MX IGP

I have a GeForce4MX IGP (SN41G2). When I switch to init 3 and install the drivers, then startx, the drivers work fine. When i reboot, i get stuck at a blank screen. Any ideas?
ninjachinchilla is offline   Reply With Quote
Old 03-30-03, 01:52 PM   #42
moali
Registered User
 
Join Date: Oct 2002
Location: Austria
Posts: 31
Default Re: btw - what about the old drivers?

Quote:
Originally posted by bimbo00
Does anybody know if the GeForce 4 MX 440 would work with the older drivers?
I had the same issue with my GF 2 GO. The latest drivers wich work are the 2960. Perhapps it is the same with your GF 4.

I reported this problem to the nvidia-guys somewhen in november or december last year. But it seems, that they haven´t dealt with it by now...
moali is offline   Reply With Quote
Old 04-03-03, 01:07 PM   #43
Vic-20
Registered User
 
Join Date: Apr 2003
Posts: 9
Cool NVidia + X + console (solved it for me)

I seem to have solved the "can't go back to the console after starting X" problem - at least on my system. The solution was to enable the VESA framebuffer in the kernel and use a VGA text mode for the console (the exact mode I used in LILO is 0317 - which I believe is 1027x768x64k) As a bonus, you get a tux graphic in the upper left hand corner of the display while Linux boots

I still use the nvidia driver in X, and my 3D performance is unaffected.

Read /usr/src/linux/Documentation/fb/vesa.txt for other VGA mode numbers you can try.
Vic-20 is offline   Reply With Quote
Old 05-10-03, 11:33 AM   #44
spurnelle
Registered User
 
Join Date: Jan 2003
Posts: 7
Unhappy console text not possible

I notice that nobody can explain how to use a NVIDA driver from NVIDIA (not X driver) correctly witn the user configuration. I donwload a driver, I install it and the text mode is not functionnal. If I install a NVIDIA driver on a server and I start a X some time, I must reboot a SERVER for see correctly my console. I DON'T would like install fb on a server. I think thats the FB option is not correct.

Despite this un-approbation, in my workstation, i configurated grub for FB vga = 0303., but i have the same problem the graphic console is not readable.

somebody cal help me ?

RedHat 8.0
NVIDIA 4363
X mode : 12840*1024
text mode : 1024*768
spurnelle is offline   Reply With Quote

Old 06-09-03, 09:20 PM   #45
hj_18
Registered User
 
Join Date: Jun 2003
Posts: 3
Default i find u, but it seems helpless

i install 4363 in turbolinux8wks , my graphic card is MSI GF4MX440 , with PHILIPS 107P4 . when i startx , it works well , glxgear reports up . but when i quit to virtual consonle, the characters become a mess--each like a small snake. someone suggested use nvtv to push the button 'tv-off' and so on, but for me ,it doesn't work , and i toggle the FB on or off when the machine boot(vesafb option in grub.conf and setup the grub again), but it still fail. how can i do.
hj_18 is offline   Reply With Quote
Old 06-11-03, 12:23 AM   #46
tarkawebfoot
Registered User
 
Join Date: Jun 2003
Location: Talent, OR
Posts: 2
Default Re: NVidia + X + console (solved it for me)

Quote:
Originally posted by Vic-20
I seem to have solved the "can't go back to the console after starting X" problem - at least on my system. The solution was to enable the VESA framebuffer in the kernel and use a VGA text mode for the console (the exact mode I used in LILO is 0317 - which I believe is 1027x768x64k) As a bonus, you get a tux graphic in the upper left hand corner of the display while Linux boots

I still use the nvidia driver in X, and my 3D performance is unaffected.

Read /usr/src/linux/Documentation/fb/vesa.txt for other VGA mode numbers you can try.
Hi Vic-20,

I'm a noobie to Open Source OSes and was wondering if you could verify that I got something right. Do you mean that you added the line:

vga=0317

to your /etc/lilo.conf file? I read the file you mentioned and it doesn't give clear instructions on how to change the settings. My vga line is set to 'normal' and I get a tux during boot already.

Also, I noticed that my vesa.txt wasn't in the same place, so I assume you're using a different distro than I am. Can you post your system info? Here's mine:

distro: Debian (Woody)
kernel: 2.4.18
FB support is on and VESA and VGA are compiled in.
video card: MSI Geforce4 440-MX
Monitor: NEC MultiSync FE700
MB: Gigabyte GA-7VAXP

Thanx
__________________
Debian, FreeBSD user
Open Source Noobie
tarkawebfoot is offline   Reply With Quote
Old 06-11-03, 07:14 AM   #47
Vic-20
Registered User
 
Join Date: Apr 2003
Posts: 9
Default

Actually, the text I put in my lilo.conf was

vga = 0x0317

distro: Slackware 8.1 (heavily upgraded)
kernel: 2.4.20
FB support is on and VESA VGA is compiled in.
video card: MSI Geforce4 440-MX
Monitor: ViewSonic PF90
MB: MSI K7T Turbo2

I should note, that even with this mode, the text, after leaving X, is very "fuzzy" or "wiggly" or whatever you want to call it. But it is still barely legible, which is better than nothing at all in a pinch.
Vic-20 is offline   Reply With Quote
Old 06-11-03, 09:08 PM   #48
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

After you edit /etc/lilo.conf, you have to rerun /sbin/lilo (or run it with the -v option if you want to see exactly what it's doing) to make your changes take effect. lilo is different from grub, in that grub reads its config file on every boot. lilo writes the config file's information into the boot record itself.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.