Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-09-06, 03:50 AM   #1
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default UT2004 Games Pauses with 8756

Well, the new driver seems to work well, most of the time, but I noticed a real annoying pause while playing UT2004 games (And mods). It will last for about 5 sec. and during that time, the screen seems to lag tremendously.

It only does this with UT2004 games. Doom3, Quake4, RTCW, and ET does not seems to do this.

Anyone else seeing this and if so, is there a fix...

This is with Composite enabled btw.

I am running Xorg 7 with a 2.6.16 archck+nitro kernel.

Thanks!!!

Joe
LinuxRocks is offline   Reply With Quote
Old 04-09-06, 07:35 AM   #2
etymxris
Registered User
 
Join Date: Apr 2005
Posts: 46
Default Re: UT2004 Games Pauses with 8756

Is this just soon after joining a server and right before spawning? Certain servers started giving me pauses at the beginning of a match about a month or two ago, but I think it was something with the newest UT update and not the drivers. I don't have pauses in the middle of gameplay, thankfully.
etymxris is offline   Reply With Quote
Old 04-09-06, 11:07 AM   #3
Agonizer
Registered User
 
Join Date: Apr 2006
Posts: 2
Question Re: UT2004 Games Pauses with 8756

I have the same Problem in UT2004. I also noticed a frame drop in glxgears (also a framedrop in UT2004). Unfortunately i did also switch from monolitic xorg to modular so i blamed xorg for it

My Computer is a Pentium(R) 4 CPU 2.53GHz, 1.5GB RAM, Videocard is a GeForce4 Ti 4200 AGP8X (running with 4xAGP due to board limit), 128MB, VBIOS Version 04.28.20.05.11, and operating system is gentoo linux.

I reverted to the previous driver and this did NOT help, so it may be a problem also related to the switch from xorg 6.8.2 to xorg-7.0-r1 or its configuration... or not?

I have attached the output of glxinfo, and my xorg.conf(.txt).

Hope someone has a solution.

Thanks
Attached Files
File Type: txt glxout.txt (12.0 KB, 126 views)
File Type: txt xorg.conf.txt (4.9 KB, 140 views)
Agonizer is offline   Reply With Quote
Old 04-09-06, 11:47 AM   #4
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default Re: UT2004 Games Pauses with 8756

Well, I have had Xorg 7 for months now and this problem didn't show up until after I upgrade my Nvidia driver, so its defiantly the driver.

It happens right after spawn and during gameplay also. Its totally random, and totally annoying. I am going to use the previous version of the driver till this one matures a bit...
LinuxRocks is offline   Reply With Quote
Old 04-09-06, 02:49 PM   #5
kgroombr
Using Linux Since 1995
 
Join Date: Sep 2002
Posts: 130
Default Re: UT2004 Games Pauses with 8756

I had this problem and this is what I found:

My xorg.conf file had the Option "NvAGP" "1" (use nvagp). I had my kernel compiled with agpgart as a module. Even though I specified to use NvAGP, the nvidia driver was loading the agpgart module.

My glxinfo showed this line which indicated to me that everything was OK:

direct rendering: Yes

and lsmod shows that the agpgart module as loaded (which it shouldn't be since I specified to use nvagp).

But looking at /proc/driver/nvidia/agp/status

It showed AGP as disabled. If I specifed Option "NvAGP" "3" (load agpgart, fallback to nvagp), everything worked fine, but I wanted to use NvAGP instead of agpgart. To do so, I had to remove the agpgart module to prevent it from loading. So again, I rebuilt my kernel without the agpgart module, and specified Option "NvAGP" "1", and all was good and listed as "Enabled" in /proc/driver/nvidia/agp/status.

It appears that if the nvidia driver finds the presense of the agpgart driver, it loads it reguardless of the setting of "NvAGP", but if "NvAGP" option is set to use nvagp, agp is disabled unless agpgart is not found.

Hope I covered that OK.

Ken
__________________
Kenton A. Groombridge
kgroombr@comcast.net
http://home.comcast.net/~kgroombr/
kgroombr is offline   Reply With Quote
Old 04-09-06, 03:14 PM   #6
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default Re: UT2004 Games Pauses with 8756

Quote:
Originally Posted by kgroombr
I had this problem and this is what I found:

My xorg.conf file had the Option "NvAGP" "1" (use nvagp). I had my kernel compiled with agpgart as a module. Even though I specified to use NvAGP, the nvidia driver was loading the agpgart module.

My glxinfo showed this line which indicated to me that everything was OK:

direct rendering: Yes

and lsmod shows that the agpgart module as loaded (which it shouldn't be since I specified to use nvagp).

But looking at /proc/driver/nvidia/agp/status

It showed AGP as disabled. If I specifed Option "NvAGP" "3" (load agpgart, fallback to nvagp), everything worked fine, but I wanted to use NvAGP instead of agpgart. To do so, I had to remove the agpgart module to prevent it from loading. So again, I rebuilt my kernel without the agpgart module, and specified Option "NvAGP" "1", and all was good and listed as "Enabled" in /proc/driver/nvidia/agp/status.

It appears that if the nvidia driver finds the presense of the agpgart driver, it loads it reguardless of the setting of "NvAGP", but if "NvAGP" option is set to use nvagp, agp is disabled unless agpgart is not found.

Hope I covered that OK.

Ken

Well, I don't use AGP, I have a 7800 GLX and use PCI-X.

I don't even think I have the kernel module for AGP in the kernel.

It was not doing this prior to upgrading to the latest Nvidia driver. However, I would usually get a slight lag when I would join a new server or change maps so the textures could load, but that was quick and didn't do it after the initial map load.

I did, however, figure out how to alleviate that; compile the kernel with the deadline scheduler and change preemption to voluntary. That would stop the install texture load lag (Probably due to the deadline sched. )

Anyhoo, I will just wait for a new driver to come out with bug fixes...

Thanks for the reply...

Joe

Joe
LinuxRocks is offline   Reply With Quote
Old 04-09-06, 04:53 PM   #7
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: UT2004 Games Pauses with 8756

Hi,

you should try a vanilla kernel first.

ck has a lot of scheduler patches which might be the culprit. (might? very probalbly!).

If that does not help, try replacing libsdl and openal.so in the ut2004 directory with the system's versions.
energyman76b is offline   Reply With Quote
Old 04-09-06, 07:22 PM   #8
Rafaelrrbr
Registered User
 
Join Date: Apr 2006
Posts: 4
Default Re: UT2004 Games Pauses with 8756

i had this same problem b4... with the latest patch 3369
i fixed it doing a downgrade to 3355
Rafaelrrbr is offline   Reply With Quote

Old 04-09-06, 09:15 PM   #9
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default Re: UT2004 Games Pauses with 8756

Quote:
Originally Posted by energyman76b
Hi,

you should try a vanilla kernel first.

ck has a lot of scheduler patches which might be the culprit. (might? very probalbly!).

If that does not help, try replacing libsdl and openal.so in the ut2004 directory with the system's versions.
I tried with the vanilla kernel for my distro and it does the same thing.

Its not a patch or something that the servers just started doing. It all worked FINE until I upgraded to this new driver and enabled composite.

Before, with the old driver, it worked as it should, even with composite enabled. The only issue I had before, was desktop widgets like superkaramba would put a black square in the game where the desktop app was located. Now, it doesn't do this, improvement, but the sporadic lag through out the game is not an improvement.

UT2004 is the only game that does this, however.

Other games like Doom3, Quake4 and such run fine (Well, the game screen is now a small box in the lower right and the rest of the screen is black, but the game plays ok).

Any idea when this will be resolved?

I like the new driver, but it only works 100% on the desktop; games are broken.

Thanks!!!

Joe
LinuxRocks is offline   Reply With Quote
Old 04-10-06, 11:39 AM   #10
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default Re: UT2004 Games Pauses with 8756

Surely I am not the only one seeing this... UT2004 is one of the most popular Linux games on the planet.

I reinstalled the game, and my OS and still the same result.

A little backround on my setup...

Running desktop at 1920x1200 (Dell 2405 FPW monitor). Running UT2004 at same res.

Using latest patch from Icculas (SP?) with RenderTarget TRUE and player shadow TRUE.

When I run at a lower res, the problem is still there, but the frequency is and time are diminished.

Again, I can't believe that everyone on the planet with this game and an nvidia card with the new drivers is not here complaining...

Quite interesting...

On a side note, my other machine (SUSE 10) with a GeForce 6800 does the same thing as my box (Arch Linux with a 7800 GTX).

Joe
LinuxRocks is offline   Reply With Quote
Old 04-10-06, 01:50 PM   #11
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: UT2004 Games Pauses with 8756

I don't get any hitching with ut2004 with latest nvidia drivers, and I am a faithful longtime -ck user and admire Con's patchset.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 04-10-06, 01:57 PM   #12
Agonizer
Registered User
 
Join Date: Apr 2006
Posts: 2
Default Re: UT2004 Games Pauses with 8756

Quote:
Originally Posted by kgroombr
I had this problem and this is what I found:
But looking at /proc/driver/nvidia/agp/status

It showed AGP as disabled. If I specifed Option "NvAGP" "3" (load agpgart, fallback to nvagp), everything worked fine, but I wanted to use NvAGP instead of agpgart. To do so, I had to remove the agpgart module to prevent it from loading. So again, I rebuilt my kernel without the agpgart module, and specified Option "NvAGP" "1", and all was good and listed as "Enabled" in /proc/driver/nvidia/agp/status.

Hope I covered that OK.

Ken
Thanks! That was exactly the problem - and the solution! Thank you, Ken!

Regards,
Torsten
Agonizer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Op-Ed: E3 games exploit real fears in a tumultuous world News Gaming Headlines 0 06-17-12 08:40 PM
Console Killers News Archived News Items 0 06-11-12 10:10 PM
When will we see DVD based games? thcdru2k Gaming Central 34 05-31-12 08:58 PM
PC Games, CeleronII 566, CeleronA 300, BIOS Savior, Heatsinks, NES & Sega Items +pics TekViper For Sale/Trade 5 08-07-02 10:48 PM

All times are GMT -5. The time now is 09:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.