Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-22-06, 03:00 PM   #1
andrewshawcare
Registered User
 
Join Date: Mar 2006
Posts: 1
Default Installing 1.0-8178 on Fedora Core 5

I'm writing this simply because I had to traverse through three different threads to find this information.

I'm using a GeForce Go 6600 GT running the i686 kernel.
  1. Install the xorg-x11-server-sdk package with yum:

    # yum install xorg-x11-server-sdk

    This package will provide the NVIDIA driver with the correct X server paths for Fedora Core 5.
    Optional: It might help to update the xorg-x11-server-Xorg package with yum (seems to have helped in some installations):

    # yum update xorg-x11-server-Xorg
  2. Install both the kernel and kernel-devel packages for the kernel you are running from http://people.redhat.com/davej/kernels/Fedora/FC5/ (apparently there is a bug in the kernel released with Fedora Core 5 which is resolved in this version).
  3. Install the 1.0-8178 driver update by following the instructions at http://www.nvnews.net/vbulletin/showthread.php?t=62021.
  4. Stop X and use the following command to install the driver:

    # ./nvidia-installer

Edit: Removed the path command arguments and added the installation of the xorg-x11-server-sdk package (and the optional update of the xorg-x11-server-Xorg package) for greater stability.

Last edited by andrewshawcare; 03-22-06 at 11:38 PM.
andrewshawcare is offline   Reply With Quote
Old 03-22-06, 03:28 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Installing 1.0-8178 on Fedora Core 5

Instead of specifying the X prefix manually, you can install the xorg-x11-server-sdk package prior to the NVIDIA Linux graphics driver installation.
zander is offline   Reply With Quote
Old 03-22-06, 07:02 PM   #3
rewt
mmm, Beer.. :drooling:
 
rewt's Avatar
 
Join Date: May 2004
Location: USA
Posts: 3,667
Default Re: Installing 1.0-8178 on Fedora Core 5

I've followed these instructions to the T, but my X server still will not load. The screen flashes a few times but then goes back to the command prompt with no cursor.

Is there a known problem with FC5 and SLI setups?
__________________
My pimp'n rig
Athlon64 Venice 3000+ @ 2.6GHz (4100+) · Win XP Pro x86, Vista Ultimate x64 · eVGA K8-NF41 nForce4 SLi · Corsair XMS 1.5GB PC3200 CAS2/1T · eVGA 2x 6600GT SLi · Leadtek Winfast TV2000 XP Deluxe · Western Digital Caviar SE ½TB RAID 0/1 · PowerLink LPK2-30 400W · LiteON LDW-411S OC to 811S 8x DVD±R/RW/ROM · MicroAdvantage 64MB QuickiDrive · Samsung SyncMaster 931B 19" LCD · Microsoft Optical Wheel Mouse USB · Sony PSXtoUSB Analog Gamepads · Memorex MX2700 Multimedia Keyboard · Lexmark 3200 Color Jetprinter · nForce Network Controller 1Gb/s LAN (Cable ~3Mb/s down) · ΩPioneer Dolby Digital 5.1 Surround Sound
rewt is offline   Reply With Quote
Old 03-22-06, 07:05 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing 1.0-8178 on Fedora Core 5

Please generate and post a bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 03-22-06, 07:15 PM   #5
master3dfx
Registered User
 
Join Date: Mar 2006
Posts: 1
Default Re: Installing 1.0-8178 on Fedora Core 5

If anyones has a problem with the screen staying black when X is initializing make sure when you installed the nvidia drivers that you disabled SELinux. After I disabled SeLinux and reinstalled problem was gone.

#setenforce 0
#./nvidia-installer -n
master3dfx is offline   Reply With Quote
Old 03-22-06, 07:16 PM   #6
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: Installing 1.0-8178 on Fedora Core 5

Quote:
Originally Posted by andrewshawcare
I'm writing this simply because I had to traverse through three different threads to find this information.

I'm using a GeForce Go 6600 GT running the i686 kernel.
  1. Install both the kernel and kernel-devel packages for the kernel you are running from http://people.redhat.com/davej/kernels/Fedora/FC5/ (apparently there is a bug in the kernel released with Fedora Core 5 which is resolved in this version).
  2. Install the 1.0-8178 driver update by following the instructions at http://www.nvnews.net/vbulletin/showthread.php?t=62021.
  3. Stop X and use the following command to install the driver:

    # ./nvidia-installer -n --x-prefix=/usr --x-module-path=/usr/lib/xorg/modules

    This will tell the installer the correct X server paths for Fedora Core 5.

This worked for me, after two days of passive frustration.
this does not work for me. i did exactly as you said and i got the following error still

nvidia: version magic '2.6.16 preempt K7 gcc-4.1' should be '2.6.16 preempt
K7 gcc-4.0'
nvidia: version magic '2.6.16 preempt K7 gcc-4.1' should be '2.6.16 preempt
K7 gcc-4.0'
mrmailer is offline   Reply With Quote
Old 03-22-06, 07:20 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing 1.0-8178 on Fedora Core 5

mrmailer,
That doesn't look like a FC5 kernel you're using. Unless you're using an official FC5 kernel, this thread doesn't really apply to you.

I'd suggest starting a new thread detailing your problem, and posting your installer log. However, it looks like your problem is that the version of gcc that you're using to install the nvidia driver differs from what was used to build the kernel.

-Lonni
netllama is offline   Reply With Quote
Old 03-22-06, 08:12 PM   #8
rewt
mmm, Beer.. :drooling:
 
rewt's Avatar
 
Join Date: May 2004
Location: USA
Posts: 3,667
Default Re: Installing 1.0-8178 on Fedora Core 5

I get this when switching to runlevel 5. The screen flashes a few times and..

"Failed to start the X server (your graphical interface). It is likely that it is not set up correctly."

I've posted some logs along with the xorg.conf file that the driver generated for me.

TIA
Attached Files
File Type: log nvidia-installer.log (35.7 KB, 567 views)
File Type: log nvidia-bug-report.log (96.3 KB, 576 views)
File Type: log Xorg.0.log (16.9 KB, 496 views)
File Type: txt xorg.conf.txt (2.8 KB, 569 views)
__________________
My pimp'n rig
Athlon64 Venice 3000+ @ 2.6GHz (4100+) · Win XP Pro x86, Vista Ultimate x64 · eVGA K8-NF41 nForce4 SLi · Corsair XMS 1.5GB PC3200 CAS2/1T · eVGA 2x 6600GT SLi · Leadtek Winfast TV2000 XP Deluxe · Western Digital Caviar SE ½TB RAID 0/1 · PowerLink LPK2-30 400W · LiteON LDW-411S OC to 811S 8x DVD±R/RW/ROM · MicroAdvantage 64MB QuickiDrive · Samsung SyncMaster 931B 19" LCD · Microsoft Optical Wheel Mouse USB · Sony PSXtoUSB Analog Gamepads · Memorex MX2700 Multimedia Keyboard · Lexmark 3200 Color Jetprinter · nForce Network Controller 1Gb/s LAN (Cable ~3Mb/s down) · ΩPioneer Dolby Digital 5.1 Surround Sound
rewt is offline   Reply With Quote

Old 03-22-06, 09:34 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing 1.0-8178 on Fedora Core 5

rewt,
It looks like the nvidia driver isn't installed in the correct location. Did you install the xorg-x11-server-sdk RPM before installing the nvidia driver?

-Lonni
netllama is offline   Reply With Quote
Old 03-22-06, 10:02 PM   #10
bryantai
Registered User
 
Join Date: Mar 2006
Posts: 1
Default Re: Installing 1.0-8178 on Fedora Core 5

Just tried installing xorg-x11-server-sdk, w/ the 2.6.15.1-2054 (x86_64 intel DuCore), w/ a 7800GT, no luck.
I'll have to try the 2.6.16 dev kernel from Dave at Nvidia.
bryantai is offline   Reply With Quote
Old 03-22-06, 10:09 PM   #11
rewt
mmm, Beer.. :drooling:
 
rewt's Avatar
 
Join Date: May 2004
Location: USA
Posts: 3,667
Default Re: Installing 1.0-8178 on Fedora Core 5

Well, I actually tried it both ways.

First time, after patching the x86_64 driver for 2.6.16 x86_64 kernel I did

# ./nvidia-installer -n --x-prefix=/usr --x-module-path=/usr/lib/xorg/modules

That didn't work. So I --uninstall the driver.

Then I did yum install xorg-x11-server-sdk , as zander recommended, and then after that was done, I reinstalled the driver again. The driver actually appeared to install just fine. But X server will still not load..

As a side note, I had to install FC5 in text mode because my screen was all corrupted (black yellow and green vertical lines) from the get go. After I was done installing FC5, it only boots up to runlevel 3 by default.
__________________
My pimp'n rig
Athlon64 Venice 3000+ @ 2.6GHz (4100+) · Win XP Pro x86, Vista Ultimate x64 · eVGA K8-NF41 nForce4 SLi · Corsair XMS 1.5GB PC3200 CAS2/1T · eVGA 2x 6600GT SLi · Leadtek Winfast TV2000 XP Deluxe · Western Digital Caviar SE ½TB RAID 0/1 · PowerLink LPK2-30 400W · LiteON LDW-411S OC to 811S 8x DVD±R/RW/ROM · MicroAdvantage 64MB QuickiDrive · Samsung SyncMaster 931B 19" LCD · Microsoft Optical Wheel Mouse USB · Sony PSXtoUSB Analog Gamepads · Memorex MX2700 Multimedia Keyboard · Lexmark 3200 Color Jetprinter · nForce Network Controller 1Gb/s LAN (Cable ~3Mb/s down) · ΩPioneer Dolby Digital 5.1 Surround Sound
rewt is offline   Reply With Quote
Old 03-22-06, 10:31 PM   #12
adam.stokes
Registered User
 
Join Date: Mar 2006
Posts: 7
Default Re: Installing 1.0-8178 on Fedora Core 5

Im still seeing issues with using the latest kernel from http://people.redhat.com/davej/

[adam@localhost ~]$ rpm -qa |grep xorg|grep sdk
xorg-x11-server-sdk-1.0.1-9

kernel-2.6.16-1.2070_FC5
kernel-devel-2.6.16-1.2070_FC5

I keep seeing errors like this :

(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)

took out some mode lines in the bug report so this thing would upload


im updating the following

[adam@localhost ~]$ rpm -qa |grep xorg |grep X
xorg-x11-server-Xorg-1.0.1-8
[adam@localhost ~]$ rpm -qa |grep xorg |grep sdk
xorg-x11-server-sdk-1.0.1-9

make sure xorg-x11-server-Xorg matches same version as the sdk and will attempt to reinstall
Attached Files
File Type: log nvidia-bug-report.log (98.7 KB, 442 views)

Last edited by adam.stokes; 03-22-06 at 11:07 PM.
adam.stokes is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel's Ivy Bridge Core i7 3770K Overheating Issue Detailed News Archived News Items 0 05-16-12 11:40 AM
CPUMark99 - how do you compare fuelrod Benchmarking And Overclocking 66 07-19-11 09:32 AM

All times are GMT -5. The time now is 11:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.