Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

View Poll Results: Did you find this howto useful?
Yeah, it Rocks! 2 50.00%
mmm, not bad... 2 50.00%
Awful! You could do more... 0 0%
Voters: 4. You may not vote on this poll

Reply
 
Thread Tools
Old 04-07-06, 07:01 AM   #25
avilella
Registered User
 
Join Date: Mar 2006
Posts: 33
Default Re: Nvidia Go 7400 Works On Linux

has anyone succeeded in having xinerama/twinview working with 7400 and this patched drivers?

scorpio?

Many thanks in advance,
avilella is offline   Reply With Quote
Old 04-07-06, 11:36 AM   #26
equinoxel
Registered User
 
Join Date: Apr 2006
Posts: 2
Default Re: Nvidia Go 7400 Works On Linux

Quote:
Originally Posted by worm75011
Hi

i try your device solution :
Option "IgnoreEDID"
Option "UseEdidFreqs" "false"
Option "NoLogo" "true"
Option "RenderAccel" "true"

but i have the same and befor i have IgnoreEDID , RenderAccel" "true"
i think by default IgnoreEDID is true
after UseEditFreqs is specifise to change the frequences of the screen
NoLogo is for Nvidia logo when the nvidia driver is coming up
i think this options are no important for deteminated the range of screen

i see your blog in Section modules you have : " Load "v4l" " do you know what is it?

someone have all options of the drivers?

thx for your help

worm

The nologo is not important. The EDID is. By default, EDID is not ignored (that was in the documentation).

If you run X -logverbose 9 (or -verbose 9) you'll se somewhere that EDID says that your screen is 1024x768 and therefore the driver will just ignore other resolutions.
Once EDID is disabled, the driver works with what's in the configuration, namely the 1280x800.

my guess is the logic is something like:
if (edid) {
getEDID()
getResolutionForEDID()
useResolution()
} else {
useBestResolutionAvailableInConfiguration()
}

unfortunately, the EDID for sz1xp is wrong (either the EDID data, or the way nvidia interprets it - my guess is the second one), so you get 1024x768.
equinoxel is offline   Reply With Quote
Old 04-07-06, 12:21 PM   #27
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia Go 7400 Works On Linux

1.0-8756 has been officially released, and supports the GeForce 7400 Go:
http://www.nvnews.net/vbulletin/showthread.php?t=67864
netllama is offline   Reply With Quote
Old 04-08-06, 04:17 AM   #28
neu1980
Registered User
 
Join Date: Apr 2006
Posts: 8
Default Re: Nvidia Go 7400 Works On Linux

so now, it is running with Nvidia 8756
but!!
Xgl don run ! why.
(Detected graphics card
nVida Corporation Unknown device 01d8)
why? why?
i need help!!!
neu1980 is offline   Reply With Quote
Old 04-08-06, 04:41 AM   #29
worm75011
worm75011
 
worm75011's Avatar
 
Join Date: Mar 2006
Location: FRANCE
Posts: 33
Send a message via MSN to worm75011 Send a message via Skype™ to worm75011
Default Re: Nvidia Go 7400 Works On Linux

Thx the new driver

On my etch it s run but i work on 1024x768 or my screen can work on 1280x800 ...
My hardware is a vaio vgn-fe11s
video card is : GeForce Go 7400
screen is : 15.4'' wxga x-black LCD

My config is :
ETCH debian distribution
xserver is xorg version 6.9
kernel is 2.6.15-1 686 smp

with nvidia-settings :
It s a nice tools but i can t change the resolution of screen : 1024x768 to 1280x800



you can find my xorg.con here : http://www.wormcs.dyndns.org/nvidia/...new-driver.txt

you can see the result :



Can you make all options we can use on our xorg.conf?



Thanks for your support

worm
__________________
H@V3 FuN
"Il existe deux choses d'infini dans notre univers, la taille de l'univers et la connerie humaine, il y a juste que pour l'univers que je ne suis pas sūr"
ALBERT EINSTEIN

Last edited by worm75011; 04-08-06 at 10:17 AM.
worm75011 is offline   Reply With Quote
Old 04-08-06, 11:45 AM   #30
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia Go 7400 Works On Linux

worm75011,
Please start X with the following command:
startx -- -logverbose 5

and then generate and post an nvidia-bug-report.log

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 01:02 PM   #31
worm75011
worm75011
 
worm75011's Avatar
 
Join Date: Mar 2006
Location: FRANCE
Posts: 33
Send a message via MSN to worm75011 Send a message via Skype™ to worm75011
Default Re: Nvidia Go 7400 Works On Linux

Quote:
Originally Posted by netllama
worm75011,
Please start X with the following command:
startx -- -logverbose 5

and then generate and post an nvidia-bug-report.log

Thanks,
Lonni
hi

thx

ok i make that

worm
__________________
H@V3 FuN
"Il existe deux choses d'infini dans notre univers, la taille de l'univers et la connerie humaine, il y a juste que pour l'univers que je ne suis pas sūr"
ALBERT EINSTEIN
worm75011 is offline   Reply With Quote
Old 04-08-06, 01:27 PM   #32
worm75011
worm75011
 
worm75011's Avatar
 
Join Date: Mar 2006
Location: FRANCE
Posts: 33
Send a message via MSN to worm75011 Send a message via Skype™ to worm75011
Default Re: Nvidia Go 7400 Works On Linux

hi lonni

I make the startx -- -verbose 5
the log repport is here :
http://www.wormcs.dyndns.org/nvidia/...ia.repport.txt

=> the result : starting the xserver and gnome 2.12 ...
you have a picture of it you can see the resolution 1024x768:


Now you have the differents snapshot here :










I use the nvidia-bug-report.sh
the log repport is here :
http://www.wormcs.dyndns.org/nvidia/...bug-report.log
__________________
H@V3 FuN
"Il existe deux choses d'infini dans notre univers, la taille de l'univers et la connerie humaine, il y a juste que pour l'univers que je ne suis pas sūr"
ALBERT EINSTEIN

Last edited by worm75011; 04-08-06 at 02:14 PM.
worm75011 is offline   Reply With Quote

Old 04-08-06, 04:17 PM   #33
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Nvidia Go 7400 Works On Linux

Thanks for the bug report. I see a few potential problems:

0) Is there a reason why you're using a "1280x800" modeline if your display has a native mode of 1280x800? I'd suggest commenting that mode out.
1) The IgnoreEDID option is deprecated, and no longer has any impact. It has been replaced with the UseEDID option. Please remove the IgnoreEDID option, and re-run the command that I requested in my last post, with a new bug report.
2) Is there a reason why you're using the ConnectedMonitor option?
3) You can't call UseEDIDFreqs and IgnoreEDID at the same time. Additionally, starting with 1.0-8756, the EDID is used by default, so there's normally not a need to specify UseEdidFreqs.
4) "ExactModeTimingsDVI" defaults to false, so specifying it explicitly is redundant, and unneccesary. However, in your case you might want to call that option (with True). I'd suggest testing with it set to true to see if it has any impact.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 04:35 PM   #34
neu1980
Registered User
 
Join Date: Apr 2006
Posts: 8
Default Re: Nvidia Go 7400 Works On Linux

hello,
how about Xgl??
can you use it??
thx
neu1980 is offline   Reply With Quote
Old 04-08-06, 06:09 PM   #35
worm75011
worm75011
 
worm75011's Avatar
 
Join Date: Mar 2006
Location: FRANCE
Posts: 33
Send a message via MSN to worm75011 Send a message via Skype™ to worm75011
Default Re: Nvidia Go 7400 Works On Linux

Quote:
Originally Posted by netllama
Thanks for the bug report. I see a few potential problems:

0) Is there a reason why you're using a "1280x800" modeline if your display has a native mode of 1280x800? I'd suggest commenting that mode out.
1) The IgnoreEDID option is deprecated, and no longer has any impact. It has been replaced with the UseEDID option. Please remove the IgnoreEDID option, and re-run the command that I requested in my last post, with a new bug report.
2) Is there a reason why you're using the ConnectedMonitor option?
3) You can't call UseEDIDFreqs and IgnoreEDID at the same time. Additionally, starting with 1.0-8756, the EDID is used by default, so there's normally not a need to specify UseEdidFreqs.
4) "ExactModeTimingsDVI" defaults to false, so specifying it explicitly is redundant, and unneccesary. However, in your case you might want to call that option (with True). I'd suggest testing with it set to true to see if it has any impact.

Thanks,
Lonni
I modify my xorg.org you can find it on :
http://www.wormcs.dyndns.org/nvidia/...ver.modify.txt

the nvidia repport bug and the startx -- -verbose 5 is made with the xorg.conf (see it up)

the result of startx -- -verbose 5 is here :
http://www.wormcs.dyndns.org/nvidia/...ver.modify.txt

the result of nvidia repport bug is here :
http://www.wormcs.dyndns.org/nvidia/...report.new.log

with the option :
1°)
"UseEDID" "true" it work in 1024X768
"UseEDID" "false" i have a black screen
when i don t use UseEDID on xorg.conf it work in 1024X768
2°)
"ExactModeTimingsDVI" "flase" it work in 1024X768
"ExactModeTimingsDVI" "true" i have a black screen
when i don t use ExactModeTimingsDVI on xorg.conf it work in 1024X768

3°)
In all case i comment the line : "UseEdidFreqs"
In all case i comment the line : "ConnectedMonitor"
In all case i comment the line : ModeLine "1280x800" 75.214 1280 1476 1524 1536 800 805 808 812 -hsync -vsync Option "DPMS" "true" in the monitor section

thinks for your help

good night (here in france it s now 00:06 am)

worm
__________________
H@V3 FuN
"Il existe deux choses d'infini dans notre univers, la taille de l'univers et la connerie humaine, il y a juste que pour l'univers que je ne suis pas sūr"
ALBERT EINSTEIN
worm75011 is offline   Reply With Quote
Old 04-08-06, 06:10 PM   #36
worm75011
worm75011
 
worm75011's Avatar
 
Join Date: Mar 2006
Location: FRANCE
Posts: 33
Send a message via MSN to worm75011 Send a message via Skype™ to worm75011
Default Re: Nvidia Go 7400 Works On Linux

Quote:
Originally Posted by neu1980
hello,
how about Xgl??
can you use it??
thx
you can see in your xorg.conf if you have the option :
Option "AllowGLXWithComposite" "true
in the device section

good night

worm
__________________
H@V3 FuN
"Il existe deux choses d'infini dans notre univers, la taille de l'univers et la connerie humaine, il y a juste que pour l'univers que je ne suis pas sūr"
ALBERT EINSTEIN
worm75011 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can NVIDIA better engage with Linux artem NVIDIA Linux 8 06-26-12 10:05 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 01:52 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
NVIDIA Drivers + Linux 7.3 Works once then quits Yupper3d NVIDIA Linux 3 08-01-02 05:03 AM

All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.