Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-02-03, 11:48 AM   #1
Hawkins
Registered User
 
Join Date: Feb 2003
Posts: 6
Default How to set the AGP to 2x????

Hi all:
How can I set the AGP 2x???:
I have this at modules.conf:

alias char-major-195 nvidia
options nvidia NVreg_ReqAGPRate=2

this is the content of /proc/driver/agp/card
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x0f000101

and this is the contect of host-bridge
Host Bridge: AMD Irongate
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x0f000203:0x00000101

AND THIS IS THE #~#~ STATUS!!!
Status: Enabled
Driver: NVIDIA
AGP Rate: 1x
Fast Writes: Disabled
SBA: Disabled

This is all the options I have in the XF86Config:
Section "Device"
BoardName "GeForce2 MX/MX 400"
BusID "1:5:0"
Driver "nvidia"
Identifier "Device[0]"
Option "NvAGP" "1" # use nvidia agp
#Option "NvAGP" "0" # disable agp
#Option "NvAGP" "3" # try 2 than 1
#Option "NvAGP" "2" # use agpgart
Option "ConnectedMonitor" "CRT"
Option "CursorShadow" "on"
Option "HWCursor" "on"
Option "NoLogo" "on"
VendorName "NVidia"
EndSection

Please, help me, I tried almost all. I read that my chipset is unstable under agp 2x, this is not true, I used AGP 2x (enabling it with Power Strip) and I get a good perfomance.

One more thing, the MoBo is a FIC SD-11 and there is no BIOS setting to change the AGP.
Hawkins is offline   Reply With Quote
Old 02-02-03, 03:41 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Well, if the default drivers only give you AGP 1x, then that's because they think your chipset isn't stable at 2x or 4x.

If you want to prove them wrong, then you're going to have to install the NVIDIA_kernel package from .tar.gz. Unpack it (with tar xvzf or similar), and edit the os-registry.c file after it's decompressed. Don't change the NVreg_ReqAGPRate setting in there (well... you can if you want to, but if you do change it here rather than using a module param, you'll never be able to use any other AGP rate...), but do, near the bottom of the file, get rid of the two underscores in the string.

For example, the last few lines of my os-registry.c look like this:

Code:
nv_parm_t nv_parms[] = {
    { NULL, "__VideoMemoryTypeOverride",  &NVreg_VideoMemoryTypeOverride  },
    { NULL, "ResmanDebugLevel",           &NVreg_ResmanDebugLevel         },
    { NULL, "EnableVia4x",                &NVreg_EnableVia4x              },
    { NULL, "EnableALiAGP",               &NVreg_EnableALiAGP             },
    { NULL, "UpdateKernelAGP",            &NVreg_UpdateKernelAGP          },
    { NULL, "__ReqAGPRate",               &NVreg_ReqAGPRate               },
    { NULL, "EnableAGPSBA",               &NVreg_EnableAGPSBA             },
    { NULL, "EnableAGPFW",                &NVreg_EnableAGPFW              },
    { NULL, "SoftEDIDs",                  &NVreg_SoftEDIDs                },
    { NULL, "Mobile",                     &NVreg_Mobile                   },
    { NULL, "FlatPanelMode",              &NVreg_FlatPanelMode            },
    { NULL, NULL,                         NULL                            }
};
so I would change it to look like this:

Code:
nv_parm_t nv_parms[] = {
    { NULL, "__VideoMemoryTypeOverride",  &NVreg_VideoMemoryTypeOverride  },
    { NULL, "ResmanDebugLevel",           &NVreg_ResmanDebugLevel         },
    { NULL, "EnableVia4x",                &NVreg_EnableVia4x              },
    { NULL, "EnableALiAGP",               &NVreg_EnableALiAGP             },
    { NULL, "UpdateKernelAGP",            &NVreg_UpdateKernelAGP          },
    { NULL, "ReqAGPRate",                 &NVreg_ReqAGPRate               },
    { NULL, "EnableAGPSBA",               &NVreg_EnableAGPSBA             },
    { NULL, "EnableAGPFW",                &NVreg_EnableAGPFW              },
    { NULL, "SoftEDIDs",                  &NVreg_SoftEDIDs                },
    { NULL, "Mobile",                     &NVreg_Mobile                   },
    { NULL, "FlatPanelMode",              &NVreg_FlatPanelMode            },
    { NULL, NULL,                         NULL                            }
};
Notice how there are now no __'s in front of ReqAGPRate? That's the way it should be. ReqAGPRate is disabled by default -- the reason is detailed up by the setting itself in os-registry.c.

Once you change that, you can just make the driver, and then try passing it the higher ReqAGPRate parameter. If it works, and if your system is stable, then continue using it. If not, you're going to have to revert that change back.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-02-03, 05:57 PM   #3
Hawkins
Registered User
 
Join Date: Feb 2003
Posts: 6
Talking it works!!!!!

Status: Enabled
Driver: NVIDIA
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

I need to see now if this configuration is stable. Thank you very much!!!
Hawkins is offline   Reply With Quote
Old 02-02-03, 06:10 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Glad to help!
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
agp 440bx/zx tntultar32 t00bad NVIDIA Linux 1 09-11-02 02:46 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
TNT2 M64 vs Voodoo3 3000 AGP Jake Other Desktop Graphics Cards 11 08-25-02 04:18 AM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 11:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.