Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-06, 03:03 PM   #1
davemg
Registered User
 
Join Date: Apr 2006
Posts: 21
Default Galaxy GeForce 7600 not loading in Ubuntu

NVidia Forums,

I had bought a Galaxy GeForce 7600 card a few weeks ago, and was delighted when the driver became available yesterday. I downloaded it, and ran it from a command prompt without any errors.

However, on next boot, X would not start. The error output said GLX could not be loaded. So I downloaded and installed an nvidia-glx package from the Ubuntu repositories.

But X still would not load. I reinstalled the latest nvida drivers again, and again there were no errors in the installation process.

To make a long story short, I've tried various edits of my xorg.conf file, where I think the problem is. I can't determine where I am making the mistakes.

I've included my xorg.conf file below, as well as some error output below that. If someone could tell me where I'm going wrong, I would greatly appreciate it.

My goal is to not only get my Galaxy GeForce 7600 card working with Ubuntu/Linux, but to also have my two 19 inch screens working at a resolution of 1240x1024 each.

Here is my xorg.conf file. Please note that I tried to auto-configure it using the nvidia xorg.conf configuration utility included with the drivers. But that did not work. This xorg.conf file was put together based on information I got on the web:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
#Load "GLcore"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "wacom"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mouse0"
Option "Protocol" "ExplorerPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "CorePointer"
Option "USB" "on"
Option "Mode" "Relative"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "USB" "on"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "USB" "on"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia" # must be "nvidia" NOT "nv"
VendorName "nVidia Corporation"
BoardName "GeForce 7600" # your info here
BusID "PCI:04:00:00" # Fill in your device id here, use lspci
Option "TwinView"
Option "MetaModes" "1280x1024,1280x1024" # fill in your resolutions here
Option "TwinViewOrientation" "LeftOf"
Option "SecondMonitorHorizSync" "61.8-81.1" # fill in your monitor capabilities
Option "SecondMonitorVertRefresh" "66-76" # fill in your monitor capabilities
#Option "SecondMonitorHorizSync" "UseEdidFreqs" # turn this on and it might just detect the second monitors abilities
#Option "SecondMonitorVertRefresh" "UseEdidFreqs" # turn this on and it might just detect the second monitors abilities

# All these options arent that important, you might hack with them later though:
#Option "RenderAccel"
#Option "HWcursor"
#Option "CursorShadow"
#Option "CursorShadowAlpha" "32"
#Option "CursorShadowXOffset" "3"
#Option "CursorShadowYOffset" "3"
# if you want Composite and GLX (they don't cooperate):
#Option "AllowGLXWithComposite"
EndSection

Section "Monitor"
Identifier "L1950T"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "L1950T"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
EndSection

#Section "DRI"
# Mode 0666
#EndSection


Here is the error output I saw, from /var/log/Xorg.0.log:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/libglx.so
dlopen: /usr/lib/libGLcore.so.1: undefined symbol: _nv000041gl
(EE) Failed to load /usr/lib/xorg/modules/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)
(WW) VESA(0): Bad V_BIOS checksum
davemg is offline   Reply With Quote
Old 04-07-06, 03:09 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

Did you remove the Ubuntu provided nvidia driver before installing 1.0-8756?

If so, please generate and provide an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-07-06, 09:38 PM   #3
davemg
Registered User
 
Join Date: Apr 2006
Posts: 21
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

I have included a nvidia-bug-report.log attached to this document.

I had to zip it because the original exceeded the 100kb upload limit of this forum.

When I installed the latest driver, it said that it removed previous nvidia drivers. If there is something I need to do by hand, please tell me.

Also, the only way I can boot my computer and access email and web is by taking the card out and using the motherboard's onboard graphics card. Is there any way I can have an alternate xorg.conf configuration or something that will allow me to leave the card in and use limited functionality? Taking the card in and out any time I want to test it and report on it is quite a hassle.

Thank you for your help.
Attached Files
File Type: zip nvidia-bug-report.log.zip (30.2 KB, 171 views)
davemg is offline   Reply With Quote
Old 04-07-06, 09:52 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

According to the bug report, you're using the vesa X driver, not the nvidia X driver.

Ubuntu ships with its owner version of the nvidia driver. You need to remove that driver with apt-get and then reinstall 1.0-8756. Please see Ubuntu's documentation or the other threads on this forum for more information.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 12:29 AM   #5
davemg
Registered User
 
Join Date: Apr 2006
Posts: 21
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

Thank you for your continued assistance. Here is what I did:

I used Synaptic to search for any instances of nvidia related packages installed on my system. I removed anything that had "nvidia" in the name, or looked to be an nvidia driver.

I then turned off the computer and disconnected the monitor from the motherboard's onboard video output.

Then I installed the Galaxy GeForce 7600 card into the computer and connected the monitor cables.

I turned on the machine. Predictably, X would not start. I now ran the NVIDIA-Linux-x86-1.0-8756-pkg1.run driver installer. It also gave me a notice that it was going to remove old drivers. It then installed the new drivers.

I then placed the version of xorg.conf cited above in the /etc/X11 directory, overwriting the old one.

I rebooted, and X did not start. At the command prompt, I ran the nvidia-bug-report.sh script to generate the new error log attached to this posting.

If there is any flaw in any steps I took, please let me know. The error log attached to this posting should reflect at the very least that I have the nvidia drivers installed.

Thank you for your time.
Attached Files
File Type: zip nvidia-bug-report.log.zip (24.7 KB, 141 views)
davemg is offline   Reply With Quote
Old 04-08-06, 12:45 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

See:
http://www.zwhlug.nl/content/nvidia_...tu_breezy_5_10
netllama is offline   Reply With Quote
Old 04-08-06, 01:47 AM   #7
davemg
Registered User
 
Join Date: Apr 2006
Posts: 21
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

Thank you for posting the link.

Before I delve into it, is this link being suggested because there is something particular about my error log or situation that would be directly addressed by the information there? If so, what exactly is the issue?

Forgive me if I seem at all unappreciative. I'm glad to have the input. But I can't help but wonder if the advice comes merely because I am using Ubuntu and Nvidia, and that is all that was considered.

I ask because it seems I have covered all the steps listed on that web site, if not in the precisely exact same way. Also, because of configuring my Wacom tablet, I have already crossed some hurdles like making sure I have gcc and kernel sources.

So, essentially, what is it about that web site that is of particular assistance?

Thank you for your time.
davemg is offline   Reply With Quote
Old 04-08-06, 02:59 AM   #8
FRidh
Registered User
 
Join Date: Nov 2004
Posts: 5
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

It seems you are running Xorg 7.0
The installer installs the nvidia driver in the wrong place.
Somewhere else on this forum i saw someone had it with the 8178 driver and he found out that a symbolic link would help.

I made these symbolic links and now X works while in
/usr/lib/xorg/modules/drivers

ln -s /usr/X11R6/lib/modules/extensions/libglx.so.1.0.8756
ln -s /usr/X11R6/lib/modules/extensions/libglx.so

Looks like a lot of people have this problem

Edit:

making the second symbolic link should be enough i think. libglx.so already points to libglx.so.1.0.8757

Last edited by FRidh; 04-08-06 at 04:20 AM.
FRidh is offline   Reply With Quote

Old 04-08-06, 10:31 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

FRidh,
davemg stated that the driver works fine until after a reboot, which suggests that something is breaking the driver installation. If those symlinks were required, I would imagine that they would be needed from the start, and not just after a reboot (not to mention that reinstalling the driver after the reboot seems to temporarily fix dagemg's problem).

davemg,
The reason I posted that URL is because in nearly all of the cases where people have reported the problem symptoms that you are reporting, those instructions have fixed the problem. Furthermore, the only way that I can reproduce the problem you are reporting is by performing a fresh Ubuntu installation, and not proceeding to run throug the steps in that URL. I've successfully installed 1.0-8756 several times in Ubuntu, so I'm not seeing any bugs in that respect.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 10:15 PM   #10
davemg
Registered User
 
Join Date: Apr 2006
Posts: 21
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

Thank you for continuing to take an interest in my problems.

Sorry, I seem to have mis-represented part of the problem:

The Nvidia driver is not "working fine" until the next reboot. When I said that the Nvidia driver installed without problems, I meant only that the nvidia shell script processed without any compile errors, or errors in finding any kernel source or anything of that nature.

The nvidia drivers have never, at any point, successfully loaded X on my machine. I have not been able to run X at all while the Galaxy GeForce 7600 is inside my computer.

Lonni -

I understand where you are coming from. To be sure, I went through the howto at the link you suggested. I was able to go through the entire howto without any deviation from the instructions. However, at the end, my situation seems to be exactly what it was when I started this thread.

Fridh -

I created the symbolic links you suggested. Unfortunately, that does not seem to have had any effect.


In case it helps at all, I have included with this posting a copy of the xorg.conf file that was automatically generated by the Nvidia install shell script.


I hope that we're on the same page in terms of having gone through the standard steps to install the Nvidia drivers. Please let me know if there is anything else I can do to diagnose or fix the problem.
Attached Files
File Type: txt xorg.conf.nvidia.txt (4.1 KB, 190 views)
davemg is offline   Reply With Quote
Old 04-09-06, 10:41 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Galaxy GeForce 7600 not loading in Ubuntu

What is the output from the following command?
pkg-config --variable=moduledir xorg-server
netllama is offline   Reply With Quote
Old 04-09-06, 05:33 PM   #12
hmedney
Registered User
 
Join Date: Apr 2006
Posts: 3
Default My experiences (and problems) with a GTX 7800

I wanted to share my experiences since I am having the same problem. I looked at davemg's bug report and it appears we both fail in the same place.

Using Kununtu Dapper Drake FC5, I was unable to get X workiing using the 1.0.8178 driver install script from Nvidia. I was able to get it working using the nvidia debian packages from the repository (installed via adept - the synaptic couterpart on Kunbuntu).

When using the packages from the repository, I did have to add this line to the Device section:
Option "ConnectedMonitor" "DFP"

Without this line, I was only getting X on my TV out.

Now I am trying the new 1.0-8756 drivers from Nvidia. Like the previous attempt using the NVidia script, I am unable to get X working. The problem:

...
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
....

..even though "modprobe nvidia" does not report any errors. The driver was compiled/installed successfully using Nvidia's script.

Thanks,
Hunter Medney
hmedney is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GALAXY Launches the GeForce GTX 670 and GTX 670 GC! News Archived News Items 0 05-10-12 09:28 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 08:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.