Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-08-06, 06:24 PM   #1
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Black Screen - 8756 - Dell 2005FPW

I'm getting a black screen on gdm start. I can still hear sounds, and if I log in, I can hear the login sounds.

xorg.conf

Code:
Section "Device"
    Driver         "nvidia"
    Identifier     "NVIDIA Corporation NV40 [GeForce 6800 GT]"
    Option	   "ConnectedMonitor" "DFP"
    Option	   "UseEDID" "False"
EndSection

Section "Modes"
   Identifier "16:10"
   ModeLine "1680x1050" 146.2 1680 1960 2136 2240 1050 1080 1086 1089
   -hsync +vsync
EndSection

Section "Monitor"
   Identifier "Generic Monitor"
   UseModes "16:10"
   HorizSync 30-83
   VertRefresh 56-75
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV40 [GeForce 6800 GT]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050" "1280x1024" "1024x768" "800x600"
	ViewPort   0 0
    EndSubSection
EndSection
Relevant Xorg.0.log sections:

Code:
(WW) NVIDIA(0): Unable to use mode "1680x1050" for DFP-0; cannot compute
(WW) NVIDIA(0): No valid modes for "1680x1050"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(WW) NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI
(WW) NVIDIA(0):     from EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
Any help would be greatly appreciated.
Mythin is offline   Reply With Quote
Old 04-08-06, 06:31 PM   #2
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: Black Screen - 8756 - Dell 2005FPW

My nvidia log was too big and didn't upload the first time. I removed the Xorg.0.log section because it's not the one that doesn't work.
Attached Files
File Type: log nvidia-bug-report.log (77.3 KB, 119 views)
Mythin is offline   Reply With Quote
Old 04-08-06, 06:34 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black Screen - 8756 - Dell 2005FPW

Please start X with the following command:
startx -- -logverbose 5

and then generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 06:36 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black Screen - 8756 - Dell 2005FPW

The X log needs to be included in your bug report. Without it, I have no means of determining what X is doing (wrong). You can zip the bug report to compress it.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 06:50 PM   #5
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: Black Screen - 8756 - Dell 2005FPW

I can't run the nvidia bug report script while X is running for obvious reasons, but I zipped up everything I think you asked for.

If I missed anything, feel free to yell at me
Attached Files
File Type: zip NVIDIA.zip (30.0 KB, 121 views)
Mythin is offline   Reply With Quote
Old 04-08-06, 07:26 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black Screen - 8756 - Dell 2005FPW

You can't disable the EDID, or that removes most of the verbosity in the X log:
Option "UseEDID" "False"

Please remove the above option, the ConnectedMonitor option, the UseEdidFreqs option and the ModeValidation option and then generate the bug report again.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-08-06, 07:39 PM   #7
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: Black Screen - 8756 - Dell 2005FPW

Okay, I reset my xorg.conf to a very basic state with almost no tweaking done. Here's the bug report.
Attached Files
File Type: zip nvidia-bug-report.log.zip (25.3 KB, 128 views)
Mythin is offline   Reply With Quote
Old 04-08-06, 09:14 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black Screen - 8756 - Dell 2005FPW

This bug report shows what I need, thanks. The problem in the latest bug report is that the driver defaults to a CRT if one is connected. That's what X is using, and why your Dell DFP isn't displaying anything.

Adding the following option to your X configuration should address that problem (assuming that you only wish to use the DFP, and not the CRT):
Option "UseDisplayDevice" "DFP"

If the above change doesn't help, please generate a new bug report. It would also be a good idea to verify that you have the latest BIOS for your motherboard applied.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 04-08-06, 09:23 PM   #9
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: Black Screen - 8756 - Dell 2005FPW

That's what I was trying to do with the "ConnectedMonitors" line. I'll try what you suggested.

Just a note, I ONLY have the Dell DFP connected. I'll let you know how that comes out.
Mythin is offline   Reply With Quote
Old 04-08-06, 09:33 PM   #10
Mythin
Registered User
 
Join Date: Apr 2006
Posts: 6
Default Re: Black Screen - 8756 - Dell 2005FPW

That worked beautifully, thank you so much!
Mythin is offline   Reply With Quote
Old 04-08-06, 09:39 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black Screen - 8756 - Dell 2005FPW

Glad to hear you got this fixed. The ConnectedMonitor option was never meant for telling the driver which display to use when more than one was connected.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 12:17 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 07:24 PM

All times are GMT -5. The time now is 03:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.