Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-11-06, 06:19 AM   #1
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default 8756/IA32/nForce2IGP--Resume-from-disk fails--err NVRM: Xid (0001:00):8, Channel 001b

I'm having trouble getting suspend-to-disk working with these drivers. (The results were similar with 8178, so it doesn't seem to be a regression).

I'm running Fedora Core 5, with the suspend2 enabled 2.6.16-2080 kernel from atrpms.net and the associated suspend2 packages also from atrpms.
I've been using the serial console to watch the kernel messages during boot up.
I'm running this on GF4MX integrated graphics (on a Soltek SL-7BA-F nForce2 board).

With NvAGP enabled, the system locks up during the resume process - suspend2 starts (and possibly finishes) restoring the RAM image. Nothing further is written to the console.
With NvAGP disabled, things get further. The resume appears to complete successfully, but the video doesn't come back. It does change from text mode back to graphics mode (and continues to output a signal, since the monitor powersaving doesn't kick in), but the screen stays black.
At the serial console, the resume appears to have finished, but the system seems to pause for a few seconds every 10 secs or so, and the following NVRM message is printed every time
"NVRM: Xid (0001:00): 8, Channel 0000001b"

A full syslog is attached, from initial bootup, through suspend, and then resume.


Enabling/disabling apic and lapic doesn't seem to have any effect.
I've also sanity checked by doing the suspend-to-disk from a text-mode console with the X server shutdown and the nvidia module unloaded --- this works fine.


Any suggestions on how to debug this problem further?


Bug report script results and Nvidia installer log file to follow...

Regards,
Ken
Attached Files
File Type: zip nv8756_suspendlog.zip (9.3 KB, 213 views)

Last edited by mrkh; 04-11-06 at 11:40 AM.
mrkh is offline   Reply With Quote
Old 04-11-06, 05:55 PM   #2
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Ok, here are nvidia-bug-report.sh logs, lspci -vvxxx output and nvidia-installer.log.

Also included is the suspend2 hibernate.conf file and associated blacklisted-modules file.


For the NvAGP enabled case, nvidia-bug-report.sh/lspci could only be run beforehand because the system locks up hard....even sysrq is dead.

--
Ken
Attached Files
File Type: zip bug_report_logs.zip (94.1 KB, 206 views)
mrkh is offline   Reply With Quote
Old 04-12-06, 11:33 AM   #3
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

For the American audience
mrkh is offline   Reply With Quote
Old 04-13-06, 02:27 PM   #4
pipopieter
Registered User
 
Join Date: Apr 2006
Posts: 1
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

I don't have a solution, but have similar experiences on my x86-system (Athlon XP 2000+, ECS K7S5a motherboard)

Running latest NVidia kernel module (1.0.8756) for a Geforce 5200, kernel 2.6.16 using Con Kolivas's CK3 patches on a gentoo box.

When I don't touch my computer for a while, it completely locks up. Keyboard/mouse-interactivity becomes impossible. Hardware reset is the only option to regain access.

/var/log/messages displays:
Code:
Apr 13 19:16:00 pico su[8599]: Successful su for root by root
Apr 13 19:16:00 pico su[8599]: + pts/1 root:root
Apr 13 21:02:54 pico NVRM: Xid (0001:00): 7, Ch 0000001e M 00000304 D 7fff7fff intr 00011000
Apr 13 21:02:54 pico NVRM: Xid (0001:00): 7, Ch 0000001f M 00000304 D 7fff7fff intr 00011000
Apr 13 22:07:47 pico syslog-ng[5640]: syslog-ng version 1.6.9 starting
Apr 13 22:07:47 pico syslog-ng[5640]: Changing permissions on special file /dev/tty12
At 19:16 I su'd to root, did some stuff and went away. Apparently at 21:02:54 NVidia-related started bugging. I came back to my machine just after ten o'clock and rebooted it..
pipopieter is offline   Reply With Quote
Old 04-14-06, 04:32 AM   #5
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Discovered something else...

With both agpgart and nvagp disabled, resume-from-disk works properly!
It looks like the problem is definitely agp related.
Attached are before and after nvidia-bug-report logs and lspci -vvxxx outputs.

@pipopieter: Thanks for adding your report. Maybe its just nvidia trying to tell you that you shouldn't stay su'd as root if you leave your PC

But seriously...it's hard to tell if its the same issue...I don't know what those NVRM: Xid message codes mean, I wonder is there a list published somewhere?. I do see two differences between our problems though - first mine happens only on resume-from-disk, and second you have an SiS chipset, whereas mine is nForce.


Ken
Attached Files
File Type: zip noagp_reports.zip (55.9 KB, 236 views)

Last edited by mrkh; 04-14-06 at 11:06 AM.
mrkh is offline   Reply With Quote
Old 04-14-06, 04:52 AM   #6
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

I had the same experiment with suspend2 and previous linux Nvidia driver. Turning AGP off helped resuming.

Unfortunately with latest Nvidia driver and latest suspend2 I cannot even suspend. It fails after writing memory out. I get a blank screen, and it does not shut down, completely frozen. See signature for specs.
__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote
Old 04-14-06, 05:27 AM   #7
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Thanks for the reply krionius. I was beginning to think I was the only person with this problem.

It looks like your specs are very similar to mine (i.e. nForce2, Barton 2500+)

Was this with the NvAGP driver or agpgart? I get slightly different results depending on which driver is enabled.

Are there any messages written to the system log during the suspend?

Regards,
Ken
mrkh is offline   Reply With Quote
Old 04-14-06, 06:02 AM   #8
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Quote:
Originally Posted by mrkh
Was this with the NvAGP driver or agpgart? I get slightly different results depending on which driver is enabled.

Are there any messages written to the system log during the suspend?
- I've tried both nvAgp and agpgart, no success, same thing happened.
- I haven't seen any usefull message. Neither on screen nor in file (although I didnt oversearched it.)

I am wondering if this is related to suspend2's recent version in which suspend2 code has been partially unified with kernel's built-in suspend. I don't have the patience to experiment with it further... Have you tried former versions of susepend2? 2.2.1 or something like that...
__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote

Old 04-14-06, 06:41 AM   #9
mrkh
Registered User
 
Join Date: Apr 2006
Posts: 18
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Quote:
Originally Posted by krionius
I am wondering if this is related to suspend2's recent version in which suspend2 code has been partially unified with kernel's built-in suspend. I don't have the patience to experiment with it further... Have you tried former versions of susepend2? 2.2.1 or something like that...
Hmmm, I have only tried 2.2.1. I must have a look to see what changes were made related to integrating with the kernel's built-in suspend.

Still, it seems unlikely to be the problem though, since our setups will work with agp disabled.

By the way - have you tried changing any of the settings in suspend2's hibernate.conf?
One would be to set "Verbosity" and "LogVerbosity" to 9, so that all of the debugging messages are turned on.
Also, it was suggested on the suspend2 list to try changing "PowerdownMethod" from 5 to 4 so that the ACPI hibernate routines would be run. (Didn't make any difference for me though).
mrkh is offline   Reply With Quote
Old 04-15-06, 06:13 AM   #10
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

With or without AGP, nvagp=1 and nvagp=0, and page extra allowance set to 0 or 10000, nothing helps. With new driver 8756 I cannot suspend anyhow. Without nvidia driver I can suspend /resume perfectly. Suspend2 2.2.4 with kernel 2.6.16

I attach my bugreport for the officials. Please try to advise.
Attached Files
File Type: zip nvidia-bugreport.zip (24.0 KB, 200 views)
__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote
Old 04-15-06, 02:02 PM   #11
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

Additional comment: with 8176 I could suspend but resume worked only with AGP off. 8756 is worse. I cannot even just suspend, screen goes blank and system is left frozen.

Please, other Suspend(2) users with AGP (not PCI-X) comment if you are succesful with your GF 6XXX series card!

Thanks,
SK
__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote
Old 04-16-06, 04:04 AM   #12
krionius
Asus 8800GTS 320M
 
krionius's Avatar
 
Join Date: Jul 2003
Location: Budapest, HU
Posts: 249
Default Re: 8756/IA32/nForce2IGP -- Suspend-to-disk fails on resume

__________________
SK - Java Classic RPG http://zaza.uw.hu/mrp/index.html http://linuxrpgs.blogspot.com
Asus GF8800GTS 320M DDR3 PCI-E - nvidia 169.09
Abit KN9 SLI (nforce570),AMD64 X2 3800+@4800+,2x1GB 800MHz DDR2,160G SATA2 WesternDigital,430W Chieftec PSU
gentoo linux (since 2003) 2006.1 amd64 kernel 2.6.22-suspend2 X.Org 7.3 | gnome 2.20.0, kde 3.5.5, beryl 0.2.1

Samsung SyncMaster 913N@1240, Tatung "32 @1080i, Pinnacle PCTV Rave, Pioneer DVR110D
Abit AN-M2HD NVidia 7050PV Noiseless HTPC, Ubuntu Linux 7.10 64bit kernel 2.6.23.8, nvidia 169.04, FSP Zen 300W,
Thermaltake Sonic Tower, AMD64 X2 4200+, 2GB DDR2, 400G SATA2 WD, Asus TVTuner (saa7134) Silent Linux HTPC

Asus TravelMate 4100 NVidia 6200 Go, Ubuntu Linux 8 32bit kernel 2.6.24, nvidia 169.12, Intel32 1.6G, 1.5GB DDR2,
krionius is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.07 no resume from suspend stecklum NVIDIA Linux 85 12-07-12 01:27 PM

All times are GMT -5. The time now is 04:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.