Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-09-06, 02:47 AM   #1
pannomatte
Registered User
 
Join Date: Mar 2003
Posts: 14
Default Multihead configuration problem

I'm almost there but I have problem getting correct reolution on HD DVI connection
Heres my setup
AMD 64 Dual Core
Assus A8n-sli Deluxe mobo
Nvidia 6600 PCIE # 1
Nvidia 6500 PCIE #2
Suse 10.1 (box set)
2 G ram

Both Cards have 1280 x 1024 LCD displays working properly and set up with Sax2. Card 1 has twinview setup with nvidia-xconfig --twinview. Twinview drives Emprex HD-3701 monitor giving me 1280x1024 lcd on the eft, HD via DVI in the middle and 1280x1024 on the right for one virtual desktop. All is well with the exception the HD/DVI can only see 1024x768 resolution. I should note I'm using a DVI to HDMI cable.

Thanks in advance
Daniel
pannomatte is offline   Reply With Quote
Old 08-09-06, 09:08 PM   #2
pannomatte
Registered User
 
Join Date: Mar 2003
Posts: 14
Default Re: Multihead configuration problem

Forgot to attach xorg.cof for above. Here it is
PHP Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Mon May 15 14:17:32 PDT 2006

# /.../
# SaX generated X11 config file
# Created on: 2006-08-09T10:00:18-0500.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    
Identifier     "Layout[all]"
    
Screen         "Screen[1]" RightOf "Screen[0]"
    
Screen         "Screen[0]" 0 0
    InputDevice    
"Keyboard[0]" "CoreKeyboard"
    
InputDevice    "Mouse[1]" "CorePointer"
    
Option         "Clone" "off"
    
Option         "Xinerama" "on"
EndSection

Section
"Files"
    
InputDevices      "/dev/gpmdata"
    
InputDevices      "/dev/input/mice"
    
FontPath        "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/local"
    
FontPath        "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    
FontPath        "/usr/X11R6/lib/X11/fonts/URW"
    
FontPath        "/usr/X11R6/lib/X11/fonts/Speedo"
    
FontPath        "/usr/X11R6/lib/X11/fonts/PEX"
    
FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    
FontPath        "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/latin2/Type1"
    
FontPath        "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/kwintv"
    
FontPath        "/usr/X11R6/lib/X11/fonts/truetype"
    
FontPath        "/usr/X11R6/lib/X11/fonts/uni:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/CID"
    
FontPath        "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/hellas/Type1"
    
FontPath        "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
    
FontPath        "/usr/X11R6/lib/X11/fonts/xtest"
    
FontPath        "/opt/kde3/share/fonts"
EndSection

Section
"Module"
    
Load           "v4l"
    
Load           "dbe"
    
Load           "glx"
    
Load           "type1"
    
Load           "freetype"
    
Load           "extmod"
EndSection

Section
"ServerFlags"
    
Option         "AllowMouseOpenFail" "on"
EndSection

Section
"InputDevice"
    
Identifier     "Keyboard[0]"
    
Driver         "kbd"
    
Option         "Protocol" "Standard"
    
Option         "XkbLayout" "us"
    
Option         "XkbModel" "pc104"
    
Option         "XkbRules" "xfree86"
EndSection

Section
"InputDevice"
    
Identifier     "Mouse[1]"
    
Driver         "mouse"
    
Option         "Buttons" "5"
    
Option         "Device" "/dev/input/mice"
    
Option         "Name" "ImPS/2 Generic Wheel Mouse"
    
Option         "Protocol" "explorerps/2"
    
Option         "Vendor" "Sysp"
    
Option         "ZAxisMapping" "4 5"
EndSection

Section
"Modes"
    
Identifier         "Modes[0]"
    
ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066
EndSection

Section
"Modes"
    
Identifier         "Modes[1]"
    
ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066
EndSection

Section
"Monitor"
    
Identifier     "Monitor[0]"
    
VendorName     "--> VESA"
    
ModelName      "1280X1024@60HZ"
    
UseModes       "Modes[0]"
    
DisplaySize     330    270
    HorizSync       31.0
- 64.0
    VertRefresh     50.0
- 60.0
    Option         
"CalcAlgorithm" "XServerPool"
EndSection

Section
"Monitor"
    
Identifier     "Monitor[1]"
    
VendorName     "--> VESA"
    
ModelName      "1280X1024@60HZ"
    
UseModes       "Modes[1]"
    
DisplaySize     330    270
    HorizSync       31.0
- 64.0
    VertRefresh     50.0
- 60.0
    Option         
"CalcAlgorithm" "XServerPool"
EndSection

Section
"Device"
    
Identifier     "Device[0]"
    
Driver         "nvidia"
    
VendorName     "NVidia"
    
BoardName      "GeForce 6600"
    
BusID          "1:0:0"
    
Screen          0
EndSection

Section
"Device"
    
Identifier     "Device[1]"
    
Driver         "nvidia"
    
VendorName     "NVidia"
    
BoardName      "GeForce 6500"
    
BusID          "2:0:0"
    
Screen          0
EndSection

Section
"Screen"
    
Identifier     "Screen[0]"
    
Device         "Device[0]"
    
Monitor        "Monitor[0]"
    
DefaultDepth    24
    Option         
"TwinView" "True"
    
Option         "TwinViewOrientation" "RightOf"
    
Option         "UseEdidFreqs" "True"
    
Option         "MetaModes" "1024x768, 1024x768"
    
SubSection     "Display"
        
Depth       15
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       16
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       24
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       8
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
EndSection

Section
"Screen"
    
Identifier     "Screen[1]"
    
Device         "Device[1]"
    
Monitor        "Monitor[1]"
    
DefaultDepth    24
    Option         
"TwinView" "True"
    
Option         "TwinViewOrientation" "RightOf"
    
Option         "UseEdidFreqs" "True"
    
Option         "MetaModes" "1024x768, 1024x768"
    
SubSection     "Display"
        
Depth       15
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       16
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       24
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
    SubSection     
"Display"
        
Depth       8
        Modes      
"1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    
EndSubSection
EndSection
pannomatte is offline   Reply With Quote
Old 08-09-06, 09:20 PM   #3
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Multihead configuration problem

Quote:
Originally Posted by pannomatte
Forgot to attach xorg.cof for above. Here it is

PHP Code:
    Option         "MetaModes" "1024x768, 1024x768"
I guess you need to add Metamodes for all Modes.

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 08-11-06, 12:35 AM   #4
pannomatte
Registered User
 
Join Date: Mar 2003
Posts: 14
Default Re: Multihead configuration problem

No luck. I'm really frustrated. adding what should be the right Metamode gives no output on that switch. (Ctrl + Alt + + /-) Has anyone managed to get a 1920x1080 working. All I've seen in scouring the list is similar problems. If yes could you attach your xorg.conf in reply.
Here is the relevant section

PHP Code:
Section "Device"
  
BoardName    "GeForce 6600"
  
BusID        "1:0:0"
  
Driver       "nvidia"
  
Identifier   "Device[0]"
  
Option       "SaXDualHead"
  
Option       "TwinView"
  
Option       "SaXDualMonitorVendor" "<UNDEFINED>"
  
Option       "SecondMonitorHorizSync" "30-50"
  
Option       "SaXDualVSync" "50-61"
  
Option       "MetaModes" "1280x1024,1920x1080;1280x1024,1024x768;1280x960,1024x768"
  
Option       "SaXDualOrientation" "RightOf"
  
Option       "SaXDualResolution" "1920x1080"
  
Option       "TwinViewOrientation" "RightOf"
  
Option       "SaXDualMode" "Xinerama"
  
Option       "SecondMonitorVertRefresh" "50-61"
  
Option       "SaXDualHSync" "30-50"
  
Option       "SaXDualMonitorModel" "<UNDEFINED>"
  
Screen       0
  VendorName   
"NVidia"
EndSection
pannomatte is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
Sony SDM-S51 monitor and GeForce4 problem hassasin NVIDIA GeForce 7, 8, And 9 Series 4 10-12-02 04:10 PM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 12:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.