Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-06, 07:13 AM   #1
Eazy
Registered User
 
Join Date: Nov 2005
Posts: 9
Unhappy Bad FPS with good hardware

Hi!
I just bought some new hardware:
CPU: AMD Athlon 64 4400+ X2 Dual-Core
GFX: XFX 7900gt PCIe (extreme edition)
RAM: 2x Corsair 512Mb
MB: MSI K8N-Sli

I reinstalled Kubuntu Breezy and installed "kernel 2.6.12-10-k7-smp" (thought I should do that as I got a X2 CPU). Then I installed the latest Driver from Nvidia using "Method 2" from this guide. The Nvidia driver installed with no errors.

When I tested to se what fps Glxgears would give me, I get:
Window mode: 17728.682 FPS
Full screen mode: 1873.842 FPS

When playing UT2004 I get strange graphic errors (big coloured blocks) and really bad fps (35-50 fps).

My xorg.conf:

PHP Code:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice
"Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section
"Files"

# paths to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/100dpi:unscaled"
FontPath "/usr/share/X11/fonts/75dpi:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
FontPath "/usr/share/fonts/truetype/ttf-gujarati-fonts"
FontPath "/usr/share/fonts/truetype/ttf-arabeyes"
FontPath "/usr/share/fonts/truetype/ttf-bengali-fonts"
FontPath "/usr/share/fonts/truetype/arphic"
FontPath "/usr/share/fonts/truetype/baekmuk"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/type1/gsfonts"
FontPath "/usr/share/fonts/truetype/ttf-dejavu"
FontPath "/usr/share/fonts/truetype/freefont"
FontPath "/usr/share/fonts/truetype/ttf-devanagari-fonts"
FontPath "/usr/share/fonts/truetype/kochi"
FontPath "/usr/share/fonts/truetype/ttf-punjabi-fonts"
FontPath "/usr/share/fonts/truetype/ttf-tamil-fonts"
FontPath "/usr/share/fonts/truetype/ttf-malayalam-fonts"
FontPath "/usr/share/fonts/truetype/ttf-mgopen"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-telugu-fonts"
FontPath "/usr/share/fonts/truetype/ttf-kannada-fonts"
FontPath "/usr/share/fonts/truetype/ttf-oriya-fonts"
FontPath "/usr/local/share/fonts"
EndSection

Section
"Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section
"InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section
"InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Protocol" "evdev"
Option "Dev Name" "B16_b_02 USB-PS/2 Optical Mouse"
Option "Dev Phys" "usb-0000:00:02.0-7/input0"
Option "Device" "/dev/input/event1"
Option "Buttons" "10"
Option "ZAxisMapping" "4 5"
Option "Resolution" "800"
EndSection


#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
# Option "ZAxisMapping" "4 5"
#EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30.0 - 82.0
VertRefresh 50.0
- 85.0
Option
"DPMS"
EndSection

Section
"Device"
Identifier "NVIDIA Corporation NVIDIA Default Card"
Driver "nvidia"
# Option "Coolbits" "1"
Option "NoLogo"
EndSection

Section
"Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NVIDIA Default Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection
"Display"
Depth 1
Modes
"1280x1024"
EndSubSection
SubSection
"Display"
Depth 4
Modes
"1280x1024"
EndSubSection
SubSection
"Display"
Depth 8
Modes
"1280x1024"
EndSubSection
SubSection
"Display"
Depth 15
Modes
"1280x1024"
EndSubSection
SubSection
"Display"
Depth 16
Modes
"1280x1024"
EndSubSection
SubSection
"Display"
Depth 24
Modes
"1280x1024"
EndSubSection
EndSection
I would so appreciate some help!

/A sad Eazy
Eazy is offline   Reply With Quote
Old 04-16-06, 09:50 AM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Bad FPS with good hardware

It would be more helpfull if you posted the nvidia bugreport instead.
Lithorus is offline   Reply With Quote
Old 04-16-06, 02:57 PM   #3
Eazy
Registered User
 
Join Date: Nov 2005
Posts: 9
Default Re: Bad FPS with good hardware

ok, but wont. So I guesse its the end of it.
Eazy is offline   Reply With Quote
Old 04-16-06, 04:54 PM   #4
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Bad FPS with good hardware

Quote:
Originally Posted by Eazy
ok, but wont. So I guesse its the end of it.
Huh? The bugreport script is used to collect all sorts of usefull data which people here can use to help you. An xorg.conf won't tell us much about your problem, just the configuration.

I'm sorry if the reply wasn't what you expected, but it IS actually alot more helpfull to post the report. It's detailed how you do in one of the stickies.
Lithorus is offline   Reply With Quote
Old 04-17-06, 03:53 AM   #5
Eazy
Registered User
 
Join Date: Nov 2005
Posts: 9
Default Re: Bad FPS with good hardware

Sorry for being a bit stupid, but yesterday I had just enough of it. I bought expencive computer parts (have saved money a long time) to make my gaming a bit more smooth, but it made it worse instead.

I attached both my Install and bug log. Hopfully I have just made an error some where and maybe this can be solved.
Attached Files
File Type: zip BugAndInstallLog.zip (33.0 KB, 122 views)
Eazy is offline   Reply With Quote
Old 04-17-06, 04:50 AM   #6
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Bad FPS with good hardware

How's the FPS in other games, i.e. Quake4 and Doom3? Sounds like your UT2004 installations doesn't use the correct GL libraries or something.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-17-06, 07:58 AM   #7
Eazy
Registered User
 
Join Date: Nov 2005
Posts: 9
Default Re: Bad FPS with good hardware

I dont got any other game, but I think it will be the same with other games aswell, because glxgears gives really bad fps in fullscreen mode. I'll see if I can find a opengl-game in repository
Eazy is offline   Reply With Quote
Old 04-17-06, 08:08 AM   #8
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Bad FPS with good hardware

Glxgears is not a benchmark. I'm not convinced you actually have a problem, I'm sure your fps will be fine in a different game.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote

Old 04-17-06, 09:13 AM   #9
Eazy
Registered User
 
Join Date: Nov 2005
Posts: 9
Default Re: Bad FPS with good hardware

Borrowed a copy of Quake4 and installed, but I get the same low fps as in UT2004, so there must be something with my Linux. I didnt get any graphic error as I did in ut2004.
Eazy is offline   Reply With Quote
Old 04-17-06, 09:55 AM   #10
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Bad FPS with good hardware

Code:
ldd /usr/bin/glxinfo
	linux-gate.so.1 =>  (0xffffe000)
	libGL.so.1 => /usr/lib/libGL.so.1 (0xb7f26000)
	libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb7eb0000)
	libglut.so.3 => /usr/lib/libglut.so.3 (0xb7e86000)
	libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7e63000)
	libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7d35000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb7c75000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0xb7c68000)
	libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7c55000)
	libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb7c4f000)
	libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7c4b000)
	libdrm.so.1 => /usr/lib/libdrm.so.1 (0xb7c44000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b5e000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7b53000)
	/lib/ld-linux.so.2 (0xb7f9b000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb7b4f000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7b4b000)
mssing:
libGLcore.so.1 => /usr/lib/libGLcore.so.1
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1

=> your nice gfx renders in software mode!


so, delete all libGL.so libGLcore.so files in /usr/lib or /usr/X11R6/lib (e.g rm /usr/lib/libGL.so* ... and rm /usr/lib/libGLcore.so*
rm /usr/X11R6/lib/libGL.so*, ... BUT NOT libGLU.so) then _reinstall_.

if this doesn't fix the problem... run glxinfo and attach the output.
and what says ls -o /usr/lib/libGL.so.1?
chunkey is offline   Reply With Quote
Old 04-17-06, 10:14 AM   #11
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Bad FPS with good hardware

Looks like something went wrong during installation indeed. Perhaps you should read the posts in the installation instruction you linked to, that seems like the correct place for your problems.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-17-06, 11:37 AM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Bad FPS with good hardware

Or please post an nvidia-bug-report.log, as was requested a few days ago.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Podcast: DDN WOS Software on OCP Storage Hardware to Enable Hyperscale Storage Clouds News Archived News Items 0 05-22-12 07:10 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
ECS K7S5A SiS 735 on NewEgg a good deal ($53)? ragejg CPUs, Motherboards And Memory 6 10-03-02 10:02 PM
hardware T&L nosrema NVIDIA Linux 2 09-14-02 02:35 PM
low fps why??? nipster Benchmarking And Overclocking 4 08-07-02 02:35 PM

All times are GMT -5. The time now is 11:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.