Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-06, 02:44 PM   #1
doctorzoidberg
Registered User
 
Join Date: Apr 2006
Posts: 3
Default 1.0.8756 + galaxy 6800xt = missing GL_ARB_fragment_program extension

Hi everybody. I tried running the "water" plugin for compiz, but it complains about missing GL_ARB_fragment_program extension.
In glxinfo it's not listed, but a friend with 6600GT has it. I'd like to know _why_ this happens and how to fix it (maybe it's a driver bug).
I'm running a 2.6.15 gentoo kernel on amd64.
Not that I need that extension (i can live without water effect, and also without XGL) but it's not nice to have a quite new card that doesn't support something...
Any idea ?
doctorzoidberg is offline   Reply With Quote
Old 04-16-06, 02:51 PM   #2
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: 1.0.8756 + galaxy 6800xt = missing GL_ARB_fragment_program extension

Is your opengl working correctly?

glxinfo

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800 GT/AGP/SSE2/3DNOW!
OpenGL version string: 2.0.2 NVIDIA 87.56
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 04-16-06, 02:54 PM   #3
doctorzoidberg
Registered User
 
Join Date: Apr 2006
Posts: 3
Default Re: 1.0.8756 + galaxy 6800xt = missing GL_ARB_fragment_program extension

Yes, it is. but the _really_ odd thing is that in xorg i have that extension....
doctorzoidberg is offline   Reply With Quote
Old 04-16-06, 03:21 PM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: 1.0.8756 + galaxy 6800xt = missing GL_ARB_fragment_program extension

When you use XGL with compiz you use mesa's libGL for the texture from pixmap extension. Because of this you won't have that extension. When you don't use XGL and just try glxinfo you'll see that you have the extension.
Thunderbird is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GALAXY Launches the GeForce GTX 670 and GTX 670 GC! News Archived News Items 0 05-10-12 09:28 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 01:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.