Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-18-06, 09:43 PM   #1
louis nichols
Registered User
 
louis nichols's Avatar
 
Join Date: Mar 2006
Posts: 6
Default screensavers problem after upgrade to 1.0-8756

Hi everybody!

I use Ubuntu Breezy on a machine with a Geforce FX 5200 videocard and things have been running smoothly for the most part.

I just upgraded the drivers to 1.0-8756 and things seemed alright at first, but tghen I noticed screensavers don't work properly when transparency is enabled for windows. All I see are a few bits and pieces of the screensaver, running with like 2 fps, on areas of the screen that corespond to where transparent windows are.

My desktop environment is Gnome, configured to run kwin as a window manager, instead of metacity, partly because setting transparencies is easier. This has worked without problems with drivers before this one.

Probably some info from lg files is needed to help me, but I dunno which one(s).

Can anybody help?

EDIT: forgot to mention, if needed, that screensavers run perfectly when transparencies are disabled
louis nichols is offline   Reply With Quote
Old 04-18-06, 10:25 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: screensavers problem after upgrade to 1.0-8756

Hi Louis,

Which version of X are you using? GLX with Composite is only designed to work correctly with X.org 6.9 and higher.

-- Aaron
AaronP is offline   Reply With Quote
Old 04-18-06, 10:30 PM   #3
louis nichols
Registered User
 
louis nichols's Avatar
 
Join Date: Mar 2006
Posts: 6
Default Re: screensavers problem after upgrade to 1.0-8756

Quote:
Originally Posted by AaronP
Hi Louis,

Which version of X are you using? GLX with Composite is only designed to work correctly with X.org 6.9 and higher.

-- Aaron
Well, I learn a new thing every day

Indeed, xorg under Breezy is only 6.8. So you're saying that thing working fine with previous versions of the driver was just luck?

In this case, is upgrading Xorg a guaranteed solution to this? Well... I'd start using Dapper testing rather than compiling X, but it's good to know....
louis nichols is offline   Reply With Quote
Old 04-18-06, 11:19 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: screensavers problem after upgrade to 1.0-8756

Quote:
Originally Posted by louis nichols
So you're saying that thing working fine with previous versions of the driver was just luck?
Basically, yes. With previous drivers, OpenGL applications would draw on top of everything else, causing flickering and other problems. The new drivers changed the way Composite+OpenGL windows are handled, but require X.org 6.9 or higher to work properly. Note that the AllowGLXWithComposite option is not, and never has been, supported.
AaronP is offline   Reply With Quote
Old 04-18-06, 11:24 PM   #5
louis nichols
Registered User
 
louis nichols's Avatar
 
Join Date: Mar 2006
Posts: 6
Default Re: screensavers problem after upgrade to 1.0-8756

Quote:
Originally Posted by AaronP
Basically, yes. With previous drivers, OpenGL applications would draw on top of everything else, causing flickering and other problems. The new drivers changed the way Composite+OpenGL windows are handled, but require X.org 6.9 or higher to work properly. Note that the AllowGLXWithComposite option is not, and never has been, supported.

Ok, thanks. I understand. (and I actually remember the flickering)
louis nichols is offline   Reply With Quote
Old 04-19-06, 12:43 AM   #6
LinuxRocks
Registered User
 
Join Date: May 2005
Posts: 55
Default Re: screensavers problem after upgrade to 1.0-8756

I wouldn't go an blame the issue on Xorg; however, that is a pretty old version.

I am running version 7 and with composite enabled, the OpenGL screen savers in KDE, UT2004, and some other OpenGL stuff is broke.

I have already posted this issue, and there is a bug report in for it; the Nvidia people were able to re create the issue.

Problem is with the driver for the most part and we are still waiting for a fix

If there are testers needed for a patch, I would be glad to assist...

Joe
LinuxRocks is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.