Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-26-06, 03:46 AM   #1
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Stereo emitter sync problem on Fedora 5 using 8756

I've installed the 8756 driver on Fedora Core 5, kernel 2.6.16-1.2096_FC5. The card is a NV28GL [Quadro4 980 XGL]. Everything works just fine, except stereo emitter synchronization (Stereographics E2). The image appears in stereo on screen and the emitter led lights when stereo is turned on, but the emitter is out of sync. When viewed through stereo glasses, the picture flickers badly and the stereo effect is way off.

We have various versions of the Quadro cards in use. Stereo sync works correctly on NV36GL [Quadro FX 1100] cards using this driver. Older NV25GL [Quadro4 750 XGL] (rev a3) cards are even worse than the NV28GL ones: the emitter led never lights. It seems the emitter gets no signal at all from the card. The GL window is drawn in stereo, though.

The stereo worked correctly on all of these machines using Fedora Core 3 (kernels 2.6.11 and 2.6.12 and 7xxx drivers).

I'm attaching nvidia-bug-report.sh output for the NV28GL machine.
Attached Files
File Type: txt nvidia-bug-report.txt (97.6 KB, 201 views)
Gemini is offline   Reply With Quote
Old 04-26-06, 11:39 PM   #2
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Re: Stereo emitter sync problem on Fedora 5 using 8756

Version 8178 of the driver (requires patching to work on Fedora 5) has the same problem. Is the problem just kernel/compiler incompatibility? Does anyone see this behaviour on an older kernel/distribution?
Gemini is offline   Reply With Quote
Old 04-27-06, 03:44 AM   #3
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Re: Stereo emitter sync problem on Fedora 5 using 8756

I tested the 8756 driver on Fedora Core 3 and a NV28 chip, and the stereo sync does not work. The kernel was Fedora 3's 2.6.12. So the problem does not seem to be specific to the kernel or gcc version, but the driver version.
Gemini is offline   Reply With Quote
Old 04-28-06, 08:13 AM   #4
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Re: Stereo emitter sync problem on Fedora 5 using 8756

I tested the recent versions of the nvidia driver on Fedora 3, and the
one that still works is 7676. All the 8xxx versions after that are
broken. Version 7676 cannot be installed on Fedora 5, because it does
not compile against kernels 2.6.15 and 2.6.16. The solution turned out
to a patch to the driver found on this forum here

http://www.nvnews.net/vbulletin/showthread.php?t=66750

After patching, the driver compiles/links against kernel version
2.6.16.

So, for the record: Quadro stereo sync on NV25 and NV28 chips is
broken in driver versions 8174, 8178 and 8756.
Gemini is offline   Reply With Quote
Old 07-19-06, 08:14 PM   #5
Saes_1
Registered User
 
Join Date: Jul 2006
Posts: 1
Default Re: Stereo emitter sync problem on Fedora 5 using 8756

Quad Buffer stereo is still broken in the 8762 release for NV28 (at least on Ubuntu Breezy and Dapper, kernel >v. 2.6.12 ). It remains a frustration, it works fine with our Quadro FX based workstations.
Saes_1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.