Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-27-06, 03:51 AM   #1
chandru.in
Registered User
 
Join Date: Apr 2006
Posts: 7
Unhappy System freezes while running OpenGL applications

Hi,

When I run OpenGL applications like chromium, OpenGL Screensavrs, etc. for a considerable amount of time, the system freezes completely. The only way to come out of this is a hard-reboot.

I do not understand where the problem lies(Hardware/Software).

nVIDIA driver - 1.0-8756

VGA Card - nVIDIA GeFORCE MX 4000 64 MB
RAM - 256 MB
CPU - Intel Celeron 2.0 GHz

Please Help Me.



I'm using Slackware 10.2 (if that might help). I have not upgraded any package except that I installed the latest nVIDIA divers.
chandru.in is offline   Reply With Quote
Old 04-27-06, 04:33 AM   #2
chandru.in
Registered User
 
Join Date: Apr 2006
Posts: 7
Default Re: System freezes while running OpenGL applications

Has anyone had this problem here?
chandru.in is offline   Reply With Quote
Old 04-27-06, 06:53 AM   #3
aktarus
Registered User
 
Join Date: Mar 2006
Posts: 4
Default Re: System freezes while running OpenGL applications

Hi, same problem here. I have a samsung X10 laptop with xorg version 7.0.14 (Debian unstable) and nvidia driver version 8756.
aktarus is offline   Reply With Quote
Old 04-27-06, 07:13 AM   #4
a7v
Registered User
 
Join Date: Jun 2005
Posts: 67
Default Re: System freezes while running OpenGL applications

I've had similar problems where games etc would lock up after a while, often with flashing textures.
In my case it was something electrical, probably due to my old and weak power supply. After I fiddled with AGP Drive Strength Settings in BIOS I have a stable system again.
__________________
Computer stuff I've owned at one time or another:
CPUs: K6-3 400, Duron 600, Thunderbird 1400, Barton 2500, Duron 1800, A-64 3700+, C2D E7200
Motherboards: Shuttle Via MVP, Asus A7V, Asus A7V133, Asus N8X-VM400, Abit NF7, Abit UL8, Asus P5Q Pro
Graphics Cards: TNT2, GF 2 MX, GF 2 Pro, GF4 MX, GF FX 5500, GF 6600, GF 7600 GT, GF 9800GT
a7v is offline   Reply With Quote
Old 04-27-06, 08:49 AM   #5
aktarus
Registered User
 
Join Date: Mar 2006
Posts: 4
Default Re: System freezes while running OpenGL applications

Ok, after a few investigation, I noticed that Xorg load both glx and GLcore modules whereas my xorg.conf does not include any reference to the GLcore module. If I remove the GLcore.so file, Xorg no longer load the glx module, arguing that the GLcore module is required by the glx one:

(II) Module glx: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(WW) Warning, couldn't open module GLcore
(II) UnloadModule: "GLcore"
(II) UnloadModule: "glx"
(II) Unloading /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (a required submodule could not be loaded, 0)
aktarus is offline   Reply With Quote
Old 04-29-06, 03:46 AM   #6
chandru.in
Registered User
 
Join Date: Apr 2006
Posts: 7
Default Re: System freezes while running OpenGL applications

Hi a7v, could you please explain, what exactly you had done??
chandru.in is offline   Reply With Quote
Old 05-01-06, 12:29 PM   #7
pampelmuse
Registered User
 
Join Date: Aug 2005
Posts: 11
Default Re: System freezes while running OpenGL applications

Hallo

I have the same experience with GeForce FX Go 5600 in a Vaio laptop.
I have opened also a thread for this, but did not come to a solution.
After playing around with a options in 2.6.* Kernel,
I already thought that it may be a hardware/thermal problem.

But now I found that a (very) old configuration works without freeze.
This is Kernel 2.4.22 with NVidia-4496 (!).

Maybe you can check-out this configuration.

Next testing I will do is Kernel 2.4.22 with latest NVidia driver,
do find out if it is kernel or NVidia driver related.

Best Regards

Christoph
pampelmuse is offline   Reply With Quote
Old 05-09-06, 02:45 PM   #8
pampelmuse
Registered User
 
Join Date: Aug 2005
Posts: 11
Default Re: System freezes while running OpenGL applications

Hallo

Now I tested Kernel 2.4.22 with NVIDIA 8756 and
I get the very same hangs as with 2.6.* Kernels.
So next testing would be 4496 against 2.6 but there the module does not compile.

Does anybody know how to to this?

Thank you

Best Regards

Christoph
pampelmuse is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 2 freezes system under Direct3D Matthius NVIDIA GeForce 7, 8, And 9 Series 20 06-05-12 02:46 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Multiple OpenGL applications and NVidia gbrauer NVIDIA Linux 7 09-01-02 04:47 PM
SMP system hangs with OpenGL chazmati NVIDIA Linux 9 08-26-02 09:28 AM
System freezes while gaming with a GeForce4 Grimwall NVIDIA GeForce 7, 8, And 9 Series 12 07-31-02 07:50 AM

All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.