Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-13-06, 10:20 PM   #13
pest_789
Registered User
 
Join Date: Nov 2006
Posts: 33
Default Re: 1080i

It didn't work

Here's what I tried:

Code:
Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       28.0 - 64.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
    DisplaySize    656 369
#    ModeLine       "1920x1080i" 74.25 1920 1960 2016 2200 1080 1082 1088 1125 Interlace
    ModeLine       "1080i3" 148.5 1920 2008 2052 2200 1080 1084 1094 1124 interlace +hsync +vsync
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV43 [GeForce 6600 GT]"
    Driver         "nvidia"
    Option         "RenderAccel" "True"
    Option         "ExactModeTimingsDVI" "True"
    Option         "UseEdidDpi"   "FALSE"
    Option         "DPI"   "150x150"
    Option         "ModeValidation" "AllowNon60HzDFPModes,NoVertRefreshCheck,NoEdidMaxPClkCheck,NoHorizSyncCheck"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV43 [GeForce 6600 GT]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option         "TVStandard" "HD1080i"
    Option         "ConnectedMonitor" "DFP"
    SubSection     "Display"
          Modes          "1080i3"
    EndSubSection
EndSection
I had to add NoEdidMaxPClkCheck and NoHorizSyncCheck to ModeValidation to get the modeline to validate, but the tv didn't like it at all. It went into 'no signal' mode.

I don't understand this problem at all. It HAS to be a bug. 8774 worked perfectly for desktop and general display, but would crash when playing video with xv. Now I understand the xv problem has been fixed but I can't get a picture! This is VERY frustrating
pest_789 is offline   Reply With Quote
Old 11-14-06, 12:59 AM   #14
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: 1080i

Option "ExactModeTimingsDVI" "True"

Never worked quite right for me, my TV never sync'd when I use that with valid modelines. Could you try commenting it out or disabling it? Also, my modeline has +hsync +vsync (from my tv EDID).
asdere is offline   Reply With Quote
Old 11-14-06, 11:28 PM   #15
pest_789
Registered User
 
Join Date: Nov 2006
Posts: 33
Default Re: 1080i

That did it - I've got the crazy modeline working. Even with the new beta driver I still can't get mythtv to play video with xv without crashing Xorg.
pest_789 is offline   Reply With Quote
Old 11-15-06, 01:38 AM   #16
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: 1080i

Quote:
Originally Posted by pest_789
That did it - I've got the crazy modeline working. Even with the new beta driver I still can't get mythtv to play video with xv without crashing Xorg.
Does it crash with mplayer -vo xv?
asdere is offline   Reply With Quote
Old 11-18-06, 06:04 PM   #17
pest_789
Registered User
 
Join Date: Nov 2006
Posts: 33
Default Re: 1080i

Quote:
Originally Posted by asdere
Does it crash with mplayer -vo xv?

yep - in exactly the same way
pest_789 is offline   Reply With Quote
Old 11-21-06, 10:58 PM   #18
wognvnews
Registered User
 
Join Date: Nov 2006
Posts: 12
Default Re: 1080i

I've had a similar problem since moving from 8776 to 9626/9629. The following mode line gave me a nice 1080i output on my 1080i samsung CRT with 8776 and older, but with 9626 or newer it only shows the top 540 lines on the screen. I've played around with setting and no luck getting 1080i to display correctly.

################################################## ####
# 1920x1080_120i appears to be the exact mode the EDID reports, but in order to use it explicitly
# I had to have HorizSync 15.0 - 67.0, ExactModeTimingsDVI TRUE, UseEdidFreqs FALSE, NoEdidMaxPClkCheck
ModeLine "1920x1080_120i" 148.4 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync interlace

Any idea welcomed. Thanks.
wognvnews is offline   Reply With Quote
Old 11-22-06, 12:23 PM   #19
pest_789
Registered User
 
Join Date: Nov 2006
Posts: 33
Default Re: 1080i

try removing ExactModeTimingsDVI and adding NoHorizSyncCheck (one at a time, so you know which one fixes it, if any)

Edit: Actually, now that I think about it, the only time it gave the top 540 lines and not a black screen was when it was using the EDID nvidia-auto-select mode that it decided on. I don't think it's actually using the modeline you listed above. You really should do a 'startx -- -logverbose 6' and then look at /var/log/Xorg.0.log (or /var/log/XFree86.0.log) and see exactly what it's trying to do. I think it's actually rejecting your modeline and just picking one from EDID, which means you should try this line in your xorg.conf:

Option "ModeValidation" "AllowNon60HzDFPModes, NoVertRefreshCheck, NoEdidMaxPClkCheck, NoHorizSyncCheck"

and remove your ExactModeTimingsDVI line.

Last edited by pest_789; 11-22-06 at 12:43 PM.
pest_789 is offline   Reply With Quote
Old 11-23-06, 10:38 AM   #20
wognvnews
Registered User
 
Join Date: Nov 2006
Posts: 12
Default Re: 1080i

Quote:
Originally Posted by pest_789
... I don't think it's actually using the modeline you listed above.
You were absolutely right! It just so happened that one of the EDID modes got named "1920x1080_120i", which is what actually got used. After renaming my mode line to "1920x1080__120i" I was able to select it, but found it was too fast for my TV. Then changed to 60Hz as shown below and then it worked for 8776.

##################################################
# 1920x1080__60i appears to be the exact mode the EDID reports, but in order to use it explicitly
# I had to have ExactModeTimingsDVI TRUE else got mode too large for DFP message
ModeLine "1920x1080__60i" 74.18 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync interlace

So for 8776, I see that I had been happily using the 1920x1080 EDID mode all along without knowing it.

So I reloaded 9629 and found that I STILL only see the top half of the display streched to fill the screen. Tried both the EDID mode and my custom mode.

Also played with the new scaling settings in nvidia-settings utility. No difference.

Any other other ideas? Thanks.
wognvnews is offline   Reply With Quote

Old 11-23-06, 11:44 AM   #21
pest_789
Registered User
 
Join Date: Nov 2006
Posts: 33
Default Re: 1080i

did you try adding the modevalidation option line from my last post?
pest_789 is offline   Reply With Quote
Old 11-25-06, 04:08 PM   #22
wognvnews
Registered User
 
Join Date: Nov 2006
Posts: 12
Default Re: 1080i

Quote:
Originally Posted by pest_789
did you try adding the modevalidation option line from my last post?
Sorry, I forgot to mention that I did try those options.

Update: I found a dumb typo in my xorg.conf, and now have my 1920x1080__60i custom modeline working great with 9629. Out of curiousity, one question remains, ...why doesn't the 1920x1080 EDID mode display correctly with 9629? It worked fine with 8776.

(II) NVIDIA(0): --- Modes in ModePool for SAMSUNG (DFP-0) ---
(II) NVIDIA(0): "nvidia-auto-select" : 1920 x 1080 @ 120.1 Hz Interlace (from: EDID)
(II) NVIDIA(0): "1920x1080" : 1920 x 1080 @ 120.1 Hz Interlace (from: EDID)
(II) NVIDIA(0): "1920x1080__60i" : 1920 x 1080 @ 60.0 Hz Interlace (from: X Configuration file ModeLine)
Attached Files
File Type: zip nvidia-bug-report.log_9629.zip (33.3 KB, 173 views)
wognvnews is offline   Reply With Quote
Old 11-25-06, 09:41 PM   #23
PenGun
Registered User
 
Join Date: Jan 2006
Posts: 93
Default Re: 1080i

I gave up on DVI via DVI - HDMI and turned to component output fot my Sony 34XS944 CRT HDTV. Works well and the 720p I can do in both is pretty well the same.

I can get 1080i with the TVOut and it's nice for 1080i stuff but 720p works well for most things, games included.

PenGun
PenGun is offline   Reply With Quote
Old 06-09-07, 11:13 PM   #24
crow
Registered User
 
Join Date: Jan 2004
Posts: 43
Default Re: 1080i

I'm having almost the exact same problem. It works fine with 8776, using the EDID information from my HDTV for the 1080i mode. I've tried tons of modelines that I've found on the net for 1080i, and they all result in displaying a blank screen.

All I want to do is to create a custom modeline that is the same as what it's getting from the EDID, so that with the 9xxx drivers it will work correctly. All my attempts have failed.

With the 9755 drivers, the EDID modeline displays 1920x540 instead of 1920x1080.

I'm beginning to think that there's a bug in the 8776 driver where interlaced modes from EDID are parsed differently from modes from custom modelines. Hence, it may be impossible in 8776 to specify a custom modeline that is exactly the same as an interlaced mode from the EDID. With the 9xxx drivers, the EDID is now interpreted the same way as the custom modelines, so while it's consistent now, there's no way to get it to display 1080i.
crow is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why You Should Watch and Record Video in 720p Instead of 1080i [Video] News Archived News Items 0 05-10-12 07:00 AM

All times are GMT -5. The time now is 01:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.