Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-30-06, 05:34 PM   #1
Gnuyen
Registered User
 
Join Date: May 2003
Posts: 8
Send a message via ICQ to Gnuyen Send a message via AIM to Gnuyen Send a message via Yahoo to Gnuyen
Default 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

Running Ubuntu Dapper, apt-get dist-upgraded to the newest nvidia drivers.
System Specs: Intel Pentium-D running 2.6.15-21-amd64-generic, running a GeForce 6600 on PCI-E with two Dell 2405fpw LCDs attached.
System was working fine before the upgrade, at 1920x1200,1920x1200. Xorg 7.0

Symptoms: Upon running X the system locks up black screens on both displays. I often can no longer ssh into the system when this happens.

Xorg.conf, modified slightly from original configuration for debugging purposes
Code:
Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
#	Load	"GLcore"
	Load	"bitmap"
	Load	"ddc"
#	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Buttons"		"7"
	Option		"Device"		"/dev/input/mouse0"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"Emulate3Buttons"	"false"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"stylus"
	Driver		"wacom"
	Option		"Device"		"/dev/input/wacom"
	Option		"Type"			"stylus"
	Option		"USB"			"on"
	Option		"PressCurve"		"0,0,100,100"
	Option		"Twinview"		"horizontal"
EndSection

Section "InputDevice"
	Driver        "wacom"
	Identifier    "eraser"
	Option        "Device"        "/dev/input/wacom"   #USB ONLY
	Option        "Type"          "eraser"
	Option        "USB"           "on"                  #USB ONLY
	Option		"Twinview"		"horizontal"
EndSection

Section "InputDevice"
	Driver        "wacom"
	Identifier    "cursor"
	Option        "Device"        "/dev/input/wacom"   #USB ONLY
	Option        "Type"          "cursor"
	Option        "Mode"          "relative"
	Option        "USB"           "on"                  #USB ONLY
	Option		"Twinview"		"horizontal"
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV43 [GeForce 6600]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Option "TwinView" "1"
	VideoRam	256
	Option "SecondMonitorHorizSync" "30-81"
	Option "SecondMonitorVertRefresh" "56-75"
	Option "TwinViewOrientation" "RightOf"
#	Option "MetaModes" "1920x1200,1920x1200; 1680x1050,1680x1050; 1280x800,1280x800; 1280x1024,1280x1024; 1024x768,1024x768; 1920x1200, NULL; 1680x1050, NULL; 1280x800, NULL; 1280x1024, NULL; 1024x768, NULL; 800x600, NULL; 640x480, NULL; NULL, 1920x1200; NULL, 1680x1050; NULL 1280x800;NULL, 1280x1024; NULL, 1024x768; NULL, 800x600; NULL, 640x480;"
	Option "ConnectedMonitor" "DFP, DFP"
	Option "Rotate" "on"
	Option "RandRRotation" "on"
EndSection

Section "Monitor"
	Identifier	"Dell 2405fpw"
	Option		"DPMS"
	HorizSync	30-81
	VertRefresh	56-76
#	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
#	Modeline "1920x1200" 154.0 1920 1968 2000 2080 1200 1203 1209 1235
#	Modeline "1680x1050" 146.2 1680 1960 2136 2240 1050 1080 1086 1089 -hsync +vsync
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV43 [GeForce 6600]"
	Monitor		"Dell 2405fpw"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1920x1200_60" "1600x1200" "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice    "stylus"    "SendCoreEvents"
        InputDevice    "eraser"    "SendCoreEvents"
        InputDevice    "cursor"    "SendCoreEvents"
EndSection

Section "DRI"
	Mode	0666
EndSection
I think the problem might be the new EDID stuff?
Any help would be extremely appreciated!
__________________
I do not fear computers. I fear the lack of them. -- Isaac Asimov
Gnuyen is offline   Reply With Quote
Old 04-30-06, 05:37 PM   #2
Gnuyen
Registered User
 
Join Date: May 2003
Posts: 8
Send a message via ICQ to Gnuyen Send a message via AIM to Gnuyen Send a message via Yahoo to Gnuyen
Default Re: 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

Attached is the Xorg.0.log, as it's too long to have inline:
Attached Files
File Type: log Xorg.0.log (23.5 KB, 123 views)
__________________
I do not fear computers. I fear the lack of them. -- Isaac Asimov
Gnuyen is offline   Reply With Quote
Old 04-30-06, 06:04 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

There is currently a known bug in 1.0-8756 where TwinView with two DFPs results in a kernel panic.

Does this work in 1.0-8178?

As a side note, I'd suggest removing the ConnectedMnoitor option from your X configuration, unless you have a good reason for using it as its documented.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-30-06, 07:15 PM   #4
Gnuyen
Registered User
 
Join Date: May 2003
Posts: 8
Send a message via ICQ to Gnuyen Send a message via AIM to Gnuyen Send a message via Yahoo to Gnuyen
Default Re: 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

Thanks for your help!

I believe prior to the upgrade I was running 8178 and it worked fine. I will attempt to run without twinview and see if it crashes.

Is there a link to information about this bug some place?

Thanks again!
__________________
I do not fear computers. I fear the lack of them. -- Isaac Asimov
Gnuyen is offline   Reply With Quote
Old 05-01-06, 06:24 PM   #5
Gnuyen
Registered User
 
Join Date: May 2003
Posts: 8
Send a message via ICQ to Gnuyen Send a message via AIM to Gnuyen Send a message via Yahoo to Gnuyen
Default Re: 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

Okay it works with a single view.. is there a workaround for this crash?

Thanks
__________________
I do not fear computers. I fear the lack of them. -- Isaac Asimov
Gnuyen is offline   Reply With Quote
Old 05-01-06, 06:44 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0-8756 x86-64 on 2 Dell 2405fpw X lockup

The only workaround is to use analog on at least one of the displays. The next driver release should have this bug resolved.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.