Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-09-06, 06:38 AM   #1
xehonk
Registered User
 
Join Date: May 2006
Posts: 1
Default nvidia-settings error: BadMatch

Hi,

since upgrading to the newest nvidia-settings (8756) and nvidia-drivers (20051122), I get the following problem (it worked just fine before upgrading):

Code:
honk@honk ~ $ nvidia-settings 

WARNING: NV-CONTROL extension not present on screen 2 of this Display.


WARNING: NV-CONTROL extension not present on screen 2 of this Display.

The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 97 error_code 8 request_code 144 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Screen 2 is a tft on some old s3 savage4. If I start X without that screen enabled, nvidia-settings work just fine.

I'm using the gentoo ebuild to build the nvidia-settings, but using the official build from nvidia.com doesnt work either.



Attachements: nvidia-bug-report.log as well as my lspci output (I figured I'd post this, as the bug-report tool was complaining about my missing /proc/pci *g*), my xorg.conf and my Xorg.0.log (with -- -logverbose 5 as requested).
Attached Files
File Type: txt lspci.txt (1.8 KB, 128 views)
File Type: zip nvidia-bug-report.zip (23.8 KB, 125 views)
File Type: zip Xorg.0.zip (12.1 KB, 130 views)
File Type: zip xorg.zip (1.5 KB, 132 views)
xehonk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Found Simpsons in NVIDIA registry settings! ShVen NVIDIA GeForce 7, 8, And 9 Series 6 10-06-02 09:26 PM

All times are GMT -5. The time now is 08:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.