Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-11-06, 03:14 PM   #1
lbiechele
Registered User
 
Join Date: May 2006
Posts: 2
Default nvidia error on loading module

Hello I am very new in doing asks in forums

on a debian system i cant modprobe the nvidia module.
the message on modprobe nvidia is:
"FATAL: Error inserting nvidia (/lib/modules/2.6.16/nvidia/nvidia.ko): Invalid module format".

the kernel i made is 2.6.16.
perhaps someone could say what to do?
Tanks a lot
lbiechele is offline   Reply With Quote
Old 05-11-06, 03:19 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nvidia error on loading module

The most likely problem is that you built the nvidia kernel module with a different version of gcc than was used to build your kernel. Please post the installer log if you have additional questions or problems.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 05-13-06, 02:37 AM   #3
lbiechele
Registered User
 
Join Date: May 2006
Posts: 2
Default Re: nvidia error on loading module

good morning

i didnt expect that the answer is so very fast.
i make a new kernel with make-kpkg --initrd kernel_image. boot from the kernel
, then make-kpkg modules_image
and now i get

sat:~# cd /usr/src/linux-2.6.16
sat:/usr/src/linux-2.6.16# make-kpkg modules_image
exec debian/rules DEBIAN_REVISION=2.6.16-10.00.Custom modules_image
====== making .config because of Makefile ======

test -f .config || test ! -f .config.save || \
cp -pf .config.save .config
test -f .config || test ! -f .config || \
cp -pf .config .config
test -f .config || test ! -f ./debian/config || \
cp -pf ./debian/config .config
test -f .config || (echo "*** Need a config file .config" && false)
echo "The UTS Release version in include/linux/version.h"; echo " \"\" "; echo "does not match current version:"; echo " \"2.6.16\" "; echo "Please correct this."; exit 2
The UTS Release version in include/linux/version.h
""
does not match current version:
"2.6.16"
Please correct this.
make: *** [modules_image] Fehler 2


thanks very much

lu
lbiechele is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 05:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.