Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-03, 10:41 AM   #1
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default (EE) LoadModule: Module glx does not have a glxModuleData data object.

Ok, there is A VERY LONG TIME I want to get the 3D acceleration to work, and this time I think I'm really close. I'm running a SuSE 8.0, and I followed this howto to the letter.

When I run sax2 to configure Xfree86 4.0, I change the drivers from "nv" to "nvidia", and I set the "Load glx" option. When I try to run this, I get :

(EE) LoadModule: Module glx does not have a glxModuleData data object.
(EE) Failed to load module "glx" (invalid module, 0)

If I try to run the nvidia drivers without glx, everything is fine, except I have 1 fps in UT

I searched about this type of error but up to now, nothing interesting. I used the source GLX drivers and compiled them, but I tried to install the rpm's for SuSE 8.0 too. Now, maybe I should uninstall the compiled drivers before trying to install the rpm's, but I don't know how to do this.

Any help would be greatly appreciated, 'cause I already spent MANY hours (not to say many days) on this and I'm getting tired...
[Mystik_Cool] is offline   Reply With Quote
Old 02-01-03, 12:21 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

The "glxModuleData object" message seems to be a SuSE specific problem (at least according to a Google search -- it only showed up on SuSE discussion lists).

One possible thing to check is that you have a correct /usr/X11R6/lib/modules/extensions/libglx* file installed -- I know that some older rpm versions strip symbols that they shouldn't, and some systems don't install a libglx.so -> libglx.so.1.0-4191 symlink. Check that the symlink is there, and run file on the target of the symlink to see whether or not it's stripped.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-01-03, 02:13 PM   #3
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

The symlink libglx.so was not there. I added it. But still not result. The strange thing is that I got it working : I ran glxgears at 220FPS ! But then I rebooted, and get the error message I posted again.

I'm currently trying to reinstall everything once again, to see if it works. But up to now, no result. I'm a little bit lost in all symlinks and .so files and all the lib directories !
[Mystik_Cool] is offline   Reply With Quote
Old 02-01-03, 06:24 PM   #4
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

I reinstalled the glx stuff many times, I can't get it running again, always the same error. This must be a problem with the symlinks and libraries...
If someone could post a list of lib and symlinks (all the .so and .so.*) that should be there or shouldn't, it would really help me, 'cause I'm lost !

BTW, what did you mean by "run file on the target of the symlink to see whether or not it's stripped."

Thanx a lot !

PS : when I make the /usr/X11R6/lib/modules/extension/libglx.so symlink manually, and then try to restart X, it doesn't run because of the error I mentionned, deletes the libglx.so, and comes back non-using glx !

PPS : in fact, it seems that a lot of modifications I made (changing symlinks from Mesa files,...) are deleted and everything is set back when I try to restart X and it fails...

PPPS : I have two files : libGLcore.1.0.4191 and libGLcore.1.0.4191.nv_glx... which one is the right one ???

Last edited by [Mystik_Cool]; 02-01-03 at 06:42 PM.
[Mystik_Cool] is offline   Reply With Quote
Old 02-01-03, 09:10 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Arrrgh! Apparently SuSE is being "helpful" by changing your filesystem on you.

You should have the following files, all in /usr/X11R6/lib/modules/:

extensions/libglx.so (should be a symlink to...)
extensions/libglx.so.1.0-4191
drivers/nvidia_drv.o

Then, in /usr/lib, there should be:

libGL.so (a symlink to...)
libGL.so.1 (a symlink to...)
libGL.so.1.0-4191
libGLcore.so.1 (a symlink to...)
libGLcore.so.1.0-4191

That should be it, at least from the GLX package.

If your symlink keeps getting deleted, it may work to hardlink the libglx.so.1.0-4191 file, or it might work to copy it. I have a feeling that you can get rid of that libGLcore.xxxx.nv_glx one, but you probably want to move it somewhere else temporarily instead.

With the file comment, I meant run file /usr/X11R6/lib/modules/extensions/libglx.so.1.0-4191. That will print a bunch of info on what kind of file the libglx.whatever is.

I believe there is a way to use some of SuSE's distro-specific tools to set this up (I believe there's a switch2nvidia_glx script somewhere, for example), but I've never used SuSE, so I don't know how to do that.

Maybe a search for switch2nvidia_glx would turn something up? It would have to be a distro-specific how-to...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-02-03, 04:21 AM   #6
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

I'm going to become crazy !!!

I moved all useless files. So now, I have what you said, exactly. But when I start X, I still get the error message. The ONLY thing changing now is the /usr/lib/libGL.so.1. Even if I make a copy of the right file with this name, after running X again, it becomes a symlink to GL/libGL.so.1.3.mesasoft. But I MOVED this GL directory, it's not existing anymore, even after running X !!!

switch2nvidia was not really helpfull. Easier to do everything manually, to be sure...

I don't know what to do ! When I type "make" to make the GLX, the libGL.so.1 becomes a correct symlink (and I thing everything else is correct). But then I run sax2, it tries to load GLX, fails, and then the libGL.so.1 is again a symlink to a mesa file !
Maybe I forgot to delete some file somewhere... ? The strange thing is that I got it working once !

[edit] : I just realized the ./modules/extension/libglx.so was deleted too, even if it was a hard copy of the libglx.so.1.0.4191

PS :
linux:/usr/X11R6/lib/modules/extensions # file libglx.so.1.0.4191
libglx.so.1.0.4191: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped
Correct ?

Last edited by [Mystik_Cool]; 02-02-03 at 04:30 AM.
[Mystik_Cool] is offline   Reply With Quote
Old 02-02-03, 06:57 AM   #7
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

There is something strange with the GLX suse8.0 rpm : the files in it are called lib....nv_glx.
Are you sure I can forget those files ? Then I should only try to install from the source (tar.gz) GLX drivers...

Anyway, in both case, it doesn't work :
[Mystik_Cool] is offline   Reply With Quote
Old 02-02-03, 07:58 AM   #8
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

I'm giving up for the moment... It seems that when I change the XFree config in runlevel 3 (no X), and then try to come back to runlevel 5, the lib are not changed. (Before, I was doing everything with sax2, X running).
But then I get a nice black screen. With an error that I've already seen... Don't remember exactly, something about the display 0:0. I'll try to get the exact message and post it here.
[Mystik_Cool] is offline   Reply With Quote

Old 02-02-03, 08:25 AM   #9
[Mystik_Cool]
Registered User
 
Join Date: Feb 2003
Posts: 16
Default

Ok, here is the point :

Every lib and symlink seem to be correct. When I change everything without running sax2 and X, they remain correct. But when I want to start X, I have the error :

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

Even if I don't want to run glx (so impossible to run only with nvidia)
I'll try to look for some info about this...
[Mystik_Cool] is offline   Reply With Quote
Old 02-02-03, 08:45 AM   #10
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
libglx.so.1.0.4191: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), stripped
Correct ?
Seems to be OK, although it depends more on what was stripped.

I did find this on a SuSE admin-guide page, though -- maybe it helps?

Quote:
If you are installing with YaST2 for the first time, activate 3D support during installation, if the related YaST2 support is recognized. nVidia graphics chips are the only exception. For these, the ``dummy'' driver included must be replaced by the official nVidia driver. Use YaST Online Update (YOU) to update the NVIDIA_GLX and NVIDIA_kernel packages. If updating with YOU is not an option, download the appropriate RPM packages NVIDIA_GLX and NVIDIA_kernel from the nVidia web server (http://www.nvidia.com), install them with YaST2, and run the script switch2nvidia_glx.
Maybe it's as simple as that... maybe.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 09:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.