Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-12-06, 12:16 PM   #1
eleach
Registered User
 
Join Date: Mar 2006
Posts: 3
Default EN7800 GTX - X won't start on Ubuntu

I'm using Ubuntu. I uninstalled its driver and installed the nvidia 8756 driver. I let the installer do the config file. X will not start. Below are parts or the log file. Any advice appreciated.


(WW) NVIDIA: More than one matching Device section for instances
(BusID: PCI:3:0:0) found: NVIDIA Corporation NVIDIA Default Card
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
Skipping "/usr/X11R6/lib/modules/libfb.a:fbmmx.o": No symbols found
(II) Module fb: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 0.1.0
ABI class: X.Org Video Driver, version 0.7


(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "Monitor0, Monitor1"
(**) NVIDIA(0): Option "TwinView" "Yes"
(**) NVIDIA(0): Option "TwinViewOrientation" "RightOf"
(WW) NVIDIA(0): Option "MetaModes" requires an string value
(**) NVIDIA(0): Enabling RENDER acceleration
(WW) NVIDIA(0): No TwinView "MetaModes" specified; will fall back to Display
(WW) NVIDIA(0): SubSection modes.
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): ConnectedMonitor string: "Monitor0, Monitor1"
(WW) NVIDIA(0): Invalid ConnectedMonitor string token: "Monitor0"; discarding
(WW) NVIDIA(0): token.
(WW) NVIDIA(0): Invalid ConnectedMonitor string token: "Monitor1"; discarding
(WW) NVIDIA(0): token.
(II) NVIDIA(0): NVIDIA GPU GeForce 7800 GTX at PCI:3:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.70.02.11.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 7800 GTX at PCI:3:0:0:
(--) NVIDIA(0): Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-1)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 400 MHz maximum pixel clock
(--) NVIDIA(0): Samsung SyncMaster (CRT-1): 400 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Devices: CRT-0, CRT-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 2560 x 1024
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b]
[1] 0 0 0xc0000000 - 0xcfffffff (0x10000000) MX[b]
[2] 0 0 0xfd000000 - 0xfdffffff (0x1000000) MX[b]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xfeaf8000 - 0xfeafbfff (0x4000) MX[b]
[9] -1 0 0xfeaff800 - 0xfeafffff (0x800) MX[b]
[10] -1 0 0xfa8fc000 - 0xfa8fffff (0x4000) MX[b]
[11] -1 0 0xfa7f8000 - 0xfa7fbfff (0x4000) MX[b]
[12] -1 0 0xfa7ffc00 - 0xfa7ffc7f (0x80) MX[b]
[13] -1 0 0xfebfa000 - 0xfebfafff (0x1000) MX[b]
[14] -1 0 0xfebfb000 - 0xfebfbfff (0x1000) MX[b]
[15] -1 0 0xfebfc000 - 0xfebfcfff (0x1000) MX[b]
[16] -1 0 0xfebfd000 - 0xfebfdfff (0x1000) MX[b]
[17] -1 0 0xfebffc00 - 0xfebffcff (0x100) MX[b]
[18] -1 0 0xfebfe000 - 0xfebfefff (0x1000) MX[b]
[19] -1 0 0xfe9e0000 - 0xfe9fffff (0x20000) MX[b](B)
[20] -1 0 0xfc000000 - 0xfcffffff (0x1000000) MX[b](B)
[21] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[b](B)
[22] -1 0 0xfd000000 - 0xfdffffff (0x1000000) MX[b](B)
[23] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[24] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[25] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[26] 0 0 0x0000bc00 - 0x0000bc7f (0x80) IX[b]
[27] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[28] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[29] -1 0 0x0000a800 - 0x0000a8ff (0x100) IX[b]
[30] -1 0 0x00009c00 - 0x00009c7f (0x80) IX[b]
[31] -1 0 0x0000c480 - 0x0000c487 (0x8) IX[b]
[32] -1 0 0x0000c800 - 0x0000c80f (0x10) IX[b]
[33] -1 0 0x0000c880 - 0x0000c883 (0x4) IX[b]
[34] -1 0 0x0000cc00 - 0x0000cc07 (0x8) IX[b]
[35] -1 0 0x0000d000 - 0x0000d003 (0x4) IX[b]
[36] -1 0 0x0000d080 - 0x0000d087 (0x8) IX[b]
[37] -1 0 0x0000d400 - 0x0000d40f (0x10) IX[b]
[38] -1 0 0x0000d480 - 0x0000d483 (0x4) IX[b]
[39] -1 0 0x0000d800 - 0x0000d807 (0x8) IX[b]
[40] -1 0 0x0000d880 - 0x0000d883 (0x4) IX[b]
[41] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[42] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[b]
[43] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[b]
[44] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[b]
[45] -1 0 0x00000700 - 0x0000073f (0x40) IX[b]
[46] -1 0 0x00000600 - 0x0000063f (0x40) IX[b]
[47] -1 0 0x0000ec00 - 0x0000ec1f (0x20) IX[b]
[48] -1 0 0x0000bc00 - 0x0000bc7f (0x80) IX[b](B)
[49] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[50] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting


Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
eleach is offline   Reply With Quote
Old 05-12-06, 12:23 PM   #2
a12ctic
 
Join Date: Nov 2005
Location: Chicago IL
Posts: 2,371
Default Re: EN7800 GTX - X won't start on Ubuntu

uninstall the driver you just installed

Code:
sudo apt-get install nvidia-glx nvidia-settings linux-restricted-modules-`uname -r`
then back up your xorg configuration
Code:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
then open up xorg.conf
Code:
sudo nano /etc/X11/xorg.conf
then comment out dri and glcore with #'s
Code:
Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
#Load “GLcore”
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
then make sure nvidia is here
Code:
Section "Device"
Identifier "NVIDIA Corporation *your card name here*
[b]Driver "nvidia"[b] 
BusID "PCI:1:0:0"
then save it

i forget what you need to do to get the nv settings working, but thatll give you 3d, although the drivers will be a little outdated
__________________
AMD X2 5050 AMD Radeon HD 4830 AMD 780G 4GB OCZ DDR2 Antec 300 Fedora 11
a12ctic is offline   Reply With Quote
Old 05-12-06, 08:00 PM   #3
eleach
Registered User
 
Join Date: Mar 2006
Posts: 3
Default Re: EN7800 GTX - X won't start on Ubuntu

a12ctic -

You mean *install* the ones I just *uninstalled* ???

That is what your code says.

Will try. Thanks.
eleach is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Product Spotlight ' EVGA GTX 670 Review Round Up News GeForce GTX 670 Reviews 1 05-11-12 12:15 AM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
GALAXY Launches the GeForce GTX 670 and GTX 670 GC! News Archived News Items 0 05-10-12 09:28 AM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM

All times are GMT -5. The time now is 08:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.