Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-11-06, 02:47 PM   #1
peteruta
Registered User
 
Join Date: Feb 2004
Posts: 2
Default solaris 11 build 39

Has anyone gotten the Nvidia driver to work with opensolaris build 38 or 39?

It seems some x.org modules needed by Nvidia driver are now missing.

(EE) Failed to load module "Xst" (module does not exist, 0)
(EE) Failed to load module "xtsol" (module does not exist, 0)


Thanks

Peter
peteruta is offline   Reply With Quote
Old 05-13-06, 03:46 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: solaris 11 build 39

The NVIDIA X driver doesn't rely on these modules; please generate and attach a bug report log file if you have problems specific to the NVIDIA X driver.
zander is offline   Reply With Quote
Old 05-13-06, 11:39 AM   #3
gnutux
Linux User: 362616
 
Join Date: Oct 2005
Location: Toronto, Canada
Posts: 108
Default Re: solaris 11 build 39

have you double checked your /etc/X11/xorg.conf that you're using the nvidia driver and not the nv driver?

gnutux
__________________
Specs: AsusTek P4B533-VM, Intel Pentium 4 2533MHz, 120 GB HDD Maxtor, 80 GB HDD WD, 1GB PC3200 RAM, NVIDIA GeForce 6600, openSUSE 10.2 (Main), MacOS X 10.4.5 (leisure use, backup)
gnutux is offline   Reply With Quote
Old 05-14-06, 08:19 AM   #4
jpeg
Registered User
 
Join Date: May 2006
Posts: 1
Default Re: solaris 11 build 39

Quote:
Originally Posted by peteruta
Has anyone gotten the Nvidia driver to work with opensolaris build 38 or 39?
No problem with snv_38, but encountered a "hard" problem using snv_39. I will
try to go further tonight and let you see the result, if any.

Update #1: Commenting the line which load the GLX module (in the xorg.conf file)
do the trick here. FYI, here are the correponding error lines in the Xorg.0.log
file:
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

Update #2: Following the X Window mailing list about this problem, it seems that
this is a known problem already tracked. Here is the corresponding link with
a workaround in order to be able to use OpenGL (be careful not to break anything):
http://www.opensolaris.org/jive/thre...?threadID=8955

--
-jpeg.

Last edited by jpeg; 05-15-06 at 02:28 PM.
jpeg is offline   Reply With Quote
Old 06-02-06, 02:39 PM   #5
johnmartin
Registered User
 
Join Date: May 2005
Posts: 18
Default Re: solaris 11 build 39

A temporary fix has been integrated into build 41 under 6429418.
Until b41 is available, you will need to use the b38 /lib/ld.so.1 binary
as a workaround (or disable GLX in xorg.conf).
johnmartin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: High Schoolers Build Supercomputer in Ontario News Archived News Items 0 06-01-12 12:10 PM
Diablo 3 Wizard build guide News Archived News Items 0 05-30-12 02:40 PM
Build versus buy: One company's decision to go it alone News Archived News Items 0 05-13-12 08:40 PM
Diablo 3 build guide: Barbarian, Demon Hunter, Monk, Witch Doctor and Wizard News Archived News Items 0 05-12-12 12:00 PM
My source RPM won't build right! z28Power NVIDIA Linux 5 09-18-02 11:55 AM

All times are GMT -5. The time now is 05:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.