Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-03-06, 11:38 PM   #1
jaffsonying
Registered User
 
Join Date: Jun 2006
Posts: 5
Angry how can i disable the forcedeth in debian "etch"

i have install the driver downloaded from nvidia,and added the below words to /etc/modules
alias eth0 nvnet
alias forcedeth off
but it doesn't work at all
the driver is still forcedeth when i reboot again!
jaffsonying is offline   Reply With Quote
Old 06-04-06, 02:00 AM   #2
BashfulTux
Registered User
 
Join Date: Apr 2006
Posts: 147
Default Re: how can i disable the forcedeth in debian "etch"

Quote:
Originally Posted by jaffsonying
i have install the driver downloaded from nvidia,and added the below words to /etc/modules
alias eth0 nvnet
alias forcedeth off
but it doesn't work at all
the driver is still forcedeth when i reboot again!
/etc/modules is not where you should put it create a file /etc/modprobe.d/nvnet and put the alias eth0 nvnet in there then modprobe should see it when booting. Worse case rename/delete the forcedeth from the /lib/modules/'uname -r'/kernel/drivers/net/ directory using the output of the uname -r to find the correct directory name.
BashfulTux is offline   Reply With Quote
Old 06-04-06, 04:36 AM   #3
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: how can i disable the forcedeth in debian "etch"

if your system using hotplug for loading necessary modules as I do on my Debian installation you can prevent certain modules from loading by adding module name to: /etc/hotplug/blacklist

hope it helps.
sensovision is offline   Reply With Quote
Old 06-04-06, 05:32 AM   #4
jaffsonying
Registered User
 
Join Date: Jun 2006
Posts: 5
Angry Re: how can i disable the forcedeth in debian "etch"

i have done as BashfulTux's .but it still doesn't work
i have added the below words to /etc/modprobe/nvnet
alias eth0 nvnet
alias forcedeth off
besides , i also did this :
/lib/modules/2.6.15-1-486/kernel/drivers/net# rm forcedeth.ko
but when i reboot,it implys :
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.48.
eth0: forcedeth.c: subsystem: 01565:2501 bound to 0000:00:14.0
by the way,i input the below commands
debian:/home/jaffson# ifconfig
eth0 Link encap:Ethernet HWaddr AA:00:04:00:0A:04
i'm very sure the mac address is wrong.
my network card is nforce 410/430
jaffsonying is offline   Reply With Quote
Old 06-04-06, 05:40 AM   #5
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: how can i disable the forcedeth in debian "etch"

have you try to blacklist forcedeth module as I've suggested? As hotplug would use first module it would found...
if it doesn't help maybe you consider re-compiling kernel without this module?
sensovision is offline   Reply With Quote
Old 06-05-06, 12:32 AM   #6
jaffsonying
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: how can i disable the forcedeth in debian "etch"

i have done this.but it doesn't work too.
i formatted the disk last night. and now i use sarge.
it work better than etch.
can you tell me some forums address that talk about debian os specifily?
thank you!
jaffsonying is offline   Reply With Quote
Old 06-05-06, 01:42 AM   #7
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: how can i disable the forcedeth in debian "etch"

maybe your system use udev that's why blacklisting didn't work...

As for talking about Debian specific questions I can recommend http://forums.debian.net/ or I'd be glad to see you on our forums http://forum.weblamp.net/linux which isn't Debian specific but since me and few other folks use Debian based distros we may be able to help out each other.
sensovision is offline   Reply With Quote
Old 06-05-06, 09:02 AM   #8
jaffsonying
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: how can i disable the forcedeth in debian "etch"

yes,i'm sure it use udev.if unstall it, can i disabled forcedeth?
jaffsonying is offline   Reply With Quote

Old 06-05-06, 09:42 AM   #9
sensovision
Proud user of Debian OS
 
sensovision's Avatar
 
Join Date: Jun 2004
Location: Ukraine
Posts: 26
Send a message via ICQ to sensovision
Default Re: how can i disable the forcedeth in debian "etch"

Didn't have time to switch to Udev myself, but from what I know you can prevent udev from loading module by adding line like this blacklist forcedeth to:
/etc/modprobe.d/blacklist

Also make sure that you don't have forcedeth mentioned in /etc/modules

Please let me know if it helps.
sensovision is offline   Reply With Quote
Old 06-06-06, 05:26 AM   #10
jaffsonying
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: how can i disable the forcedeth in debian "etch"

it didn't work too!
i have not only done this ,but also edited the below files
/etc/modules
/etc/modules.conf
/etc/modutiles/arch/s390
/etc/modutiles/arch/s390x
/etc/modprobe.d/aliases
/etc/modprobe.d/blacklist
almost all the files that relate to the network have been changed.
but it didn't work
i think i will never use testing os from now on.
jaffsonying is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 09:27 PM
Debian Woody 3.0r0 and Problems with Geforce drivers vogt NVIDIA Linux 3 09-09-02 02:07 PM
nvidea drivers on 2.4.18 Debian (3.0 woody) thor NVIDIA Linux 2 08-20-02 02:51 PM

All times are GMT -5. The time now is 03:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.