Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-23-06, 05:05 PM   #1
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default ~x86-1.0-8762-pkg1.run -no screens

I am trying to get the NVIDIA-Linux driver to run on my PCLinuxOS.
The driver appears to load ok with no complaints. When I startx I get a few (EE)s at the tail end. I have enclosed the install. log and the xorg.conf file. If the bug file is needed I will reload the .run package and generate one.
Thanks in advance, G.
Attached Files
File Type: log Xorg.0.log (27.5 KB, 135 views)
File Type: log nvidia-installer.log (20.6 KB, 132 views)
TheGlitch is offline   Reply With Quote
Old 06-23-06, 05:13 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Based on the X log, it looks like you didn't request any Modes in your xorg.conf, but requested a virtual desktop of 1024x768. The driver usually falls back to providing 1280x1024 when no modes are requested, and the EDID for the display supports it.

Your choices are either reduce your virtual desktop size to 1024x768, remove the virtual desktop entry, or add a Mode entry for whichever mode you'd like to use.

If you have further questions or problems, please post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 06-23-06, 07:01 PM   #3
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Lonni,
Thanks for the quick reply. I ran the installer again and am getting the same errors.
I tried to figure out your last reply and it appears all of my virtual screens are set to 1024x768 with different colr depths. Itried the manual xorg.conf changes and it seemed to do more harm than good. I am not sure how to hard code 1024x768 into the screen1 or monitor1 area. Thats the best my 17" crt and eyes can tollerate.
I am enclosing the newest Xorg.0.log, nvidia-bug-report.log, and xorg.conf files.
Thanks in advance, G

xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon May 15 13:23:42 PDT 2006

# File generated by XFdrake.
# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "ServerLayout"
Identifier "layout1"
Screen "screen1" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "nvidia"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce 6800 (generic)"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "DPMS"
SubSection "Display"
Virtual 1024 768
Depth 8
EndSubSection
SubSection "Display"
Virtual 1024 768
Depth 15
EndSubSection
SubSection "Display"
Virtual 1024 768
Depth 16
EndSubSection
SubSection "Display"
Virtual 1024 768
Depth 24
EndSubSection
EndSection
Attached Files
File Type: log Xorg.0.log (27.5 KB, 112 views)
File Type: log nvidia-bug-report.log (91.3 KB, 122 views)
TheGlitch is offline   Reply With Quote
Old 06-23-06, 07:06 PM   #4
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

PS I forgot to mention the vidio adaptor is a 6200 AGP
TheGlitch is offline   Reply With Quote
Old 06-23-06, 08:20 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: ~x86-1.0-8762-pkg1.run -no screens

In your xorg.conf, change this
#########
SubSection "Display"
Virtual 1024 768
Depth 24
EndSubSection
#########

to this:
############
SubSection "Display"
Modes "1280x1024"
Depth 24
EndSubSection
############
netllama is offline   Reply With Quote
Old 06-23-06, 11:51 PM   #6
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Hi Netlama,
Close but no cigar. Itried what you suggested and got a screen that was about 2048xx768. I tried different resolutions in the tail section and none would start x at all. I commented the last virtual setting out and beleive it or not x starts at 1280x1024. In display settings they show in the KDE display as 1280x1024.
In the Control Center the desktop resolution shows as 800x600. ( Its 1280x1024) When I change it in the Control Center to 1024x768, x will not start again. Although the resolution is clear at 1280x 1024, I cant see the tube well enough to read without putting on strong reading glasses instead of the bi-focals. If I cant get the 1024x768 this driver is just an exercise in patience. The driver I'm using is ok but I would like to get some use out of the card. As it is the built in NV MX4 is just as good.
Thanks, George
TheGlitch is offline   Reply With Quote
Old 06-23-06, 11:58 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Please generate a new bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 06-24-06, 07:50 AM   #8
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

New bug report enclosed.
Thanks, G[
TheGlitch is offline   Reply With Quote

Old 06-24-06, 08:18 AM   #9
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Sorry.
Forgot to compress
thanks g
TheGlitch is offline   Reply With Quote
Old 06-24-06, 08:55 AM   #10
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

Here is the latest. I was gzipping and it would not upload.
Live and learn.
thanks, g
Attached Files
File Type: zip nvbuglog.zip (23.8 KB, 117 views)
TheGlitch is offline   Reply With Quote
Old 06-24-06, 09:36 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: ~x86-1.0-8762-pkg1.run -no screens

You didn't make the change that I recommended. All that I see is that you completely commented out the 24bit display subsection. If you want 1024x768, then specify that instead of 1280x1024. Please make the change that I specified, and if that fails to work, generate a new bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 06-24-06, 10:53 AM   #12
TheGlitch
Registered User
 
Join Date: Jun 2006
Posts: 11
Default Re: ~x86-1.0-8762-pkg1.run -no screens

1024x768 specified Its back to where it started. 1280 x 1024 dont work, 1024 x768 dont work. Commenting out the last 1024x768 works @ 1280x1024.
1024x768 bug report enclosed.
Thanks, g
Attached Files
File Type: log nvidia-bug-report.log (91.4 KB, 112 views)
TheGlitch is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.