Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-27-06, 06:38 PM   #1
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default nforce 2 and SuSe 10.1

heya!

can't seem to get my nforce drivers to install. it starts to build for my kernal, gets to 100% then displays that it didn't install properly. I'm sorta a newb as well (though I DID get this computers sound working just fine in SuSe 9.1), so I can't make head nor tail from this error.

(Note: I don't know how to recompile a kernal yet... if I need to do that, please include how.)

Thanks a ton in advance!

Code:
nforce-installer log file '/var/log/nvidia-nforce-installer.log'
creation time: Tue Jun 27 18:26:33 2006

option status:
  license pre-accepted      : false
  expert                    : false
  uninstall                 : false
  driver info               : false
  no precompiled interface  : false
  no ncurses color          : false
  no questions              : false
  silent                    : false
  Installer install prefix  : /usr
  kernel source path        : (not specified)
  net kernel install path   : (not specified)
  audio kernel install path : (not specified)
  proc mount point          : /proc
  ui                        : (not specified)
  tmpdir                    : /tmp

Using: nvidia-installer ncurses user interface
-> Found package NVIDIA audio driver for Linux-x86
-> Found package NVIDIA network driver for Linux-x86
-> Please select packages for installation:
   Selections:
   NVIDIA audio driver for Linux-x86 (1.0-7)
-> Starting install of NVIDIA audio driver for Linux-x86
-> Checking for loaded module nvsound
-> Checking for loaded module nvaudio
-> License accepted.
-> Skipping check for conflicting rpms.
-> /proc/version is Linux version 2.6.16.13-4-default (geeko@buildhost) (gcc
   version 4.1.0 (SUSE Linux)) #1 Wed May 3 04:53:23 UTC 2006
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.16.13-4-default/source'
-> Kernel output path: '/lib/modules/2.6.16.13-4-default/build'
-> Performing cc_version_check with CC="cc".
-> running command /usr/bin/grep "^PATCHLEVEL ="
   /lib/modules/2.6.16.13-4-default/source/Makefile | /usr/bin/cut -d " " -f 3
-> Kernel module filename is nvsound.ko
   Cleaning kernel module build directory.
   executing: 'cd ./nvsound/main; make clean'...
   rm -f *.ko *mod.* *.cmd nv*.o *~ core
-> Building kernel module:
   executing: 'cd ./nvsound/main; make module SYSSRC=/lib/modules/2.6.16.13-4-d
   efault/source SYSOUT=/lib/modules/2.6.16.13-4-default/build'...
   make -C /lib/modules/2.6.16.13-4-default/build \
   KBUILD_SRC=/usr/src/linux-2.6.16.13-4 \
   KBUILD_EXTMOD="/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main"
   -f /usr/src/linux-2.6.16.13-4/Makefile modules
   rm -rf /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_ver
   sions
   mkdir -p /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_v
   ersions
   make -f /usr/src/linux-2.6.16.13-4/scripts/Makefile.build obj=/tmp/selfgz163
   37/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main
     cc -Wp,-MD,/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.n
   valinux.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.1.0/include -
   D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.16.13-4/include -inclu
   de /usr/src/linux-2.6.16.13-4-obj/i386/default/include/linux/autoconf.h  -I/
   tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -Wundef -
   Wstrict-prototypes -Wno-trigraphs -Werror-implicit-function-declaration -fno
   -strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-poin
   ter -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i586 -mtune=gener
   ic -mregparm=3 -Iinclude/asm-i386/mach-default -I/usr/src/linux-2.6.16.13-4/
   include/asm-i386/mach-default -Wdeclaration-after-statement -Wno-pointer-sig
   n -I/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -Wim
   plicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpoi
   nter-arith -Wno-multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_CHAN
   GE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD
   _STR(nvalinux)"  -D"KBUILD_MODNAME=KBUILD_STR(nvsound)" -c -o /tmp/selfgz163
   37/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_nvalinux.o /tmp/selfgz16
   337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvalinux.c
   In file included from /usr/src/linux-2.6.16.13-4/include/linux/list.h:7,
                    from /usr/src/linux-2.6.16.13-4/include/linux/wait.h:23,
                    from include2/asm/semaphore.h:41,
                    from /usr/src/linux-2.6.16.13-4/include/linux/sched.h:20,
                    from /usr/src/linux-2.6.16.13-4/include/linux/module.h:10,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvalinux.c:19:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h: In function ‘prefetch
   _range’:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h:62: warning: pointer of 
   type ‘void *’ used in arithmetic
   In file included from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvalinux.c:25:
   include2/asm/io.h: In function ‘check_signature’:
   include2/asm/io.h:258: warning: wrong type argument to increment
     cc -Wp,-MD,/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.n
   vmixer.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.1.0/include -D
   __KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.16.13-4/include -includ
   e /usr/src/linux-2.6.16.13-4-obj/i386/default/include/linux/autoconf.h  -I/t
   mp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -Wundef -W
   strict-prototypes -Wno-trigraphs -Werror-implicit-function-de
   claration -fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-p
   ointer -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i586 -mtune=ge
   neric -mregparm=3 -Iinclude/asm-i386/mach-default -I/usr/src/linux-2.6.16.13
   -4/include/asm-i386/mach-default -Wdeclaration-after-statement -Wno-pointer-
   sign -I/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -
   Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -W
   pointer-arith -Wno-multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_C
   HANGE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBU
   ILD_STR(nvmixer)"  -D"KBUILD_MODNAME=KBUILD_STR(nvsound)" -c -o /tmp/selfgz1
   6337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_nvmixer.o /tmp/selfgz1
   6337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmixer.c
   In file included from /usr/src/linux-2.6.16.13-4/include/linux/list.h:7,
                    from /usr/src/linux-2.6.16.13-4/include/linux/wait.h:23,
                    from include2/asm/semaphore.h:41,
                    from /usr/src/linux-2.6.16.13-4/include/linux/sched.h:20,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvhw.h:29,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvmixer.c:14:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h: In function ‘prefetch
   _range’:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h:62: warning: pointer of 
   type ‘void *’ used in arithmetic
   In file included from /usr/src/linux-2.6.16.13-4/include/linux/dmapool.h:14,
                    from /usr/src/linux-2.6.16.13-4/include/linux/pci.h:558,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvhw.h:35,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvmixer.c:14:
   include2/asm/io.h: In function ‘check_signature’:
   include2/asm/io.h:258: warning: wrong type argument to increment
     cc -Wp,-MD,/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.n
   vmain.o.d  -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.1.0/include -D_
   _KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.16.13-4/include -include
   /usr/src/linux-2.6.16.13-4-obj/i386/default/include/linux/autoconf.h  -I/tmp
   /selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -Wundef -Wst
   rict-prototypes -Wno-trigraphs -Werror-implicit-function-declaration -fno-st
   rict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer -pipe -mso
   ft-float -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -mregparm=3
   -Iinclude/asm-i386/mach-default -I/usr/src/linux-2.6.16.13-4/include/asm-i38
   6/mach-default -Wdeclaration-after-statement -Wno-pointer-sign -I/tmp/selfgz
   16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main  -Wall -Wimplicit -Wreturn
   -type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno
   -multichar -Werror -O -MD -Wno-cast-qual -Wno-error -DNV_CHANGE_PAGE_ATTR_PR
   ESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nvmain)"  
   -D"KBUILD_MODNAME=KBUILD_STR(nvsound)" -c -o /tmp/selfgz16337/
   NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/.tmp_nvmain.o /tmp/selfgz16337/N
   FORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c
   In file included from /usr/src/linux-2.6.16.13-4/include/linux/list.h:7,
                    from /usr/src/linux-2.6.16.13-4/include/linux/wait.h:23,
                    from include2/asm/semaphore.h:41,
                    from /usr/src/linux-2.6.16.13-4/include/linux/sched.h:20,
                    from /usr/src/linux-2.6.16.13-4/include/linux/module.h:10,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvmain.c:27:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h: In function ‘prefetch
   _range’:
   /usr/src/linux-2.6.16.13-4/include/linux/prefetch.h:62: warning: pointer of 
   type ‘void *’ used in arithmetic
   In file included from /usr/src/linux-2.6.16.13-4/include/linux/dmapool.h:14,
                    from /usr/src/linux-2.6.16.13-4/include/linux/pci.h:558,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvhw.h:35,
                    from /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main/nvmain.c:29:
   include2/asm/io.h: In function ‘check_signature’:
   include2/asm/io.h:258: warning: wrong type argument to increment
   /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c: In fu
   nction ‘Nvaudio_mmap’:
   /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c:991: e
   rror: implicit declaration of function ‘remap_page_range’
   /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c: At to
   p level:
   /tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/nvmain.c:2191: 
   error: expected ‘)’ before string constant
   make[4]: *** [/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsound/main/n
   vmain.o] Error 1
   make[3]: *** [_module_/tmp/selfgz16337/NFORCE-Linux-x86-1.0-0310-pkg1/nvsoun
   d/main] Error 2
   make[2]: *** [modules] Error 2
-> Error.
ERROR: The NVIDIA kernel module was not created.
ERROR: Installation of the audio driver has failed.  Please see the file
       '/var/log/nvidia-nforce-installer.log' for details.  You may find
       suggestions on  fixing installation problems in the README available on
       the Linux driver download page at www.nvidia.com.
esrevni is offline   Reply With Quote
Old 06-27-06, 07:59 PM   #2
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

So I spent some time and saw that nvidia is no longer supporting newer distros for the nforce2 line.

I read that ALSA can be configured.. however I am running the digital output from the sound card to a reciever. I've tried a few suggestions but nothing seems to be working.

Has anyone a suggestion of how I would set it up? I'm currently running kernal 2.6.16.13-4-default if that helps.
esrevni is offline   Reply With Quote
Old 06-27-06, 10:49 PM   #3
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Ok... hours later and still no luck at all. here's what I've come up with from all my reading. Any suggestions would be GREATLY appreciated... it's been a real quiet last few days *chuckles*

In /etc/modprobe.conf:
Code:
###################
### Sound Stuff ###
###################

# ALSA portion
alias snd-card-0 snd-intel8x0
options snd-intel8x0 ac97_clock=47470
# OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
In ~/.asoundrc:
Code:
pcm.nforce-hw {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "nforce"
}

#0,0 is analog out (i.e. headphone socket on the shuttle), and 0,1 is
#spdif out.

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,1"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

ctl.nforce-hw {
type hw
card 0
}
here's my aplay outputs:

Code:
linux-j4rh:/home/esrevni # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 2: Intel ICH - IEC958 [NVidia nForce2 -                               IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
linux-j4rh:/home/esrevni # aplay
ALSA lib pcm_dmix.c:863:(snd_pcm_dmix_open) unable to open slave
aplay: main:547: audio open error: Device or resource busy
figured this may help too... a snippet from lsmod

Code:
dm_mod                 52584  0
nvidia               4548180  12
i2c_nforce2             6272  0
forcedeth              20612  0
shpchp                 39488  0
pci_hotplug            24372  1 shpchp
snd_intel8x0           30236  5
snd_ac97_codec         82848  1 snd_intel8x0
snd_ac97_bus            2176  1 snd_ac97_codec
snd_pcm                80136  4 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              20868  3 snd_seq,snd_pcm
snd_page_alloc          9608  2 snd_intel8x0,snd_pcm
nvidia_agp              7324  1
agpgart                28976  2 nvidia,nvidia_agp
i2c_core               19728  2 nvidia,i2c_nforce2
ns558                   4612  0
gameport               13960  2 ns558
snd_mpu401              8096  0
snd_mpu401_uart         6912  1 snd_mpu401
snd_rawmidi            23552  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          7948  4 snd_seq_dummy,snd_seq_midi,snd_seq,snd_rawmidi
snd                    51076  17 snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8672  3 snd
NOTE: This is a digital connection, not analog. Have it running from soundcard to my dolby digital reciever (I guess that's called SPDIF?)

Last edited by esrevni; 06-28-06 at 12:41 AM.
esrevni is offline   Reply With Quote
Old 06-28-06, 12:40 AM   #4
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

more info

Code:
esrevni@linux-j4rh:~> cat /proc/asound/devices
  2:        : timer
  3: [ 1- 0]: raw midi
  4: [ 1]   : control
  5: [ 0- 2]: digital audio playback
  6: [ 0- 1]: digital audio capture
  7: [ 0- 0]: digital audio playback
  8: [ 0- 0]: digital audio capture
  9: [ 0]   : control
 10:        : sequencer
esrevni is offline   Reply With Quote
Old 06-28-06, 11:39 AM   #5
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Well, I've wasted over 12 hours on this problem. Time for another solution.

Can anyone suggest a spu for a PCI slot that is easy to get working in linux/supported? Note that I'm using SPDIF output to a digital receiver.

Greatly appreciated folks!
esrevni is offline   Reply With Quote
Old 06-28-06, 04:16 PM   #6
Zerocool
Registered User
 
Join Date: Mar 2005
Posts: 77
Default Re: nforce 2 and SuSe 10.1

Creative AudigyZS has had excellent detection on on Suse10.1, FC5 (which Im using now) and Ubuntu for me. Dont have to do anything, it just works. It doesnt have SPDIF though, all the audigys are well supported to my knowlegde.

http://www.alsa-project.org/alsa-doc...ve_Labs#matrix

I guess it does have spdif support ( It has a digital 1/8 jack, I always saw spdif as rca connection) Probably get a adapter for your amp though. Good luck
http://www.creative.com/products/pro...uct=4915&nav=2
Zerocool is offline   Reply With Quote
Old 06-28-06, 05:39 PM   #7
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Quote:
Originally Posted by Zerocool
Creative AudigyZS has had excellent detection on on Suse10.1, FC5 (which Im using now) and Ubuntu for me. Dont have to do anything, it just works. It doesnt have SPDIF though, all the audigys are well supported to my knowlegde.

http://www.alsa-project.org/alsa-doc...ve_Labs#matrix

I guess it does have spdif support ( It has a digital 1/8 jack, I always saw spdif as rca connection) Probably get a adapter for your amp though. Good luck
http://www.creative.com/products/pro...uct=4915&nav=2

Thanks a ton for the information, I appreciate it a lot. I shall look into buying one of those.
Cheers!
esrevni is offline   Reply With Quote
Old 06-29-06, 10:19 PM   #8
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1 *FIXED!*

Hopefully this will help anyone else that has severe issues getting SPDIF working.

NOTE: This is still not a complete fix... many sound applications still are not working as they require OSS. The OSS emulation DOES NOT and will not work due to the SPDIF being device 2 (oss emulation only handles devices 0 and 1) unless you're one of the lucky folk who happen to have your device set to 0 or 1. If any has information on how to set up OSS with SPDIF, kindly message me

First, make sure you have the newest ALSA available and run the following as root:

# alsaconf

Follow the simple instructions, when it asks if you want modprobe.conf to be set up, select yes.

Now, go back into a shell:

# cat /proc/asound/oss/sndstat

Make sure you have something along the following there:

Code:
Installed drivers:
Type 10: ALSA emulation

Card config:
NVidia nForce2 with ALC650E at 0xe4081000, irq 193
MPU-401 UART at 0x330, irq 10
If you don't, make double sure you have aoss and alsa installed.

next:

# cat /proc/asound/cards

this will list your card(s). make a note of which card you want to be configured as your main sound card. (usually will be 0). then:

# cat /proc/asound/pcm

Look for the device here that has either IEC958 or spdif, you'll want to pay attention to the second set of numbers. That identifies the device number.

In my example, device 2 is my digital out:
Code:
 linux-j4rh:/usr/include # cat /proc/asound/pcm
00-02: Intel ICH - IEC958 : NVidia nForce2 - IEC958 : playback 1 <<<------ this one!
00-01: Intel ICH - MIC ADC : NVidia nForce2 - MIC ADC : capture 1
00-00: Intel ICH : NVidia nForce2 : playback 1 : capture 1
Alright, now that we've got that all figured out, do the following to create a profile for ALSA to read:

# pico /etc/.asoundrc

and put the following:

Code:
pcm.nforce-hw {
type hw
card 0      #### Insert your card number from cat /proc/asound/cards
device 2   #### Insert your device number from cat /proc/asound/pcm
}

pcm.!default {
type plug
slave.pcm "nforce"
}

#0,0 is analog out (i.e. headphone socket on the shuttle), and 0,1 is
#spdif out.

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,2"            #### Insert card number, device number
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.nforce-hw {
type hw
card 0        #### Insert your card number from cat /proc/asound/cards
device 2    #### Insert your device number from cat /proc/asound/pcm
}
Nearly done!!

Now you'll need to configure all your sound programs (xmms, xine, etc) to run ALSA. You'll see a setting for PCM (sometimes called audio device). You'll want to set it as follows:

hw:0,2

where the first number is your card number, second is device number.

NOTE: This is for my setup using an A7N8X Deluxe. Your milage may vary but this should theoretically work for most other cards.

Hope this helps someone!!
esrevni is offline   Reply With Quote

Old 07-09-06, 01:38 AM   #9
cjspinelli
Registered User
 
Join Date: Feb 2005
Posts: 10
Thumbs down Re: nforce 2 and SuSe 10.1

Thanks for the help! I actually got sound out of my Asus A7N8X Deluxe in SUSE 10.1, YEAH!!! I am using Xine with the extended options selected. I am not getting digital output though, only stereo. I have a coaxial cable going from my mother board to a Cambridge SoundWorks DTT3500 decoder (5.1 surround). I have put "hw:0,2" in pretty much every place I could in Xine. Any thoughts?
__________________
Chris Spinelli

Home built rig:
Asus A7N8X Deluxe (nForce2)
AMD Athlon 3200+
nVIDIA GeForce 7800 GS (256 MB e-GeForce)
WD Raptor 74 GB
2.0 GB Corsair XMS
SuSE 10.1 / XP Pro
cjspinelli is offline   Reply With Quote
Old 07-09-06, 03:37 PM   #10
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Quote:
Originally Posted by cjspinelli
Thanks for the help! I actually got sound out of my Asus A7N8X Deluxe in SUSE 10.1, YEAH!!! I am using Xine with the extended options selected. I am not getting digital output though, only stereo. I have a coaxial cable going from my mother board to a Cambridge SoundWorks DTT3500 decoder (5.1 surround). I have put "hw:0,2" in pretty much every place I could in Xine. Any thoughts?
I'm still trying to figure out the 5.1 myself... I'm still doing a little tweaking here and there.

Is your center channel working? if not, use
$ alsamixer
or
$ alsamixergui
and find where the center channel is, unmute it, and adjust according to your tastes

As for the 5.1, once I get it working, I shall post it here. I've got a few things to try when I find the time.
I'm also trying to get the multi-channel thing working (I think that's the term... i.e. play xmms music at the same time as a cedega game), more on that as I figure it out.

Last edited by esrevni; 07-09-06 at 05:00 PM.
esrevni is offline   Reply With Quote
Old 07-09-06, 05:17 PM   #11
cjspinelli
Registered User
 
Join Date: Feb 2005
Posts: 10
Post Re: nforce 2 and SuSe 10.1

No I am not getting any sound out of my center channel. I used alsamixer and the volume under the "Center" is 100% and not muted. I also discovered lastnight something interesting while configuring Amarok with the Xine engine:

In Amarok 1.4.1-beta1 I went to

Settings -> Configure Amarok. . . -> Engine

In the top pull down menu I selected the "Xine enigne" as the Sound System. There are four options under "ALSA Device Configuration"
Mono:
Stereo:
4 Channels:
6 Channels:

I started off by putting "hw:0,2" in the "6 Channels" spot. When I tried to play the example file I got the following the error:
"Audio Output Unavailable; the device is busy"

When I put "hw:0,2" in the stereo, I got sound from my front left and front right speakers, just like the actual Xine player.

Based on your previous postings it made it sound like you got the digital output to work. But then you said you still haven't gotten 5.1 to work? I was a little confused by that statement.

The Cambridge SoundWorks DTT3500 decoder I am using has a green light at the bottom of the unit that illuminates when it senses a digital signal. With the old nVIDIA drivers that light was always on from startup, and the 5.1 sound worked great. However, it has never come on, even when I get the stereo sound. Just thought you might like to know. Thanks again for your help, it is great to have sound back even if it is only stereo.

PS - I really wish nVIDIA would make a new nFORCE driver, or at least give a detailed step-by-step instruction manual on how to get digital audio with the nForce 2, SoundStorm chipset. In every post I read about this problem, the wonderful advice from the nVIDIA representative is to "use the built in audio framework in the current kernel for sound." Well great, how about a little more help! Anyway, I am rambling now...
__________________
Chris Spinelli

Home built rig:
Asus A7N8X Deluxe (nForce2)
AMD Athlon 3200+
nVIDIA GeForce 7800 GS (256 MB e-GeForce)
WD Raptor 74 GB
2.0 GB Corsair XMS
SuSE 10.1 / XP Pro
cjspinelli is offline   Reply With Quote
Old 07-09-06, 06:17 PM   #12
esrevni
Registered User
 
Join Date: Apr 2005
Posts: 11
Default Re: nforce 2 and SuSe 10.1

Quote:
PS - I really wish nVIDIA would make a new nFORCE driver, or at least give a detailed step-by-step instruction manual on how to get digital audio with the nForce 2, SoundStorm chipset. In every post I read about this problem, the wonderful advice from the nVIDIA representative is to "use the built in audio framework in the current kernel for sound." Well great, how about a little more help! Anyway, I am rambling now...
Yeah, I made the exact same gripe elsewhere heh

Quote:
Originally Posted by cjspinelli
No I am not getting any sound out of my center channel. I used alsamixer and the volume under the "Center" is 100% and not muted. I also discovered lastnight something interesting while configuring Amarok with the Xine engine:

In Amarok 1.4.1-beta1 I went to

Settings -> Configure Amarok. . . -> Engine

In the top pull down menu I selected the "Xine enigne" as the Sound System. There are four options under "ALSA Device Configuration"
Mono:
Stereo:
4 Channels:
6 Channels:

I started off by putting "hw:0,2" in the "6 Channels" spot. When I tried to play the example file I got the following the error:
"Audio Output Unavailable; the device is busy"

When I put "hw:0,2" in the stereo, I got sound from my front left and front right speakers, just like the actual Xine player.

Based on your previous postings it made it sound like you got the digital output to work. But then you said you still haven't gotten 5.1 to work? I was a little confused by that statement.

The Cambridge SoundWorks DTT3500 decoder I am using has a green light at the bottom of the unit that illuminates when it senses a digital signal. With the old nVIDIA drivers that light was always on from startup, and the 5.1 sound worked great. However, it has never come on, even when I get the stereo sound. Just thought you might like to know. Thanks again for your help, it is great to have sound back even if it is only stereo.
Well, the way my reciever is setup, it show's the individual speakers... it's actually only showing stereo for me as well. I guess I should have clarified that a little, usually I have all the speakers lit up with the nforce drivers (when they worked).

Still trying to figure out how they set it up heh, glad to have another person doing the same chase. Will let you know as I make progress.
esrevni is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 03:30 PM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 12:19 PM
Newbie - Compiling my own for SuSe 8.0 jocephus19 NVIDIA Linux 5 09-01-02 10:38 PM
Suse 8.0 on Nforce - advice hastings NVIDIA Linux 3 08-25-02 05:27 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 01:31 PM

All times are GMT -5. The time now is 07:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.