Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-07-03, 04:51 PM   #1
sparhawk
Registered User
 
Join Date: Feb 2003
Posts: 4
Default Can't get NVIDIA_kernel to work on Suse 8.0 Prof

I just checked this board because I didn't succeed to install the NVIDIA drivers for Suse 8.0 Prof. The solutions I found so far didn't help.

I have a Elsa Gladiac Ultra 64MB (GF2 Ultra) and a Nokia 445XiPLus Monitor.

First I tried to use Yast Online Update which got me nvidia drivers 3193 (or somthing). When I installed them I couldn't get my configuration to work. So I decided to download the drivers from nvidia 4191.
I installed them with rpm and I got the error message that some files are conflicting so I removed all of the drivers and installed it again using rpm. This worked.
The problem is that when I run 3Ddiag it always says that:

Tests for package "NVIDIA_GLX":
package ... done.
package files ... done.
Tests for package "NVIDIA_kernel":
package ... done.
package files ... failed!
================================================== ==============
Some file(s) of package NVIDIA_kernel are missing/modified:
S.5....T /lib/modules/2.4.18-4GB/video/nvidia.o

Consider to reinstall the package NVIDIA_kernel!
================================================== ==============

Tests for correct OpenGL libraries/GLX extensions:
Symbolic Links ... done.
/etc/sysconfig/3ddiag (SCRIPT_3D=switch2nvidia_glx) ... done.

Test for correct XFree86 version ... done.

Tests for XFree86 configuration:
Config File /etc/X11/XF86Config ... done.
Driver ... done.
Color Depth ... failed!
================================================== ==============
3D Hardware acceleration is not used. To use 3D
Hardware acceleration please specify one of these entries

DefaultDepth 16

in the Section "Screen" of your /etc/X11/XF86Config.
================================================== ==============
Extensions ... done.
Options ... done.

----------------------- NOTE -----------------------------------
If 3D hardware OpenGL configuration is not stable enough, you
should switch back to 'Mesa Software Rendering'. You can
verify this configuration with the command "3Ddiag --mesasoft".
----------------------- NOTE -----------------------------------

Checking GLU/glut runtime configuration:
GLU ... done (package mesaglu)
glut ... done (package mesaglut)
-------------------------------------

Any ideas how I can fix that? Yast incorrectly determines my gfx card as a Bladerunner Geforce 2 GTS and it doesn't allow me to set my resolution at 1600x1200/24Bit/88Hz. It only allows 1600x1200/16Bit/88Hz. It doesn't give me any other resolutions of frequencies. Using Sax2 it correctly determines my gfxcard as a GF2Ultra but I can't go beyond 1280x1024.
When I try to erase the installation with rpm -e it tells me that package is not installed, but when I try to install it again it says it is already installed.
I'm totally confused at what that means and I have no experience with rpm either, so I absolutely have no idea what to do to get my card working in all the modes it supports and with a working OpenGL environment.

Any help would be gladly appreciated!
sparhawk is offline   Reply With Quote
Old 02-07-03, 05:30 PM   #2
LaoTzuTao
Registered User
 
Join Date: Sep 2002
Posts: 23
Send a message via AIM to LaoTzuTao
Default

I had the same problem...basically the rpms they provide, for some odd reason, never work...the only way I got them to work was to use the *src.rpms. I'm not sure how new you are to linux, I was very new when I first tried to get these drivers to work...but it was quite a pain until i realized the rpms just didn't work. If you understand how to install a src.rpm file, you should be all set...if not, post back and I can try to help...good luck!
LaoTzuTao is offline   Reply With Quote
Old 02-07-03, 05:36 PM   #3
sparhawk
Registered User
 
Join Date: Feb 2003
Posts: 4
Default

Quote:
Originally posted by LaoTzuTao
I had the same problem...basically the rpms they provide, for some odd reason, never work...the only way I got them to work was to use the *src.rpms. I'm not sure how new you are to linux, I was very new when I first tried to get these drivers to work...but it was quite a pain until i realized the rpms just didn't work. If you understand how to install a src.rpm file, you should be all set...if not, post back and I can try to help...good luck!
extracted the sources into my local directory with
rpm -ivh -root /root/src
then I compiled them and this seems ok because I get the nvidia.o file in /lib/modules/[kernel]/video
The problem still persists though. Using 3Ddiag gives the same result, using sax still doesn't allow me to select any resolution beyond 1280. I think that one problem seems to be that 3dinfo always thinks my card is a Bladerunner GTS.
I'm not really familiar with rpms so I might have done something worng, but I wouldn't know what that could be. I would be very gratefull for some instructions on how to set this up.
sparhawk is offline   Reply With Quote
Old 02-08-03, 10:33 AM   #4
LaoTzuTao
Registered User
 
Join Date: Sep 2002
Posts: 23
Send a message via AIM to LaoTzuTao
Default

Well first off I would go through and make absolutely sure NVIDIA_kernel is uninstalled, rpm -q NVIDIA_kernel to see if you have it installed anymore, and what version is installed, you might have more than one installed somehow, I'm not sure...do a search on your drive for nvidia.o and delete it anywhere it might be. Then once you've made sure there are no NVIDIA files installed...try reinstalling the NVIDIA files again. I'm not quite sure what you mean by "extracted the sources into my local directory with rpm -ivh -root /root/src then I compiled them " I've just never seen a command like that...what I did was just
'rpm --rebuild NVIDIA_kernel-1.0-4191.src.rpm'
That should go through and configure the package and create an actual normal rpm for you to install...It'll print out a few lines like a regular ./configure, so check a few lines up when its done for a line that says 'WROTE:' to see where it put the new rpm. For me with SuSE it was /usr/src/packages/RPMS/i386/ So assuming thats where it put the rpm, then do
'rpm -ivh /usr/src/packages/RPMS/i386/NVIDIA_kernel-1.0-4191.i386.rpm'
It should install fine, but print out a warning that it will taint the kernel, but that's fine. After that, do the same with the GLX package...
'rpm --rebuild NVIDIA_GLX-1.0-4191.src.rpm'
That should write it to the same directory, so next
'rpm -ivh /usr/src/packages/RPMS/i386/NVIDIA_GLX-1.0-4191.i386.rpm'
That should install fine also, it usually prints out a message like old glx files found, and it'll rename them for you, and if you ever uninstall the NVIDIA_GLX file it'll rename those old files and use them. After that, they should be installed correctly. Then you have to move on to editing your XF86Config file (should be in /etc/X11/) as the instructions say. You didn't mention doing that in your first post, It seems that might be part of the problem. I'll post the relevent parts of mine for you here...
Section "Module"
Load "freetype"
Load "extmod"
Load "type1"
Load "glx"
Load "speedo"
Load "v4l"
Load "dbe"
EndSection
Make sure you take out any 'dri' reference, and make sure 'glx' is in there

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection
As far as this section goes, for some reason you must set the default depth at 16 in order for 3D to be enabled. I can still set the depth to 32-bit in games and it doesn't seem to mind, but the default must be 16.

Section "Device"
BoardName "GeForce3 Ti 200"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "IgnoreEDID" "true"
Option "NvAGP" "3"
Option "DigitalVibrance" "200"
Screen 0
VendorName "NVidia"
EndSection
For this section, replace 'nv' with 'nvidia' to use the new nvidia driver, and that might be all you have to do. For me...It took me forever to realize, but for some reason I needed to add the
Option "IgnoreEDID" "true"
to get X working, I have an old Envision monitor which is never listed as an option, I'm not really sure why that is, but it works for me. The NvAGP is optional as far as I know, just to play around with different AGP settings. I add the DigitalVibrance option just to add some more vibrant color. There are other options listed in the NVIDIA_GLX readme, go through that and play around with what you want, but after all that everything should work fine...I hope after all that you can get it working...but if you have any more errors or questions I'll be around to help. Good luck! - John
LaoTzuTao is offline   Reply With Quote
Old 02-08-03, 01:50 PM   #5
sparhawk
Registered User
 
Join Date: Feb 2003
Posts: 4
Default

Thanks for your explanation. I did remove my drivers several time, but as you say, it seems that there are bits left of it. I used the tarball from nvidia and it seems that good rid of it properly. I couldn't install the tarball, though because it got more errors then previously, so I removed it again with yast2 and afterwards installed the rpms again (the one I had already installed and removed several times last night). Funny thing is that it suddenly worked. I don't understand why, for sure, because I removed it with Yast, I removed it manually and I tried to use the rpm for removing. I don't know why it suddenly works, but after that I tried 3Ddiag and it gave me nor more errors. I also checked with a OpenGL screensaver, which didn't work before, and this also worked, so it seems ok now. Thanks.
In the meantime I also "solved" my problem that I can't set resolutions beyond 1280. I manually reconfigured the modelines for 1600x1200 and this works now also. I just have to dig out what the modelines exactly means, because I currently have a frequency of 75Hz. My monitor supports up to 150Hz (800x600 and 640x480) and at least 87Hz in 1600. BUt currently every mode is in 75Hz so I need to see how I can change that.
That's the nice thing about linux. I can manually do something instead of having to rely on provided stuff.
sparhawk is offline   Reply With Quote
Old 02-08-03, 03:58 PM   #6
LaoTzuTao
Registered User
 
Join Date: Sep 2002
Posts: 23
Send a message via AIM to LaoTzuTao
Default

I dont know much about the modeline's either, I'm still learning about X configurations...but glad you got it mostly working!
LaoTzuTao is offline   Reply With Quote
Old 02-08-03, 04:47 PM   #7
sparhawk
Registered User
 
Join Date: Feb 2003
Posts: 4
Default

Quote:
Originally posted by LaoTzuTao
I dont know much about the modeline's either, I'm still learning about X configurations...but glad you got it mostly working!
By now I got it wokring as I want it. That's what I like about Linux. I don't have to rely completely on pre configured programs.
Well, every resolution now works at the frequency I want it to. Something I couldn't even do on Windows because there is a bug in W2K that prevents this.
sparhawk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 01:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 03:30 PM
DMA error (SuSE 8.0) Darkgod NVIDIA Linux 3 10-08-02 11:55 PM
SuSe 8.0 Problems. GaMMa NVIDIA Linux 19 09-26-02 07:51 AM
Suse 8.0 Dual display on Quadro 4 700XGL TheCowStir NVIDIA Linux 3 08-10-02 01:16 PM

All times are GMT -5. The time now is 10:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.