Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-06, 09:05 PM   #1
B. Williams
Registered User
 
Join Date: Jul 2006
Posts: 9
Default NForce Sound Drivers Fail to Load (Gentoo)

Greetings all.

I have recently assembled a new Gentoo desktop (kernel 2.6.16-gentoo-r9) based on the ASUS A8N-SLI Deluxe motherboard and an eVGA 7800GTX graphics card. The NVIDIA graphics drivers emerged fine after a bit of work, as did the NFORCE drivers for the network connection. However, the audio driver module fails to load with the following error:

Code:
   
ERROR: Unable to load the kernel module 'nvsound.ko'.  This is most likely
         because the kernel module was built using the wrong kernel source
         files.  Please make sure you have installed the kernel source files
         for your kernel; on Red Hat Linux systems, for example, be sure you
         have the 'kernel-source' rpm installed.  If you know the correct
         kernel source files are installed, you may specify the kernel source
         path with the '--kernel-source-path' commandline option.
I know that it isn't a problem with incorrect kernel sources, since the graphics and network drivers built on the same source.

In addition, the Gentoo standard ALSA drivers don't work... alsa-driver and alsa-utils emerge as expected, but alsaconf is unable to detect the device when it probes around. The Linux kernel detects it, however:
Code:
# lspci -v | grep -i audio

00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
So, my question is this: are the NForce drivers broken? If so, has anyone found a workaround to get sound on the chipset, or is there an anticipated replacement driver?

Regards,
Bradley Williams
Owner, BW Services
B. Williams is offline   Reply With Quote
Old 07-02-06, 11:41 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NForce Sound Drivers Fail to Load (Gentoo)

The NFORCE drivers are intenedd for kernels before 2.6.16. Kernel 2.6.16 and later already have support for the same hardware that the NFORCE driver supports.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-03-06, 08:56 PM   #3
B. Williams
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: NForce Sound Drivers Fail to Load (Gentoo)

Lonni,

I thank you for the prompt response. However, I still do not have ALSA support for my chipset. Is there a guide to configuring ALSA for this chipset, as (note my original post), alsaconf does not detect a chipset and therefore cannot configure one. If not, must I recompile my kernel with ALSA built-in to gain proper support for ALSA since no functional kernel module exists?

Regards,
Bradley Williams
Owner, BW Services
B. Williams is offline   Reply With Quote
Old 07-03-06, 09:06 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NForce Sound Drivers Fail to Load (Gentoo)

All 2.6.16 or later kernels include ALSA support for the same hardware that is included in the NFORCE driver. Unless there's something very unusual about Gentoo kernels, you should already have that support. I can say for certain that audio worked 'out of the box' on the Asus A8N-SLI Deluxe motherboard in FC5, SuSE-10.1, and Ubuntu's latest release.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-03-06, 10:39 PM   #5
B. Williams
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: NForce Sound Drivers Fail to Load (Gentoo)

Lonni,

indeed, my Gentoo kernel, when generated with genkernel, does not have support for niether ALSA nor the chipset by default. Once the kernel was recompiled with the proper support using the menuconfig in genkernel, however, ALSA works as expected.

Thank you for your help.

Regards,
Bradley Williams
Owner, BW Services
B. Williams is offline   Reply With Quote
Old 07-05-06, 10:07 PM   #6
B. Williams
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: NForce Sound Drivers Fail to Load (Gentoo)

To those looking for the exact steps that I used to compile proper support into the kernel, I have written a guide to in-kernel ALSA/NForce support, located here:

http://www.nvnews.net/vbulletin/showthread.php?t=72907

Regards,
Bradley Williams
Owner, BW Services
B. Williams is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 02:50 AM
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 09:34 PM
Cannot load nvaudio driver (NVidia nforce) thahn01 NVIDIA Linux 4 09-13-02 02:28 AM
Detonator Drivers (40.xx) and nForce. Philibob NVIDIA Windows Graphics Drivers 1 09-07-02 01:49 PM
nForce - BattleField 1942 demo - Sound cuts out rtz General Hardware 3 09-05-02 01:48 PM

All times are GMT -5. The time now is 01:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.