Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-22-06, 10:54 PM   #1
betatest04
Registered User
 
Join Date: Aug 2004
Location: Adelaide, Australia
Posts: 6
Default 1.0-8762, AMD64, 6.1-RELEASE/i386, glXMakeCurrent lockup

I appear to have a configuration which causes an interesting lockup problem :o(

In summary, glxinfo hangs itself after printing "name of display: :0.0". With a combination of ktrace and single-stepping through a debug version of glxinfo, it appears to be dropping into an infinite loop somewhere inside the glXMakeCurrent call, possibly in or around glXChannelRectSyncSGIX(). The ktrace result shows getpid() being called continuously.

My configuration:
. AMD64 X2 dual-core 4400+, 2GB RAM;
. Gigabyte K8NF-9 mb with WinFast PX7300 GS PCI-E card;
. 6.1-RELEASE/i386/SMP;
. 1.0-8762 driver, built with default settings;

I've tried various versions of the driver (8756, 8178, 8174), I've tried the GENERIC 6.1-RELEASE/i386, I've tried the GENERIC 5.5-RELEASE/i386 (with 8762), I've tried turning off all the threading options I could find (including PREEMPTION, and even setting __GL_SINGLE_THREADED, in case it had an effect)... all produced the same result: a hung glxinfo.

I should also say that glxinfo works quite happily when using a remote display, glxgears works on the local display, there are no error messages in /var/log/Xorg.0.log, and I'm occasionally getting "nvClipLock: client timed out, taking the lock" messages (if that makes a difference).

I have not yet started reflashing things (mb or card) -- both are "as new" from sealed packages.

Any thoughts? Zander?
betatest04 is offline   Reply With Quote
Old 06-27-06, 02:23 PM   #2
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: 1.0-8762, AMD64, 6.1-RELEASE/i386, glXMakeCurrent lockup

Did you disable FreeBSD's AGP driver in /boot/device.hints:

hint.agp.0.disabled="1"

Did glxinfo hang or was it the entire system?
Harvey Pooka is offline   Reply With Quote
Old 07-03-06, 04:22 AM   #3
betatest04
Registered User
 
Join Date: Aug 2004
Location: Adelaide, Australia
Posts: 6
Default Re: 1.0-8762, AMD64, 6.1-RELEASE/i386, glXMakeCurrent lockup

Yes, FreeBSD's AGP is disabled (``kldstat -v | grep agp'' returns nothing), and it is just glxinfo that hangs, _not_ the entire system.

Note that it hangs at the point just before it's about to report "Direct Rendering: yes/no", therefore I don't know whether it considers direct rendering to be on or off :-). I have tried the 8762 driver with the NvAGP flag set to 3 as well as 1 (no difference).

Also, I can run the Linux google-earth port with no problems (which I've been led to believe makes use of hardware acceleration for textures etc), I can run the OSG bluemarble demo with no problems (which wraps two 400Meg TIFF files around the planet), and I can also run the OSG demo suite as well (mainly because the OSG libraries do not seem to call glXMakeCurrent()).

It seems I can hammer the OpenGL fairly thoroughly, _except_ for this one call inside glxinfo, _on_ this particular configuration (glxinfo works okay as-is on my normal P3 box).
betatest04 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.