Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-12-06, 06:58 AM   #13
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

OK, heres my plan of action,

a) I'll put my backup of 2.6.16.20 back on
b) comment out screen1 in my xorg.conf
b) install the drivers with --force-tls=classic
c) try X
d) watch it fail
e) install the drivers with --force-tls=new
f) refer to c) and d)

I'll try this later on tonight

(it may be unrelated, but I noticed in /proc/interrupts I dont have an nvidia assigned to an IRQ, or sharing one) the PCI scan on X load doesnt show it, I know its dumb but maybe I'll reseat the card (again) too. I'll check the results of 'lspci' also.

thanks for your help
kernow is offline   Reply With Quote
Old 07-12-06, 07:02 AM   #14
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

@kernow: /proc/interrupts won't have an nvidia entry unless the device has been initialized, i.e. only when X is running.
zander is offline   Reply With Quote
Old 07-12-06, 07:03 AM   #15
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

Quote:
Originally Posted by zander
@kernow: /proc/interrupts won't have an nvidia entry unless the device has been initialized, i.e. only when X is running.
ok thanks for that, it was just something I noticed in the bug report.
kernow is offline   Reply With Quote
Old 07-13-06, 12:55 PM   #16
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default FIXED - new legacy drivers, my xorg is dead, black screen

oh my god, I'm in X

heres what I did.

.. actually .. all I did was install the nvidia drivers with --force-tls=classic.

very odd because I have done that before and it didnt work.

oh well, I can start slowly enabling options again now..


thanks zander, I'm hella grateful.

I'm going to post the URL of this thread over at linuxforums.org so it can aid anyone else.

until next time people. woo I get a chance to use this graemlin finally.
kernow is offline   Reply With Quote
Old 07-13-06, 01:05 PM   #17
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnut

No problem, it's good to hear that you were able to get the driver working properly on your system.
zander is offline   Reply With Quote
Old 07-13-06, 01:23 PM   #18
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

too right

its strange, I've got everything back the way I like it now in my xorg config and lilo config, dual head works fine, the only thing I have in my xorg.conf which is new, is NvAgp "0" .. , and I have GLX commented out.. when I substituted my very original xorg.conf it crashed just like normal. seems like its got to be one of those two options, or the classic tls library location.

thanks again anyway.
kernow is offline   Reply With Quote
Old 07-13-06, 01:58 PM   #19
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnut

@kernow: could you diff the two configuration files to see what differences there are, exactly? It shouldn't crash either way.
zander is offline   Reply With Quote
Old 07-13-06, 04:14 PM   #20
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

Sure, that was one of the first things I did.

I have my orignal config , and the one I've had to edit to get it to 'work' - I'll print the diff output here. pretty sure its only glx disabled and nvagp 0 though.
kernow is offline   Reply With Quote

Old 07-14-06, 01:10 PM   #21
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

kernow@ulysses(/etc/X11)$ diff xorg.conf xorg.conf.origbeforebroken > ~/Shared/diffresults


25c25
< # Load "glx"
---
> Load "glx"
86c86
< Option "NvAGP" "0"
---
> #Driver "nv"
210a211
>
kernow is offline   Reply With Quote
Old 08-10-06, 06:40 PM   #22
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

oh no, its happened again

all i did was compile 2.6.17.8 as I normally do, and install the legacy drivers, but i get the same old black screen thing again - argh

gonna try the things in this thread sigh
kernow is offline   Reply With Quote
Old 08-10-06, 07:10 PM   #23
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

fixed it, somehow, guess my machine doesnt like glx enabled anymore

seems this problem is going to re-occur every time i build a new kernel

woot! ?
kernow is offline   Reply With Quote
Old 08-10-06, 07:37 PM   #24
kernow
Registered User
 
Join Date: Jul 2006
Posts: 24
Default Re: new legacy drivers, my xorg is dead, black screen, no ssh , yeah that old chestnu

and now its frozen again, all i did was go from init 1 to init 4.

random as hell, it freezes every time, but unlike before the numlock LED still works this time, still can't SSH though.

I don't get how it was working just a minute ago and now it isnt , i havent even changed any settings, maybe my cards on the blink ;_;
kernow is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 11:17 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 12:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.