Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-10-06, 06:56 PM   #1
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Install driver 8762 - mission impossible

Hi All,
Sorry for my bad english, i am 40 years old Polish citizen and russian education .
In drivers NVidia is BIG Error, install is in kernel vanilia newly than 2.6.17 is impossible! I tested any patches found in Forum.
Info: with any ohter (oldest) kernel version this driver installed.
Error typical (deleted log, sorry): no kernel version found.
Any patchs tested. No effect. Compiled directly from /src/nv - nvidia.ko to modules properly, no after destroyed ALSA (kernel unknown version is... ect.).
Please help me.
Logs i include in a moment.

PS I user PVR card PV7000, support for this in kernel 2.6.18.rc1 - first
Atachments included. ALSA function properly in console (eg. mp123) to time include module nvidia.ko (manual). Installer - in log.

This is not sources problem. I installed from sources many times. Sources is properly in /usr/src/linux (link), linked in /lib/modules/{name kernel}/kernel/ ...
No any errors kernel compilation. Kernel version (manuallly edited): 2.6.18-rc1. Linux distro - Yoper.

Edit: I tested "in march" many versions kernels (2.6.10, 2.6.11, 2.6.1, 2.6.17, 26.17.4, 2.6.18-rc1) and many versions drivers NVidia (my card is GF5200U): 6629, 7167, 6111, 8762. OS Linux Yoper.
Effect: all installation sucsesfully, ALSA OK, no conflicts, zero boot errors, no problems with X.
But only kernels version >2.6.17 plus ANY NVidia graphics drivers - effects identical: "..Unable to determine the version of the kernel sources located in '/lib/modules/2.6.xxxx/source'.."

Maybe this is kernel error?

Greetings
Attached Files
File Type: zip nvidia-installer.zip (1.2 KB, 208 views)

Last edited by Lamus_PL; 07-10-06 at 08:35 PM.
Lamus_PL is offline   Reply With Quote
Old 07-11-06, 05:23 AM   #2
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: Install driver 8762 - mission impossible

Nvidia only launches updates for official stable kernel relaeses. This is not often.
I think the next driver release will have support for 2.6.18. New driver should be available in Autumn.

Update: Sometimes people post patches on this forum so be patient and wait till such people will install 2.6.18.

Last edited by zbiggy; 07-11-06 at 05:42 AM.
zbiggy is offline   Reply With Quote
Old 07-11-06, 06:33 AM   #3
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Re: Install driver 8762 - mission impossible

Thank You for any reply [mlody, madry Polak, ja, stary Cie Pozdrawiam].
I must wait for final kernel wersion.. But i installed Nvidia drivers in many testing (eg. x.x.x-rcx, 2.6.xx.x) kernels versions and ANY problems. Only need patch anymore.
Linux is big OS for me, is today is abstract, TV is ONLY for Winblows.
Thanks for this - "Prolink", i await drivers from 2003. Prolink from Taiwan (www.prolink.tw). Many money, no new drivers for PV-M2TV307PL (PV7000) in Winblows, no any support for Linux .

Sorry for any disturb.

Greetings
Lamus_PL is offline   Reply With Quote
Old 07-11-06, 06:35 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Install driver 8762 - mission impossible

@Lamus_PL: 1.0-8762 should build against current pre-release kernels provided you patch it with http://www.nvnews.net/vbulletin/showthread.php?t=72488; please attach the /var/log/nvidia-installer.log file if this doesn't work for you.
zander is offline   Reply With Quote
Old 07-11-06, 07:14 AM   #5
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Re: Install driver 8762 - mission impossible

OK, mister Zander. Thank You.
I test apply this patch (and NVIDIA_kernel-1.0-8762-1544019.diff.txt) previously.
Tested i this time. Log included.
Attached Files
File Type: zip nvidia-installer.zip (1.2 KB, 156 views)
Lamus_PL is offline   Reply With Quote
Old 07-11-06, 08:29 AM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Install driver 8762 - mission impossible

@Lamus_PL: judging from the log file, the installation fails before the actual compile step, the installer is unable to determine the kernel version based on the kernel source tree pointed to by /lib/modules/2.6.18-1/source; please make sure that `cc` is valid, that /lib/modules/2.6.18-1/source points to the correct source tree (should be the case if you ran `make modules_install`) and that this source tree hasn't been cleaned with `make mrproper` since the kernel was built. Please also make sure you run `nvidia-installer` directly after patching the driver, the .run package isn't updated.
zander is offline   Reply With Quote
Old 07-11-06, 08:52 AM   #7
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Re: Install driver 8762 - mission impossible

OK, mister Zander. After lunch (in Poland the time) packed driver reversly, and running it.
I tested pathes more times and only changed kernel name
(in kernel "Makefile") "EXTRAVERSION = -rc1" to "EXTRAVERSION = -1".
All tests after compile by properly.
I copied by links files (/usr/src/ <-> /lib/modules/2.6.18-1) reversly, linked this - no any errors found.
Disturbed me only one line in me file .config, previously not found:
-------
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config"
-------
This line created automatically after kernel compile.
"$UNAME_RELEASE" not changed (!) after restart in new kernel. ("$UNAME_RELEASE" not found!" in start console)
I thinking...

Big Thank You and sorry for my "english"
Lamus_PL is offline   Reply With Quote
Old 07-15-06, 08:05 AM   #8
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Re: Install driver 8762 - mission impossible

Hi all,

I tested driver packed, unpacked, patched for any found patch for it. I buy new (for me) Nvidia card (Sparkle GF6600).
Any test results is: kernel 2.6.17.5 - instalation 8752 OK, but kernel 2.6.18-rc1 - "..Unable to determine the version of the kernel sources located in '/lib/modules/2.6.xxxx/source'.."

Please, Nvidia, help me.

Maybe any user from Poland me helped?
I dreaming for TV in Linux...
Lamus_PL is offline   Reply With Quote

Old 07-15-06, 10:25 AM   #9
Hannibal
#356906
 
Hannibal's Avatar
 
Join Date: Feb 2004
Location: Lodz, Poland
Posts: 24
Default Re: Install driver 8762 - mission impossible

Quote:
Originally Posted by Lamus_PL
Maybe any user from Poland me helped?
As you wish. Test patch I have included in this thread http://www.nvnews.net/vbulletin/showthread.php?t=72614 (last post)
__________________
Hannibal@Slackware-current
Hannibal is offline   Reply With Quote
Old 07-16-06, 10:49 AM   #10
Lamus_PL
Registered User
 
Join Date: Jul 2006
Posts: 6
Default Re: Install driver 8762 - mission impossible

@Hannibal

I apply this patch, log into console:
--------------------------
# cd '/usr/src/NVIDIA-Linux-x86-1.0-8762-pkg1'
# patch -p0 < nvidia-utsrelease.diff.txt
patching file usr/src/nv/conftest.sh
Hunk #1 FAILED at 346.
1 out of 1 hunk FAILED -- saving rejects to file usr/src/nv/conftest.sh.rej
------------------------------
But edit script conftest.sh manually (one line shift). Efect included in a moment.
:-(((
Attached Files
File Type: log nvidia-installer.log (7.3 KB, 123 views)
Lamus_PL is offline   Reply With Quote
Old 07-16-06, 12:48 PM   #11
Hannibal
#356906
 
Hannibal's Avatar
 
Join Date: Feb 2004
Location: Lodz, Poland
Posts: 24
Default Re: Install driver 8762 - mission impossible

You should try other -p patch options (i.e. -p1), and patch should be apply cleanly.

My patch fix only kernel version detection, witch is now work fine according your log. This compilation errors is now job for Nvidia guys (BTW did you apply Zander's patch ?).
__________________
Hannibal@Slackware-current
Hannibal is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 09:27 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
How to install my nvdia driver... danyal_r NVIDIA Linux 2 10-11-02 01:06 PM
Getting bizarre errors with driver install clutch NVIDIA Linux 1 09-14-02 10:53 PM
NVIDIA driver doesn't install successfully on RH 7.3 Sunni NVIDIA Linux 3 08-28-02 03:30 PM

All times are GMT -5. The time now is 02:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.